summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-10-05 00:00:37 +0200
committerMartin Väth <martin@mvath.de>2017-10-05 00:00:37 +0200
commitff6d89e34e2610b2abff07b6fadb7a77eb0393e9 (patch)
tree6ea05ab5ea8cb3972001c0a4a2a6bff2b0ea02e2
parentapp-shells/termcolors-mv: Version bump. Add USE=poor (diff)
downloadmv-ff6d89e34e2610b2abff07b6fadb7a77eb0393e9.tar.gz
mv-ff6d89e34e2610b2abff07b6fadb7a77eb0393e9.tar.bz2
mv-ff6d89e34e2610b2abff07b6fadb7a77eb0393e9.zip
media-tv/w_scan: Add patch to force plp_id=0
-rw-r--r--media-tv/w_scan/files/plp_id.patch14
-rw-r--r--media-tv/w_scan/metadata.xml6
-rw-r--r--media-tv/w_scan/w_scan-20170107-r1.ebuild (renamed from media-tv/w_scan/w_scan-20170107.ebuild)7
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--profiles/use.local.desc1
5 files changed, 27 insertions, 3 deletions
diff --git a/media-tv/w_scan/files/plp_id.patch b/media-tv/w_scan/files/plp_id.patch
new file mode 100644
index 00000000..3f6f9ec5
--- /dev/null
+++ b/media-tv/w_scan/files/plp_id.patch
@@ -0,0 +1,14 @@
+Martin Väth <martin@mvath.de>:
+It seems that for DVB-T2 the plp_id always has to be 0.
+At least, this value seems to be correct for a Sundtek TV card in Rostock.
+--- 1/descriptors.c
++++ 1/descriptors.c
+@@ -1013,7 +1013,7 @@
+ // descriptor_tag 8 uimsbf
+ descriptor_length = buf[1]; // descriptor_length 8 uimsbf
+ //descriptor_tag_extension = buf[2]; // descriptor_tag_extension 8 uimsbf
+- t->plp_id = buf[3]; // plp_id 8 uimsbf; uniquely identifies the PLP carrying this TS within the T2 system.
++ t->plp_id = 0;//buf[3]; // plp_id 8 uimsbf; uniquely identifies the PLP carrying this TS within the T2 system.
+ t->system_id = get_u16(buf + 4); // T2_system_id 16 uimsbf; uniquely identifies the T2 system within the network, two T2 systems with same T2_system_id && network_id ire identical, except that cell_id may differ..
+ if ((t->extended_info = (descriptor_length > 4))) { // has extension
+ switch (buf[6] >> 6) { // SISO/MISO 2 bslbf (Multiple-Input Single-Output)
diff --git a/media-tv/w_scan/metadata.xml b/media-tv/w_scan/metadata.xml
index 49fd40c5..b1707910 100644
--- a/media-tv/w_scan/metadata.xml
+++ b/media-tv/w_scan/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>hd_brummy@gentoo.org</email>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
</maintainer>
+ <use>
+ <flag name="plp-id-zero">Apply experimental patch to force plp_id to 0 for DVB-T2. Seems to be necessary at least with some tuners in some regions</flag>
+ </use>
</pkgmetadata>
diff --git a/media-tv/w_scan/w_scan-20170107.ebuild b/media-tv/w_scan/w_scan-20170107-r1.ebuild
index f453db0d..e9c96443 100644
--- a/media-tv/w_scan/w_scan-20170107.ebuild
+++ b/media-tv/w_scan/w_scan-20170107-r1.ebuild
@@ -10,11 +10,16 @@ SRC_URI="http://wirbel.htpc-forum.de/w_scan/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
+IUSE="doc examples +plp-id-zero"
DEPEND=">=virtual/linuxtv-dvb-headers-5.8"
RDEPEND=""
+src_prepare() {
+ use plp-id-zero && eapply "${FILESDIR}"/plp_id.patch
+ default
+}
+
src_install() {
emake DESTDIR="${ED}" install
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index f42fde5c..6a580680 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -77,7 +77,7 @@ media-libs/avidemux-core 2.6.20-r1 2.7.0: Core libraries for media-video/avidemu
media-libs/avidemux-plugins 2.6.20 2.7.0: Plugins for media-video/avidemux
media-tv/nvtv 0.4.7-r3: TV-Out for NVidia cards
media-tv/sundtek-tv 171002.031615: Sundtek MediaTV Pro III Drivers
-media-tv/w_scan 20170107: Scan for DVB-C/DVB-T/DVB-S channels without prior knowledge of frequencies and modulations
+media-tv/w_scan 20170107-r1: Scan for DVB-C/DVB-T/DVB-S channels without prior knowledge of frequencies and modulations
media-video/avidemux 2.6.20 2.7.0-r1: Video editor designed for simple cutting, filtering and encoding tasks
media-video/avinfo 1.0_alpha15_p1: Utility for displaying AVI information
media-video/video-mv 12.0: Frontends for using mplayer/mencoder, ffmpeg/libav, or tzap as video recorder
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index feea9526..ff03b2f3 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -171,6 +171,7 @@ media-libs/avidemux-plugins:x265 - Enables HEVC support with media-libs/x265.
media-tv/sundtek-tv:ld-preload-env - Install LD_PRELOAD in /etc/env.d/50sundtek-tv
media-tv/sundtek-tv:ld-preload-file - Install /etc/ld.so.preload
media-tv/sundtek-tv:pax_kernel - Mark package which is necessary if you use a PAX kernel
+media-tv/w_scan:plp-id-zero - Apply experimental patch to force plp_id to 0 for DVB-T2. Seems to be necessary at least with some tuners in some regions
media-video/avidemux:nvenc - Adds support for NVIDIA Encoder (NVENC) API for hardware accelerated encoding on NVIDIA cards.
net-dns/noip-updater:ezipupd - Use user/group ezipupd instead of nobody: Useful if you restrict outgoing network traffic for user nobody
net-libs/wvstreams:boost - Use dev-libs/boost to provide TR1-compatible functional interface. This USE flag is only needed with GCC earlier than version 4.1, or with other compilares not providing said interface.