summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2017-09-05 09:40:19 +0200
committerMartin Väth <martin@mvath.de>2017-09-05 09:40:19 +0200
commit7cd72126b9375849a059d28c7173cfc1067dd770 (patch)
treecc8094dca3ba4417395e22970eda518b84b2690b /app-portage/eix/eix-0.33.1_alpha4.ebuild
parentapp-shells/termcolors-mv: Version bump (diff)
downloadmv-7cd72126b9375849a059d28c7173cfc1067dd770.tar.gz
mv-7cd72126b9375849a059d28c7173cfc1067dd770.tar.bz2
mv-7cd72126b9375849a059d28c7173cfc1067dd770.zip
app-portage/eix: Turn error check into a warning, only
Diffstat (limited to 'app-portage/eix/eix-0.33.1_alpha4.ebuild')
-rw-r--r--app-portage/eix/eix-0.33.1_alpha4.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/app-portage/eix/eix-0.33.1_alpha4.ebuild b/app-portage/eix/eix-0.33.1_alpha4.ebuild
index 0c5ce679..ce1f280d 100644
--- a/app-portage/eix/eix-0.33.1_alpha4.ebuild
+++ b/app-portage/eix/eix-0.33.1_alpha4.ebuild
@@ -52,13 +52,13 @@ pkg_setup() {
then for i in /usr/*/binutils-bin/lib/bfd-plugins/liblto_plugin.*
do test -h "$i" && return
done
- eerror "app-portage/eix[meson strong-optimization]' needs linker lto plugin."
- eerror "To establish this plugin, execute as root something like"
- eerror " mkdir -p /usr/*/binutils-bin/lib/bfd-plugins"
- eerror " cd /usr/*/binutils-bin/lib/bfd-plugins"
- eerror " ln -sfn /usr/libexec/gcc/*/*/liblto_plugin.so.*.*.* ."
- eerror "The * might have to be replaced by your architecture or gcc version"
- die "app-portage/eix[meson strong-optimization] needs linker lto plugin"
+ ewarn "app-portage/eix[meson strong-optimization]' might fail to"
+ ewarn "emerge (link) without the linker lto plugin."
+ ewarn "To establish this plugin, execute as root something like"
+ ewarn " mkdir -p /usr/*/binutils-bin/lib/bfd-plugins"
+ ewarn " cd /usr/*/binutils-bin/lib/bfd-plugins"
+ ewarn " ln -sfn /usr/libexec/gcc/*/*/liblto_plugin.so.*.*.* ."
+ ewarn "The * might have to be replaced by your architecture or gcc version"
fi
}