summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2020-05-09 20:59:15 +0200
committerMartin Väth <martin@mvath.de>2020-05-09 20:59:15 +0200
commited218d791ccbbf68dafd30c24c737510c4f989fa (patch)
treebc57ff30af229a77ec5bda9df16a5431cc4bbb56 /app-portage/eix
parentdev-libs/osformat: Version bump (diff)
downloadmv-ed218d791ccbbf68dafd30c24c737510c4f989fa.tar.gz
mv-ed218d791ccbbf68dafd30c24c737510c4f989fa.tar.bz2
mv-ed218d791ccbbf68dafd30c24c737510c4f989fa.zip
app-portage/eix: Version bump
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/Manifest3
-rw-r--r--app-portage/eix/eix-0.33.12_alpha.ebuild172
-rw-r--r--app-portage/eix/eix-0.34.0.ebuild (renamed from app-portage/eix/eix-0.33.11.ebuild)5
-rw-r--r--app-portage/eix/eix-99999999.ebuild7
-rw-r--r--app-portage/eix/metadata.xml1
5 files changed, 11 insertions, 177 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index d013a707..77caaa65 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1 @@
-DIST eix-0.33.11.tar.xz 623256 SHA512 2829d1482abfe479ae71e8b00da07abe74ba3090ba2a3f9d9a93437cb2d4d64213968bcd6c082a6703ec1d9c36dfcfaa0850172f3ffd4d256f553b98eeaf29e6
-DIST eix-0.33.12_alpha.tar.gz 682053 SHA512 6f4ed30c21990663ae2514a8a85ee0b3968b5409b956946d97d78649e72110950b21bfd2ef4b756c2f2d64cfaf12f8e1dd350b5db772f37bcfaa2252d5a7187f
+DIST eix-0.34.0.tar.xz 626368 SHA512 4200e097f80486b3f8caf71fc1ac4e8496a97beb81a3688dc21bdd416b3c4d772af489fd48efc05e047fc65fe83fd52d690d3a581b4a5dc59e0e320cd5160b1e
diff --git a/app-portage/eix/eix-0.33.12_alpha.ebuild b/app-portage/eix/eix-0.33.12_alpha.ebuild
deleted file mode 100644
index 75b06c4a..00000000
--- a/app-portage/eix/eix-0.33.12_alpha.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2020 Martin V\"ath and others
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-WANT_LIBTOOL=none
-AUTOTOOLS_AUTO_DEPEND=no
-MESON_AUTO_DEPEND=no
-inherit autotools bash-completion-r1 meson tmpfiles
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-case ${PV} in
-99999999*)
- EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
- inherit git-r3
- SRC_URI=""
- KEYWORDS=""
- PROPERTIES="live";;
-*)
- RESTRICT="mirror"
- EGIT_COMMIT="6707bc479ca05aa7289ce2c9de6e5ca8e753d1d6"
- SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
-esac
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-
-LICENSE="GPL-2"
-SLOT="0"
-PLOCALES="de ru"
-IUSE="debug +dep doc +jumbo-build"
-for i in ${PLOCALES}; do
- IUSE+=" l10n_${i}"
-done
-IUSE+=" +meson nls optimization +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools usr-portage"
-
-DEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${DEPEND}
- >=app-shells/push-3.1
- >=app-shells/quoter-4.1"
-BDEPEND="meson? (
- >=dev-util/meson-0.41.0
- >=dev-util/ninja-1.7.2
- strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
- nls? ( sys-devel/gettext )
- )
- !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache="${EROOT}var/cache/${PN}"
- test -f "${old_cache}" && rm -f -- "${old_cache}"
-}
-
-src_prepare() {
- sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- default
- use meson || {
- eautopoint
- eautoreconf
- }
-}
-
-src_configure() {
- local i
- export LINGUAS=
- for i in ${PLOCALES}; do
- use l10n_${i} && LINGUAS+=${LINGUAS:+ }${i}
- done
- if use meson; then
- local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${P}"
- -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
- $(meson_use jumbo-build)
- $(meson_use sqlite)
- $(meson_use doc extra-doc)
- $(meson_use nls)
- $(meson_use tools separate-tools)
- $(meson_use security)
- $(meson_use optimization normal-optimization)
- $(meson_use strong-security)
- $(meson_use strong-optimization)
- $(meson_use debug debugging)
- $(meson_use swap-remote)
- $(meson_use prefix always-accept-keywords)
- $(meson_use dep dep-default)
- $(meson_use required-use required-use-default)
- $(meson_use src-uri src-uri-default)
- $(usex usr-portage -Dportdir-default=/usr/portage '')
- -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
- -Dportage-rootpath="${ROOTPATH}"
- -Deprefix-default="${EPREFIX}"
- )
- if use prefix; then
- emesonarge+=(
- -Deix-user=
- -Deix-uid=-1
- )
- fi
- meson_src_configure
- else
- local myconf=(
- $(use_enable jumbo-build)
- $(use_with sqlite)
- $(use_with doc extra-doc)
- $(use_enable nls)
- $(use_enable tools separate-tools)
- $(use_enable security)
- $(use_enable optimization)
- $(use_enable strong-security)
- $(use_enable strong-optimization)
- $(use_enable debug debugging)
- $(use_enable swap-remote)
- $(use_with prefix always-accept-keywords)
- $(use_with dep dep-default)
- $(use_with required-use required-use-default)
- $(use_with src-uri src-uri-default)
- $(use_with usr-portage portdir-default /usr/portage)
- --with-zsh-completion
- --with-portage-rootpath="${ROOTPATH}"
- --with-eprefix-default="${EPREFIX}"
- )
- if use prefix; then
- myconf+=(
- --with-eix-user=
- --with-eix-uid=-1
- )
- fi
- econf "${myconf[@]}"
- fi
-}
-
-src_compile() {
- if use meson; then
- meson_src_compile
- else
- default
- fi
-}
-
-src_test() {
- if use meson; then
- meson_src_test
- else
- default
- fi
-}
-
-src_install() {
- if use meson; then
- meson_src_install
- else
- default
- fi
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
-}
-
-pkg_postinst() {
- local obs="${EROOT}var/cache/eix.previous"
- if test -f "${obs}"; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
- tmpfiles_process eix.conf
-}
-
-pkg_postrm() {
- if [ -z "${REPLACED_BY_VERSION}" ]; then
- rm -rf -- "${EROOT}var/cache/${PN}"
- fi
-}
diff --git a/app-portage/eix/eix-0.33.11.ebuild b/app-portage/eix/eix-0.34.0.ebuild
index 1bc3f079..de7168b0 100644
--- a/app-portage/eix/eix-0.33.11.ebuild
+++ b/app-portage/eix/eix-0.34.0.ebuild
@@ -18,7 +18,7 @@ IUSE="debug +dep doc +jumbo-build"
for i in ${PLOCALES}; do
IUSE+=" l10n_${i}"
done
-IUSE+=" +meson nls optimization +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools usr-portage"
+IUSE+=" +meson nls optimization +protobuf +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools usr-portage"
DEPEND="nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
@@ -30,6 +30,7 @@ BDEPEND="meson? (
>=dev-util/ninja-1.7.2
strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
)
+ protobuf? ( dev-libs/protobuf )
app-arch/xz-utils
nls? ( sys-devel/gettext )"
@@ -56,6 +57,7 @@ src_configure() {
-Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
$(meson_use jumbo-build)
$(meson_use sqlite)
+ $(meson_use protobuf)
$(meson_use doc extra-doc)
$(meson_use nls)
$(meson_use tools separate-tools)
@@ -85,6 +87,7 @@ src_configure() {
local myconf=(
$(use_enable jumbo-build)
$(use_with sqlite)
+ $(use_with protobuf)
$(use_with doc extra-doc)
$(use_enable nls)
$(use_enable tools separate-tools)
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index 75b06c4a..01de02df 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -32,7 +32,7 @@ IUSE="debug +dep doc +jumbo-build"
for i in ${PLOCALES}; do
IUSE+=" l10n_${i}"
done
-IUSE+=" +meson nls optimization +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools usr-portage"
+IUSE+=" +meson nls optimization protobuf +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools usr-portage"
DEPEND="nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
@@ -45,7 +45,8 @@ BDEPEND="meson? (
strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
nls? ( sys-devel/gettext )
)
- !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )"
+ !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )
+ protobuf? ( dev-libs/protobuf )"
pkg_setup() {
# remove stale cache file to prevent collisions
@@ -74,6 +75,7 @@ src_configure() {
-Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
$(meson_use jumbo-build)
$(meson_use sqlite)
+ $(meson_use protobuf)
$(meson_use doc extra-doc)
$(meson_use nls)
$(meson_use tools separate-tools)
@@ -103,6 +105,7 @@ src_configure() {
local myconf=(
$(use_enable jumbo-build)
$(use_with sqlite)
+ $(use_with protobuf)
$(use_with doc extra-doc)
$(use_enable nls)
$(use_enable tools separate-tools)
diff --git a/app-portage/eix/metadata.xml b/app-portage/eix/metadata.xml
index e242e61b..f59d4b2a 100644
--- a/app-portage/eix/metadata.xml
+++ b/app-portage/eix/metadata.xml
@@ -12,6 +12,7 @@
<flag name="jumbo-build">Compile faster and produce better binary. Recommended unless compiling on a quite memory-restricted system.</flag>
<flag name="meson">Build with meson instead of autotools. Faster but less compatible</flag>
<flag name="optimization">Accept upstream's choices for CXXFLAGS/LDFLAGS for optimization. Absense of this USE flag does not strip user's *FLAGS</flag>
+ <flag name="protobuf">Use dev-libs/protobuf to suport proto output with --proto</flag>
<flag name="required-use">Make REQUIRED_USE=true the default which enables support for REQUIRED_USE but requires more disk and memory.</flag>
<flag name="security">This adds some checks which can prevent certain exploits if e.g. the eix code has a bug. If you use the hardened toolchain, using this flag does not increase security and can even lead to problems.</flag>
<flag name="sqlite">Compile in support for portage's sqlite backend; to actually use it you need additional configuration of portage and eix</flag>