summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2016-08-05 11:29:08 +0200
committerMartin Väth <martin@mvath.de>2016-08-05 11:29:08 +0200
commit883575c2a9a5c6fb338840641d507d23a0dd2f34 (patch)
treed5b70e54be1fb503138cc58a8c5da5c9acba8264 /app-portage/etcat
parentapp-shells/schily-tools: bosh should work as /bin/sh after these patches! (diff)
downloadmv-883575c2a9a5c6fb338840641d507d23a0dd2f34.tar.gz
mv-883575c2a9a5c6fb338840641d507d23a0dd2f34.tar.bz2
mv-883575c2a9a5c6fb338840641d507d23a0dd2f34.zip
app-portage/etcat: New ebuild
Diffstat (limited to 'app-portage/etcat')
-rw-r--r--app-portage/etcat/etcat-99999999.ebuild34
-rw-r--r--app-portage/etcat/metadata.xml16
2 files changed, 50 insertions, 0 deletions
diff --git a/app-portage/etcat/etcat-99999999.ebuild b/app-portage/etcat/etcat-99999999.ebuild
new file mode 100644
index 00000000..22bd6af5
--- /dev/null
+++ b/app-portage/etcat/etcat-99999999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( pypy python2_7 python3_3 python3_4 python3_5 )
+EGIT_REPO_URI="git://github.com/proteusx/${PN}.git"
+inherit git-r3 python-single-r1
+
+DESCRIPTION="Updated version of an old Portage information extractor"
+HOMEPAGE="https://github.com/proteusx/etcat/"
+SRC_URI=""
+PROPERTIES="live"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="app-portage/gentoolkit[${PYTHON_USEDEP}]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ sed -i -e 's/ / /g' \
+ -e 's/^\(.*[ ]\)\?print \(.*\)$/\1print(\2)/' \
+ -e 's/^\(.*[ ]\)\?\(except .*\), \(.*\)$/\1\2 as \3/' \
+ -- "${S}/${PN}"
+ python_fix_shebang --force "${S}"
+ eapply_user
+}
+
+src_install() {
+ dobin "${PN}"
+}
diff --git a/app-portage/etcat/metadata.xml b/app-portage/etcat/metadata.xml
new file mode 100644
index 00000000..e4206648
--- /dev/null
+++ b/app-portage/etcat/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>proteuss@sdf.lonestar.org</email>
+ <name>Andreas Proteus</name>
+ </maintainer>
+ <bugs-to>https://github.com/proteusx/etcat/issues</bugs-to>
+ <remote-id type="github">proteusx/etcat</remote-id>
+ </upstream>
+</pkgmetadata>