summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-02-11 18:42:21 +0100
committerMartin Väth <martin@mvath.de>2018-02-11 18:42:21 +0100
commit37c578ede229976852b26df3ce7c19fcdb2d6818 (patch)
treef32b2ae920586a173415bb836dbac0ad7239ba1a /app-portage
parentdev-util/mv_perl: Version bump (diff)
downloadmv-37c578ede229976852b26df3ce7c19fcdb2d6818.tar.gz
mv-37c578ede229976852b26df3ce7c19fcdb2d6818.tar.bz2
mv-37c578ede229976852b26df3ce7c19fcdb2d6818.zip
app-portage/eix: Version bump
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/eix/Manifest2
-rw-r--r--app-portage/eix/eix-0.33.3_alpha20180211.ebuild (renamed from app-portage/eix/eix-0.33.2_alpha20180203.ebuild)14
-rw-r--r--app-portage/eix/eix-99999999.ebuild14
3 files changed, 27 insertions, 3 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 7ddcce1d..3f674a03 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1,2 @@
DIST eix-0.33.2.tar.xz 614192 SHA512 28ca4cc57e5c7ef81feb37fa90d598e681e192c442c7446c93a442908d2a9744340f7a93c71135ec3083fb85c48a65638c8929b6e1e632464132f4320225d637
-DIST eix-0.33.2_alpha20180203.tar.gz 673576 SHA512 82af01ae32e134a9d52dfb4f2f713170c4fc22586b9ef2c5bafc529ad9bcb1d7a9fb36ee2cd430310cd815cadcf1a761bf84660a93b6e6bfc04ab5e0bb825114
+DIST eix-0.33.3_alpha20180211.tar.gz 673969 SHA512 2e9d73c3a1e326976f0ee48229ca651ad60cca8554d2158c1486b34a8404cce0ddbe2084ec7031615451c9c3b8493a71dc0a251f76fbbae32f80957a6d8799c9
diff --git a/app-portage/eix/eix-0.33.2_alpha20180203.ebuild b/app-portage/eix/eix-0.33.3_alpha20180211.ebuild
index b2270870..215757f6 100644
--- a/app-portage/eix/eix-0.33.2_alpha20180203.ebuild
+++ b/app-portage/eix/eix-0.33.3_alpha20180211.ebuild
@@ -15,7 +15,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="d37ef09d8ed3532a15fe6788458576830bc14229"
+ EGIT_COMMIT="e15dad4cdecfd791db8b2f45e2f701983b660f1c"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -90,6 +90,12 @@ src_configure() {
-Dportage-rootpath="${ROOTPATH}"
-Deprefix-default="${EPREFIX}"
)
+ if use prefix; then
+ emesonarge+=(
+ -Deix-user=
+ -Deix-uid=-1
+ )
+ fi
meson_src_configure
else
local myconf=(
@@ -111,6 +117,12 @@ src_configure() {
--with-portage-rootpath="${ROOTPATH}"
--with-eprefix-default="${EPREFIX}"
)
+ if use prefix; then
+ myconf+=(
+ --with-eix-user=
+ --with-eix-uid=-1
+ )
+ fi
econf "${myconf[@]}"
fi
}
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index b2270870..215757f6 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -15,7 +15,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="d37ef09d8ed3532a15fe6788458576830bc14229"
+ EGIT_COMMIT="e15dad4cdecfd791db8b2f45e2f701983b660f1c"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -90,6 +90,12 @@ src_configure() {
-Dportage-rootpath="${ROOTPATH}"
-Deprefix-default="${EPREFIX}"
)
+ if use prefix; then
+ emesonarge+=(
+ -Deix-user=
+ -Deix-uid=-1
+ )
+ fi
meson_src_configure
else
local myconf=(
@@ -111,6 +117,12 @@ src_configure() {
--with-portage-rootpath="${ROOTPATH}"
--with-eprefix-default="${EPREFIX}"
)
+ if use prefix; then
+ myconf+=(
+ --with-eix-user=
+ --with-eix-uid=-1
+ )
+ fi
econf "${myconf[@]}"
fi
}