summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /app-shells/termcolors-mv
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'app-shells/termcolors-mv')
-rw-r--r--app-shells/termcolors-mv/Manifest1
-rw-r--r--app-shells/termcolors-mv/metadata.xml20
-rw-r--r--app-shells/termcolors-mv/termcolors-mv-3.11.ebuild48
3 files changed, 69 insertions, 0 deletions
diff --git a/app-shells/termcolors-mv/Manifest b/app-shells/termcolors-mv/Manifest
new file mode 100644
index 00000000..85b3f608
--- /dev/null
+++ b/app-shells/termcolors-mv/Manifest
@@ -0,0 +1 @@
+DIST termcolors-mv-3.11.tar.gz 7821 SHA256 d2938b2e6e9080782c71e355090cc1f14ada6fa43b8c5dd866422545603f4489 SHA512 c8784352f5d6652fe358ee65d5481cc146b8ee57a83b20f7af5a1a3864b17230244e03e8e6a60e9e65ac3323db3ad2a82b3621416dddf342399a73b848965fbe WHIRLPOOL a646b0b0c8961f826d3c578c24fc4528186da2240d112753906584aace574c5e682ed3520ce5c6c84014f9a0c6b4323ef0dcd9eca7998f6369c477b8e2c62d01
diff --git a/app-shells/termcolors-mv/metadata.xml b/app-shells/termcolors-mv/metadata.xml
new file mode 100644
index 00000000..afa70177
--- /dev/null
+++ b/app-shells/termcolors-mv/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/termcolors-mv</remote-id>
+ </upstream>
+ <use>
+ <flag name="create">Install DIR_COLORS-create perl script</flag>
+ <flag name="perl">Install 256colors perl script</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-shells/termcolors-mv/termcolors-mv-3.11.ebuild b/app-shells/termcolors-mv/termcolors-mv-3.11.ebuild
new file mode 100644
index 00000000..dddc447e
--- /dev/null
+++ b/app-shells/termcolors-mv/termcolors-mv-3.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+inherit eutils readme.gentoo
+
+DESCRIPTION="256colors sample script and dircolors configuration for standard or 256 colors"
+HOMEPAGE="https://github.com/vaeth/termcolors-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="create +perl"
+DEPEND="dev-lang/perl"
+RDEPEND="create? ( dev-lang/perl )
+perl? ( dev-lang/perl )"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="To use the colorschemes of ${PN} call
+ eval \"\`dircolors-mv\`\"
+e.g. in your bashrc; make sure that SOLARIZED (if desired)
+and DEFAULTS is set appropriately, see the documentation.
+For zsh, this happens if you use zshrc-mv"
+
+src_prepare() {
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
+ -e '1s"^#!/usr/bin/env perl$"#!'"${EPREFIX}/usr/bin/perl"'"' \
+ -- bin/* || die
+ epatch_user
+}
+
+src_compile() {
+ perl bin/DIR_COLORS-create
+}
+
+src_install() {
+ dodoc README
+ dobin bin/dircolors-mv
+ use create && dobin bin/DIR_COLORS-create
+ use perl && dobin bin/256colors
+ insinto /etc/dir_colors
+ doins DIR_COLORS*
+ readme.gentoo_create_doc
+}