summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2018-05-28 21:25:41 +0200
committerMartin Väth <martin@mvath.de>2018-05-28 21:25:41 +0200
commit466ca2896dccf6f30e331e339312d565507364de (patch)
treebcd23499ab5f2df7f9c21df55b4293f91b7611a7 /app-shells
parentapp-shells/fast-syntax-highlighting: New ebuild (diff)
downloadmv-466ca2896dccf6f30e331e339312d565507364de.tar.gz
mv-466ca2896dccf6f30e331e339312d565507364de.tar.bz2
mv-466ca2896dccf6f30e331e339312d565507364de.zip
app-shells/fast-syntax-highlighting: Version bump
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fast-syntax-highlighting/Manifest3
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.1.ebuild61
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.1_alpha20180528.ebuild (renamed from app-shells/fast-syntax-highlighting/fast-syntax-highlighting-0_alpha20180528.ebuild)0
3 files changed, 63 insertions, 1 deletions
diff --git a/app-shells/fast-syntax-highlighting/Manifest b/app-shells/fast-syntax-highlighting/Manifest
index d37f0f6e..e32992e6 100644
--- a/app-shells/fast-syntax-highlighting/Manifest
+++ b/app-shells/fast-syntax-highlighting/Manifest
@@ -1 +1,2 @@
-DIST fast-syntax-highlighting-0_alpha20180528.tar.gz 173583 SHA512 87caf8d2b287b3e9954edc1900127bf743110c2c839a94d0cd7d656622e9099371c01279a9c3e1461e2d3f294fb0b6d87ed950710014052de5c234d8a8546fed
+DIST fast-syntax-highlighting-1.1.tar.gz 173493 SHA512 d6b35b09d20cb43ab9d8ca1bd018cb4837e7f54fcd0dda6a63957f8b3e7021bf46ae30eaff5dc9533a717fce64aadf9aaa9a497cea968d498d3b22f48b8bd0f8
+DIST fast-syntax-highlighting-1.1_alpha20180528.tar.gz 173583 SHA512 87caf8d2b287b3e9954edc1900127bf743110c2c839a94d0cd7d656622e9099371c01279a9c3e1461e2d3f294fb0b6d87ed950710014052de5c234d8a8546fed
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.1.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.1.ebuild
new file mode 100644
index 00000000..b777c33e
--- /dev/null
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/zdharma/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="7bec6e57829e1020165a03371ea38a4adae7176d"
+ SRC_URI="https://github.com/zdharma/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/zdharma/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz";;
+esac
+
+DESCRIPTION="Optimized and extended zsh-syntax-highlighting"
+HOMEPAGE="https://github.com/zdharma/fast-syntax-highlighting/"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/fast-syntax-highlighting.plugin.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+
+MAKE_ARGS=(
+ "SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
+ "DOC_DIR=${ED}/usr/share/doc/${PF}"
+)
+
+src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS dir
+ dir="/usr/share/zsh/site-contrib/${PN}"
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. ${EPREFIX}${dir}/fast-syntax-highlighting.plugin.zsh"'
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh.'
+ readme.gentoo_create_doc
+ insinto "${dir}"
+ doins -r *
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-0_alpha20180528.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.1_alpha20180528.ebuild
index 2ae32f84..2ae32f84 100644
--- a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-0_alpha20180528.ebuild
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-1.1_alpha20180528.ebuild