summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2020-12-25 10:42:01 +0100
committerMartin Väth <martin@mvath.de>2020-12-25 10:42:01 +0100
commitdc4f734959a57fa06acdea9655adee44834eb018 (patch)
tree5b562600381b370b370240338d2df87ad58ca9a5 /app-shells
parentapp-shells/schily-tools media-tv/sundtek-tv: Version bump (diff)
downloadmv-dc4f734959a57fa06acdea9655adee44834eb018.tar.gz
mv-dc4f734959a57fa06acdea9655adee44834eb018.tar.bz2
mv-dc4f734959a57fa06acdea9655adee44834eb018.zip
app-shells/zsh-syntax-highlighting sys-kernel/kconfig-hardened-check: Bumps
Signed-off-by: Martin Väth <martin@mvath.de>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-syntax-highlighting/Manifest1
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.8.0_alpha1.ebuild74
-rw-r--r--app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild4
3 files changed, 78 insertions, 1 deletions
diff --git a/app-shells/zsh-syntax-highlighting/Manifest b/app-shells/zsh-syntax-highlighting/Manifest
new file mode 100644
index 00000000..a7d9e32a
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/Manifest
@@ -0,0 +1 @@
+DIST zsh-syntax-highlighting-0.8.0_alpha1.tar.gz 150914 SHA512 6a8ea5c181cbeae2fb538be50d07a5391fe7a454331b06a73ba266cd5f2b64a5f98f8d086ee2fa9e4994044686341eaccaa1ba48fcea5eee544f119b3ddf396a
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.8.0_alpha1.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.8.0_alpha1.ebuild
new file mode 100644
index 00000000..9bd9562e
--- /dev/null
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-0.8.0_alpha1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2011-2018 Martin V\"ath
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/zsh-users/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+0.8.0_alpha1)
+ my_PV=${PV/_alpha/-alpha}-pre-redrawhook
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${my_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${my_PV}";;
+*beta*)
+ EGIT_COMMIT="02a37dd919dc48e0821186e5f20e78bd0215f86a"
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz";;
+esac
+
+DESCRIPTION="Fish shell like syntax highlighting for zsh"
+HOMEPAGE="https://github.com/zsh-users/zsh-syntax-highlighting/"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+MAKE_ARGS=(
+ "SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
+ "DOC_DIR=${ED}/usr/share/doc/${PF}"
+)
+
+src_prepare() {
+ grep -q 'local .*cdpath_dir' \
+ "${S}/highlighters/main/main-highlighter.zsh" >/dev/null 2>&1 || \
+ sed -i -e '/for cdpath_dir/ilocal cdpath_dir' \
+ -- "${S}/highlighters/main/main-highlighter.zsh" || die
+ default
+}
+
+src_compile() {
+ emake "${MAKE_ARGS[@]}"
+}
+
+src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS
+ emake "${MAKE_ARGS[@]}" install
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/zsh-syntax-highlighting.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ emake "${MAKE_ARGS[@]}" test
+ emake "${MAKE_ARGS[@]}" perf
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
index 14743473..5257efa9 100644
--- a/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
+++ b/app-shells/zsh-syntax-highlighting/zsh-syntax-highlighting-99999999.ebuild
@@ -14,7 +14,9 @@ case ${PV} in
PROPERTIES="live"
SRC_URI=""
KEYWORDS="";;
-*alpha*)
+0.8.0_alpha1)
+ SRC_URI="https://github.com/zsh-users/${PN}/archive/${PV/_alpha/-alpha}-pre-redrawhook.tar.gz -> ${P}.tar.gz";;
+*beta*)
EGIT_COMMIT="02a37dd919dc48e0821186e5f20e78bd0215f86a"
SRC_URI="https://github.com/zsh-users/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;