summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2015-10-11 11:26:48 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 11:32:18 +0200
commit109d6b4f673a249aea4deeb0cdb5b54a21592410 (patch)
treeec3589a50dac5be54ef6248d1e0ff3a9fd3b41b4 /games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild
downloadmv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.gz
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.tar.bz2
mv-109d6b4f673a249aea4deeb0cdb5b54a21592410.zip
Clear history for egencache --repo=mv --update-changelogs
Diffstat (limited to 'games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild')
-rw-r--r--games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild b/games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild
new file mode 100644
index 00000000..068b1bdc
--- /dev/null
+++ b/games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Do *not* inherit latex-package: It DEPENDS unconditionally on texinfo.
+# Moreover, it would attempt to compile the *.tex example with texinfo to dvi.
+inherit eutils
+RESTRICT="mirror"
+
+DESCRIPTION="LaTeX2e character sheet layout for the Midgard Role Playing Game (Edition M5)"
+HOMEPAGE="https://github.com/vaeth/m5figur-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples"
+# We need texlive-latexextra for toolbox.sty
+RDEPEND="virtual/latex-base
+ dev-texlive/texlive-latexextra"
+DEPEND="examples? ( ${RDEPEND} )"
+
+src_compile() {
+ if use examples
+ then einfo "Compiling example character sheet as pdf"
+ export VARTEXFONTS="${T}/fonts"
+ pdflatex *.tex && test -s *.pdf || die "could not create example"
+ fi
+}
+
+src_install() {
+ TEXMF="/usr/share/texmf-site"
+ insinto "${TEXMF}/tex/latex/${PN}"
+ doins *.cls
+ insinto "${TEXMF}/doc/latex/${PN}"
+ doins *.tex
+ if use examples
+ then doins *.pdf
+ fi
+ dodoc README
+}
+
+pkg_postinst() {
+ texconfig rehash
+}
+
+pkg_postrm() {
+ texconfig rehash
+}