summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/eix/Manifest2
-rw-r--r--app-portage/eix/eix-0.32.11_alpha2.ebuild (renamed from app-portage/eix/eix-0.32.11_alpha1.ebuild)64
-rw-r--r--app-portage/eix/eix-99999999.ebuild64
-rw-r--r--app-portage/eix/metadata.xml1
-rw-r--r--metadata/pkg_desc_index2
-rw-r--r--profiles/use.local.desc1
6 files changed, 118 insertions, 16 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 08d6078c..2da03637 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1,2 @@
DIST eix-0.32.10.tar.xz 600120 SHA256 4ecd6ed7e5bb8859c5e5548265e622bffd19800c889d49e75c0bad556830c5da
-DIST eix-0.32.11_alpha1.tar.gz 653496 SHA256 6b926d9a82c020ea6db62689fc031093ffe725720db8ad3ff775dc58fcbffc28
+DIST eix-0.32.11_alpha2.tar.gz 665406 SHA256 878619eb616dffcd48dbf17b9d60a8073765336cbeff0238dea5c2a1ec961077
diff --git a/app-portage/eix/eix-0.32.11_alpha1.ebuild b/app-portage/eix/eix-0.32.11_alpha2.ebuild
index ad4bc449..54a7ef24 100644
--- a/app-portage/eix/eix-0.32.11_alpha1.ebuild
+++ b/app-portage/eix/eix-0.32.11_alpha2.ebuild
@@ -4,8 +4,9 @@
EAPI=6
RESTRICT="mirror"
WANT_LIBTOOL=none
+AUTOTOOLS_AUTO_DEPEND=no
PLOCALES="de ru"
-inherit autotools bash-completion-r1 l10n tmpfiles
+inherit autotools bash-completion-r1 l10n meson tmpfiles
case ${PV} in
99999999*)
@@ -15,7 +16,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="5687b4c2fc1bda8d2f55237b9e2f4b3941afe1d9"
+ EGIT_COMMIT="a0ce147d0da7587ba560ed2994abc045faabab77"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -26,7 +27,7 @@ HOMEPAGE="https://github.com/vaeth/eix/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
+IUSE="debug +dep doc +meson nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
BOTHDEPEND="nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
@@ -34,6 +35,8 @@ RDEPEND="${BOTHDEPEND}
>=app-shells/push-2.0-r2
>=app-shells/quoter-3.0-r2"
DEPEND="${BOTHDEPEND}
+ meson? ( >=dev-util/meson-0.41.0 )
+ !meson? ( ${AUTOTOOLS_DEPEND} )
>=sys-devel/gettext-0.19.6"
pkg_setup() {
@@ -45,12 +48,38 @@ pkg_setup() {
src_prepare() {
sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
eapply_user
- eautopoint
- eautoreconf
+ use meson || {
+ eautopoint
+ eautoreconf
+ }
}
src_configure() {
- econf \
+ local emesonargs
+ emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${P}" \
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html" \
+ -Dsqlite=$(usex sqlite true false) \
+ -Dextra-doc=$(usex doc true false) \
+ -Dnls=$(usex nls true false) \
+ -Dseparate-tools=$(usex tools true false) \
+ -Dsecurity=$(usex security true false) \
+ -Doptimization=$(usex optimization true false) \
+ -Dstrong-secutiry=$(usex strong-security true false) \
+ -Dstrong-optimization=$(usex strong-optimization true false) \
+ -Ddebugging=$(usex debug true false) \
+ -Dswap-remote=$(usex swap-remote true false) \
+ -Dalways-accept-keywords=$(usex prefix true false) \
+ -Ddep-default=$(usex dep true false) \
+ -Drequired-use-default=$(usex required-use true false) \
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions" \
+ -Dportage-rootpath="${ROOTPATH}" \
+ -Deprefix-default="${EPREFIX}"
+ )
+ if use meson; then
+ meson_src_configure
+ else
+ econf \
$(use_with sqlite) \
$(use_with doc extra-doc) \
$(use_enable nls) \
@@ -67,10 +96,31 @@ src_configure() {
--with-zsh-completion \
--with-portage-rootpath="${ROOTPATH}" \
--with-eprefix-default="${EPREFIX}"
+ fi
+}
+
+src_compile() {
+ if use meson; then
+ meson_src_compile
+ else
+ default
+ fi
+}
+
+src_test() {
+ if use meson; then
+ meson_src_test
+ else
+ default
+ fi
}
src_install() {
- default
+ if use meson; then
+ meson_src_install
+ else
+ default
+ fi
dobashcomp bash/eix
dotmpfiles tmpfiles.d/eix.conf
}
diff --git a/app-portage/eix/eix-99999999.ebuild b/app-portage/eix/eix-99999999.ebuild
index ad4bc449..54a7ef24 100644
--- a/app-portage/eix/eix-99999999.ebuild
+++ b/app-portage/eix/eix-99999999.ebuild
@@ -4,8 +4,9 @@
EAPI=6
RESTRICT="mirror"
WANT_LIBTOOL=none
+AUTOTOOLS_AUTO_DEPEND=no
PLOCALES="de ru"
-inherit autotools bash-completion-r1 l10n tmpfiles
+inherit autotools bash-completion-r1 l10n meson tmpfiles
case ${PV} in
99999999*)
@@ -15,7 +16,7 @@ case ${PV} in
PROPERTIES="live";;
*)
RESTRICT="mirror"
- EGIT_COMMIT="5687b4c2fc1bda8d2f55237b9e2f4b3941afe1d9"
+ EGIT_COMMIT="a0ce147d0da7587ba560ed2994abc045faabab77"
SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
esac
@@ -26,7 +27,7 @@ HOMEPAGE="https://github.com/vaeth/eix/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
+IUSE="debug +dep doc +meson nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
BOTHDEPEND="nls? ( virtual/libintl )
sqlite? ( >=dev-db/sqlite-3:= )"
@@ -34,6 +35,8 @@ RDEPEND="${BOTHDEPEND}
>=app-shells/push-2.0-r2
>=app-shells/quoter-3.0-r2"
DEPEND="${BOTHDEPEND}
+ meson? ( >=dev-util/meson-0.41.0 )
+ !meson? ( ${AUTOTOOLS_DEPEND} )
>=sys-devel/gettext-0.19.6"
pkg_setup() {
@@ -45,12 +48,38 @@ pkg_setup() {
src_prepare() {
sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
eapply_user
- eautopoint
- eautoreconf
+ use meson || {
+ eautopoint
+ eautoreconf
+ }
}
src_configure() {
- econf \
+ local emesonargs
+ emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${P}" \
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html" \
+ -Dsqlite=$(usex sqlite true false) \
+ -Dextra-doc=$(usex doc true false) \
+ -Dnls=$(usex nls true false) \
+ -Dseparate-tools=$(usex tools true false) \
+ -Dsecurity=$(usex security true false) \
+ -Doptimization=$(usex optimization true false) \
+ -Dstrong-secutiry=$(usex strong-security true false) \
+ -Dstrong-optimization=$(usex strong-optimization true false) \
+ -Ddebugging=$(usex debug true false) \
+ -Dswap-remote=$(usex swap-remote true false) \
+ -Dalways-accept-keywords=$(usex prefix true false) \
+ -Ddep-default=$(usex dep true false) \
+ -Drequired-use-default=$(usex required-use true false) \
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions" \
+ -Dportage-rootpath="${ROOTPATH}" \
+ -Deprefix-default="${EPREFIX}"
+ )
+ if use meson; then
+ meson_src_configure
+ else
+ econf \
$(use_with sqlite) \
$(use_with doc extra-doc) \
$(use_enable nls) \
@@ -67,10 +96,31 @@ src_configure() {
--with-zsh-completion \
--with-portage-rootpath="${ROOTPATH}" \
--with-eprefix-default="${EPREFIX}"
+ fi
+}
+
+src_compile() {
+ if use meson; then
+ meson_src_compile
+ else
+ default
+ fi
+}
+
+src_test() {
+ if use meson; then
+ meson_src_test
+ else
+ default
+ fi
}
src_install() {
- default
+ if use meson; then
+ meson_src_install
+ else
+ default
+ fi
dobashcomp bash/eix
dotmpfiles tmpfiles.d/eix.conf
}
diff --git a/app-portage/eix/metadata.xml b/app-portage/eix/metadata.xml
index 92215426..0e9dc4b8 100644
--- a/app-portage/eix/metadata.xml
+++ b/app-portage/eix/metadata.xml
@@ -21,6 +21,7 @@
<flag name="debug">Build with upstream's CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.</flag>
<flag name="dep">Make DEP=true the default which enables support for {,R,P}DEPEND but requires roughly double disk and memory.</flag>
<flag name="doc">Create description of the eix cache file additionally in html format</flag>
+ <flag name="meson">Build with meson instead of autotools. Faster but less compatible</flag>
<flag name="optimization">Accept upstream's choices for CXXFLAGS/LDFLAGS for optimization. Absense of this USE flag does not strip user's *FLAGS</flag>
<flag name="required-use">Make REQUIRED_USE=true the default which enables support for REQUIRED_USE but requires more disk and memory.</flag>
<flag name="security">This adds some checks which can prevent certain exploits if e.g. the eix code has a bug. If you use the hardened toolchain, using this flag does not increase security and can even lead to problems.</flag>
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index ad83594e..93af8218 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -21,7 +21,7 @@ app-emacs/mv_emacs 1.3: (X)Emacs extensions: block support, macrorecorder, verif
app-emacs/po-mode 0.19.8.1-r1: Major mode for GNU gettext PO files
app-eselect/eselect-net 0.2: eselect module for managing network open-rc service configurations
app-misc/knapsack 7.2-r1: A fast solver for the 0/1-knapsack problem with multiple knapsacks
-app-portage/eix 0.32.10 0.32.11_alpha1 99999999: Search and query ebuilds
+app-portage/eix 0.32.10 0.32.11_alpha2 99999999: Search and query ebuilds
app-portage/etcat 1.0.1 99999999: Updated version of an old Portage information extractor
app-portage/find_cruft 3.1.0: find cruft files not managed by portage
app-portage/gentoolkit 0.4.0-r1 9999: Collection of administration scripts for Gentoo
diff --git a/profiles/use.local.desc b/profiles/use.local.desc
index eb34851d..c1386f24 100644
--- a/profiles/use.local.desc
+++ b/profiles/use.local.desc
@@ -6,6 +6,7 @@ app-admin/checksec:update - Support self-update functionality outside of the pac
app-portage/eix:debug - Build with upstream's CXXFLAGS/LDFLAGS for debugging support; not recommended for normal use.
app-portage/eix:dep - Make DEP=true the default which enables support for {,R,P}DEPEND but requires roughly double disk and memory.
app-portage/eix:doc - Create description of the eix cache file additionally in html format
+app-portage/eix:meson - Build with meson instead of autotools. Faster but less compatible
app-portage/eix:optimization - Accept upstream's choices for CXXFLAGS/LDFLAGS for optimization. Absense of this USE flag does not strip user's *FLAGS
app-portage/eix:required-use - Make REQUIRED_USE=true the default which enables support for REQUIRED_USE but requires more disk and memory.
app-portage/eix:security - This adds some checks which can prevent certain exploits if e.g. the eix code has a bug. If you use the hardened toolchain, using this flag does not increase security and can even lead to problems.