summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/googleearth/googleearth-7.1.8.3036-r3.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.1.8.3036-r2.ebuild)10
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.0.3832-r3.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.3.0.3832-r2.ebuild)10
-rw-r--r--sci-geosciences/googleearth/googleearth-7.3.2-r2.ebuild (renamed from sci-geosciences/googleearth/googleearth-7.3.2-r1.ebuild)10
3 files changed, 9 insertions, 21 deletions
diff --git a/sci-geosciences/googleearth/googleearth-7.1.8.3036-r2.ebuild b/sci-geosciences/googleearth/googleearth-7.1.8.3036-r3.ebuild
index 9af756fc..3c5f05ac 100644
--- a/sci-geosciences/googleearth/googleearth-7.1.8.3036-r2.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.1.8.3036-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop eutils gnome2-utils pax-utils unpacker xdg-utils
+inherit desktop eutils pax-utils unpacker xdg-utils
DESCRIPTION="A 3D interface to the planet"
HOMEPAGE="https://www.google.com/earth/desktop/"
@@ -127,16 +127,12 @@ src_install() {
insinto /opt/${PN}
doins -r *
- chmod +x /opt/${PN}/${PN}{,-bin} || die
- find "${ED}" -type f -name "*.so.*" -exec chmod +x '{}' +
+ chmod +x "${ED}"/opt/${PN}/{${PN}{,-bin},gpsbabel} || die
+ find "${ED}" -type f '(' -name '*.so.*' -o -name '*.so' ')' -exec chmod +x '{}' + || die
pax-mark -m "${ED%/}"/opt/${PN}/${PN}-bin
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
elog "When you get a crash starting Google Earth, try adding a file ~./.config/Google/GoogleEarthPlus.conf"
elog "with the following options:"
diff --git a/sci-geosciences/googleearth/googleearth-7.3.0.3832-r2.ebuild b/sci-geosciences/googleearth/googleearth-7.3.0.3832-r3.ebuild
index 3e60bb91..b39e22d0 100644
--- a/sci-geosciences/googleearth/googleearth-7.3.0.3832-r2.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.3.0.3832-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop eutils gnome2-utils pax-utils unpacker xdg-utils
+inherit desktop eutils pax-utils unpacker xdg-utils
DESCRIPTION="A 3D interface to the planet"
HOMEPAGE="https://www.google.com/earth/desktop/"
@@ -135,16 +135,12 @@ src_install() {
insinto /opt/${PN}
doins -r *
- chmod +x /opt/${PN}/${PN}{,-bin} || die
- find "${ED}" -type f -name "*.so.*" -exec chmod +x '{}' +
+ chmod +x "${ED}"/opt/${PN}/{${PN}{,-bin},repair_tool,gpsbabel} || die
+ find "${ED}" -type f '(' -name '*.so.*' -o -name '*.so' ')' -exec chmod +x '{}' + || die
pax-mark -m "${ED%/}"/opt/${PN}/${PN}-bin
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
elog "When you get a crash starting Google Earth, try adding a file ~./.config/Google/GoogleEarthPlus.conf"
elog "with the following options:"
diff --git a/sci-geosciences/googleearth/googleearth-7.3.2-r1.ebuild b/sci-geosciences/googleearth/googleearth-7.3.2-r2.ebuild
index 866b3d7c..6ea761ee 100644
--- a/sci-geosciences/googleearth/googleearth-7.3.2-r1.ebuild
+++ b/sci-geosciences/googleearth/googleearth-7.3.2-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit desktop eutils gnome2-utils pax-utils unpacker xdg-utils
+inherit desktop eutils pax-utils unpacker xdg-utils
DESCRIPTION="A 3D interface to the planet"
HOMEPAGE="https://www.google.com/earth/desktop/"
@@ -122,16 +122,12 @@ src_install() {
insinto /opt/${PN}
doins -r *
- chmod +x /opt/${PN}/${PN}{,-bin} || die
- find "${ED}" -type f -name "*.so.*" -exec chmod +x '{}' +
+ chmod +x "${ED}"/opt/${PN}/{${PN}{,-bin},repair_tool,gpsbabel} || die
+ find "${ED}" -type f '(' -name '*.so.*' -o -name '*.so' ')' -exec chmod +x '{}' + || die
pax-mark -m "${ED%/}"/opt/${PN}/${PN}-bin
}
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
pkg_postinst() {
elog "When you get a crash starting Google Earth, try adding a file ~./.config/Google/GoogleEarthPlus.conf"
elog "with the following options:"