summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/fast-syntax-highlighting/Manifest1
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-0_alpha20180528.ebuild61
-rw-r--r--app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild61
-rw-r--r--app-shells/fast-syntax-highlighting/metadata.xml12
-rw-r--r--metadata/pkg_desc_index1
5 files changed, 136 insertions, 0 deletions
diff --git a/app-shells/fast-syntax-highlighting/Manifest b/app-shells/fast-syntax-highlighting/Manifest
new file mode 100644
index 00000000..d37f0f6e
--- /dev/null
+++ b/app-shells/fast-syntax-highlighting/Manifest
@@ -0,0 +1 @@
+DIST fast-syntax-highlighting-0_alpha20180528.tar.gz 173583 SHA512 87caf8d2b287b3e9954edc1900127bf743110c2c839a94d0cd7d656622e9099371c01279a9c3e1461e2d3f294fb0b6d87ed950710014052de5c234d8a8546fed
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-0_alpha20180528.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-0_alpha20180528.ebuild
new file mode 100644
index 00000000..2ae32f84
--- /dev/null
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-0_alpha20180528.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/zdharma/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="7bec6e57829e1020165a03371ea38a4adae7176d"
+ SRC_URI="https://github.com/zdharma/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/zdharma/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz";;
+esac
+
+DESCRIPTION="Optimized and extended zsh-syntax-highlighting"
+HOMEPAGE="https://github.com/zdharma/fast-syntax-highlighting/"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/fast-syntax-highlighting.plugin.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+
+MAKE_ARGS=(
+ "SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
+ "DOC_DIR=${ED}/usr/share/doc/${PF}"
+)
+
+src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS dir
+ dir="/usr/share/zsh/site-contrib/${PN}"
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. ${EPREFIX}${dir}/fast-syntax-highlighting.plugin.zsh"'
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh.'
+ readme.gentoo_create_doc
+ insinto "${dir}"
+ doins -r *
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
new file mode 100644
index 00000000..2ae32f84
--- /dev/null
+++ b/app-shells/fast-syntax-highlighting/fast-syntax-highlighting-99999999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2011-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit readme.gentoo-r1
+
+RESTRICT="mirror"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+case ${PV} in
+99999999*)
+ EGIT_REPO_URI="https://github.com/zdharma/${PN}.git"
+ inherit git-r3
+ PROPERTIES="live"
+ SRC_URI=""
+ KEYWORDS="";;
+*alpha*)
+ EGIT_COMMIT="7bec6e57829e1020165a03371ea38a4adae7176d"
+ SRC_URI="https://github.com/zdharma/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
+*)
+ SRC_URI="https://github.com/zdharma/${PN}/archive/${PV/_rc/-rc}.tar.gz -> ${P}.tar.gz";;
+esac
+
+DESCRIPTION="Optimized and extended zsh-syntax-highlighting"
+HOMEPAGE="https://github.com/zdharma/fast-syntax-highlighting/"
+
+LICENSE="HPND"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-shells/zsh"
+DEPEND=""
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. /usr/share/zsh/site-contrib/${PN}/fast-syntax-highlighting.plugin.zsh
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh."
+
+MAKE_ARGS=(
+ "SHARE_DIR=${ED}/usr/share/zsh/site-contrib/${PN}"
+ "DOC_DIR=${ED}/usr/share/doc/${PF}"
+)
+
+src_install() {
+ local DISABLE_AUTOFORMATTING DOC_CONTENTS dir
+ dir="/usr/share/zsh/site-contrib/${PN}"
+ DISABLE_AUTOFORMATTING="true"
+ DOC_CONTENTS="In order to use ${CATEGORY}/${PN} add
+. ${EPREFIX}${dir}/fast-syntax-highlighting.plugin.zsh"'
+at the end of your ~/.zshrc
+For testing, you can also execute the above command in your zsh.'
+ readme.gentoo_create_doc
+ insinto "${dir}"
+ doins -r *
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/fast-syntax-highlighting/metadata.xml b/app-shells/fast-syntax-highlighting/metadata.xml
new file mode 100644
index 00000000..abaca81a
--- /dev/null
+++ b/app-shells/fast-syntax-highlighting/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/zdharma/fast-syntax-highlighting/issues</bugs-to>
+ <remote-id type="github">zdharma/fasth-syntax-highlighting</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 7534d2bf..46c4dad4 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -34,6 +34,7 @@ app-portage/world-mv 3.19: Organize your world file and find installed packages
app-shells/auto-fu-zsh 0.0.1.12-r4 0.0.1.12_p0 99999999: zsh automatic complete-word and list-choices: incremental completion
app-shells/command-not-found 0.4.5: search ARCH database for packages with similar commands
app-shells/dash 99999999: Descendant of the NetBSD ash. POSIX compliant except for multibyte characters
+app-shells/fast-syntax-highlighting 0_alpha20180528 99999999: Optimized and extended zsh-syntax-highlighting
app-shells/oh-my-zsh 99999999: A ready-to-use zsh configuration with plugins
app-shells/push 3.1: A POSIX shell function to treat a variable like an array, quoting args
app-shells/quoter 4.1: Quote arguments or standard input for usage in POSIX shell by eval