summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/podofo/Manifest2
-rw-r--r--app-text/podofo/podofo-0.9.6_p20190928.ebuild (renamed from app-text/podofo/podofo-0.9.6_p20180715-r1.ebuild)20
-rw-r--r--metadata/pkg_desc_index2
3 files changed, 15 insertions, 9 deletions
diff --git a/app-text/podofo/Manifest b/app-text/podofo/Manifest
index ef945566..9cf4f148 100644
--- a/app-text/podofo/Manifest
+++ b/app-text/podofo/Manifest
@@ -1 +1 @@
-DIST podofo-0.9.6_p20180715.tar.xz 747444 SHA512 4c9b09c716128110b47d6a02f118eb80b6009e9e79dbc83ff804a57f0abc011b789de9287b68a6c1d6704ef386f8062a3a495408af8a832782f0bf0128190a1f
+DIST podofo-0.9.6_p20190928.tar.xz 747532 SHA512 b9d46fb02eeba61190a0efd17b507bba62d7246af6fff3c3514c9970e99e085f9aad92baa05cc6cf0a8c3c2843554099c904bff10be54dbb4d4cb7de460fc3cc
diff --git a/app-text/podofo/podofo-0.9.6_p20180715-r1.ebuild b/app-text/podofo/podofo-0.9.6_p20190928.ebuild
index f011b9ab..adea196b 100644
--- a/app-text/podofo/podofo-0.9.6_p20180715-r1.ebuild
+++ b/app-text/podofo/podofo-0.9.6_p20190928.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2019 Gentoo Authors and Martin V\"ath
+# Copyright 1999-2020 Gentoo Authors and Martin V\"ath
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils flag-o-matic multilib toolchain-funcs
+inherit cmake flag-o-matic multilib toolchain-funcs
DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format"
HOMEPAGE="https://sourceforge.net/projects/podofo/"
-SRC_URI="mirror://gentoo/${P}.tar.xz"
+SRC_URI="https://dev.gentoo.org/~zmedico/dist/${P}.tar.xz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0/${PV%_*}"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 ~sparc x86"
IUSE="+boost idn libressl lua-slotted lua51 lua52 debug test +tools"
+RESTRICT="!test? ( test )"
REQUIRED_USE="test? ( tools ) lua52? ( lua51 )"
RDEPEND="!lua-slotted? ( dev-lang/lua:0= )
@@ -39,9 +40,14 @@ BDEPEND="virtual/pkgconfig
DOCS="AUTHORS ChangeLog TODO"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
local x sed_args
+ if use libressl; then
+ sed -e 's:^#ifdef PODOFO_HAVE_OPENSSL_1_1$:#ifndef PODOFO_HAVE_OPENSSL_1_1:' \
+ -i tools/podofosign/podofosign.cpp || die #663602
+ fi
+
# bug 620934 - Disable linking with cppunit when possible, since it
# triggers errors with some older compilers.
use test || sed -e 's:^FIND_PACKAGE(CppUnit):#\0:' -i CMakeLists.txt || die
@@ -147,11 +153,11 @@ src_configure() {
)
fi
- cmake-utils_src_configure
+ cmake_src_configure
mkdir -p "${S}/test/TokenizerTest/objects" || die
}
src_test() {
- cd "${CMAKE_BUILD_DIR}"/test/unit
+ cd "${BUILD_DIR}"/test/unit || die
./podofo-test --selftest || die "self test failed"
}
diff --git a/metadata/pkg_desc_index b/metadata/pkg_desc_index
index 45fa0359..abc65f38 100644
--- a/metadata/pkg_desc_index
+++ b/metadata/pkg_desc_index
@@ -48,7 +48,7 @@ app-shells/zshrc-mv 6.0: A zshrc file initializing zsh specific interactive feat
app-text/ispell 3.3.02-r1 3.4.00: fast screen-oriented spelling checker
app-text/lesspipe 1.85_alpha20200517 99999999: Wolfgang Friebel's preprocessor for sys-apps/less. Disable by appending colon
app-text/mbtpdfasm 1.0.28-r1: Tool to assemble/merge, extract information from, and update the metadata in PDF
-app-text/podofo 0.9.6_p20180715-r1: PoDoFo is a C++ library to work with the PDF file format
+app-text/podofo 0.9.6_p20190928: PoDoFo is a C++ library to work with the PDF file format
app-text/psjoin 0.3: concatenate postscript files. From new PostScript Utilities
app-text/stardict 3.0.6-r4 4.0.0_pre20170304: A international dictionary supporting fuzzy and glob style matching
dev-cpp/cpplint 99999999: The google styleguide together with cpplint and an emacs file