summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/Manifest3
-rw-r--r--app-portage/eix/eix-0.34.9.ebuild (renamed from app-portage/eix/eix-0.34.8.ebuild)4
-rw-r--r--app-portage/eix/eix-0.34.9_alpha20200911.ebuild178
3 files changed, 4 insertions, 181 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 313ffd12..e7427ae5 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1 @@
-DIST eix-0.34.8.tar.xz 629380 SHA512 9cbda3b2d449559063910a4234c26a5b8424ab244624ba093f7d5183600c53d0240948ffb891a9d94a961d3a32033cca374635992da6abf73d746f0356c1cc8e
-DIST eix-0.34.9_alpha20200911.tar.gz 688479 SHA512 40e2eff25219e7679f9ea62c16d26a8ec1d8f258b3e9b66b9c11928c0b9ac8a1967c60b24a879704c625e3d7dbf2111b8d00e56239f29f726954b87f6a02a4a2
+DIST eix-0.34.9.tar.xz 629672 SHA512 5cb00c813bc31971a0cfd77cae0c676040d33f24963cb241274918d2e381956ca949593e0637d81040a9751db0a925552913188cc25ada9a90c6007c31f72e43
diff --git a/app-portage/eix/eix-0.34.8.ebuild b/app-portage/eix/eix-0.34.9.ebuild
index b3364c27..227b9a2a 100644
--- a/app-portage/eix/eix-0.34.8.ebuild
+++ b/app-portage/eix/eix-0.34.9.ebuild
@@ -14,7 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
PLOCALES="de ru"
-IUSE="debug +dep doc +jumbo-build"
+IUSE="cpu_flags_x86_sse2 debug +dep doc +jumbo-build"
for i in ${PLOCALES}; do
IUSE+=" l10n_${i}"
done
@@ -68,6 +68,7 @@ src_configure() {
$(meson_use debug debugging)
$(meson_use swap-remote)
$(meson_use prefix always-accept-keywords)
+ $(meson_use cpu_flags_x86_sse2 sse2)
$(meson_use dep dep-default)
$(meson_use required-use required-use-default)
$(meson_use src-uri src-uri-default)
@@ -98,6 +99,7 @@ src_configure() {
$(use_enable debug debugging)
$(use_enable swap-remote)
$(use_with prefix always-accept-keywords)
+ $(use_with cpu_flags_x86_sse2 sse2)
$(use_with dep dep-default)
$(use_with required-use required-use-default)
$(use_with src-uri src-uri-default)
diff --git a/app-portage/eix/eix-0.34.9_alpha20200911.ebuild b/app-portage/eix/eix-0.34.9_alpha20200911.ebuild
deleted file mode 100644
index 78d608ab..00000000
--- a/app-portage/eix/eix-0.34.9_alpha20200911.ebuild
+++ /dev/null
@@ -1,178 +0,0 @@
-# Copyright 1999-2020 Martin V\"ath and others
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-WANT_LIBTOOL=none
-AUTOTOOLS_AUTO_DEPEND=no
-MESON_AUTO_DEPEND=no
-inherit autotools bash-completion-r1 meson tmpfiles
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-case ${PV} in
-99999999*)
- EGIT_REPO_URI="https://github.com/vaeth/${PN}.git"
- inherit git-r3
- SRC_URI=""
- KEYWORDS=""
- PROPERTIES="live";;
-*)
- RESTRICT="mirror"
- EGIT_COMMIT="eaa44b984dcdb4fe9499d6b71735bac4a30899bd"
- SRC_URI="https://github.com/vaeth/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${PN}-${EGIT_COMMIT}";;
-esac
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-
-LICENSE="GPL-2"
-SLOT="0"
-PLOCALES="de ru"
-IUSE="cpu_flags_x86_sse2 debug +dep doc +jumbo-build"
-for i in ${PLOCALES}; do
- IUSE+=" l10n_${i}"
-done
-IUSE+=" +meson nls optimization +protobuf +required-use security +src-uri strong-optimization strong-security sqlite swap-remote tools usr-portage"
-
-DEPEND="nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${DEPEND}
- >=app-shells/push-3.1
- >=app-shells/quoter-4.1"
-BDEPEND="meson? (
- >=dev-util/meson-0.41.0
- >=dev-util/ninja-1.7.2
- strong-optimization? ( >=sys-devel/gcc-config-1.9.1 )
- nls? ( sys-devel/gettext )
- )
- !meson? ( ${AUTOTOOLS_DEPEND} >=sys-devel/gettext-0.19.6 )
- protobuf? ( dev-libs/protobuf )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache="${EROOT}var/cache/${PN}"
- test -f "${old_cache}" && rm -f -- "${old_cache}"
-}
-
-src_prepare() {
- sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
- default
- use meson || {
- eautopoint
- eautoreconf
- }
-}
-
-src_configure() {
- local i
- export LINGUAS=
- for i in ${PLOCALES}; do
- use l10n_${i} && LINGUAS+=${LINGUAS:+ }${i}
- done
- if use meson; then
- local emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${P}"
- -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html"
- $(meson_use jumbo-build)
- $(meson_use sqlite)
- $(meson_use protobuf)
- $(meson_use doc extra-doc)
- $(meson_use nls)
- $(meson_use tools separate-tools)
- $(meson_use security)
- $(meson_use optimization normal-optimization)
- $(meson_use strong-security)
- $(meson_use strong-optimization)
- $(meson_use debug debugging)
- $(meson_use swap-remote)
- $(meson_use prefix always-accept-keywords)
- $(meson_use cpu_flags_x86_sse2 sse2)
- $(meson_use dep dep-default)
- $(meson_use required-use required-use-default)
- $(meson_use src-uri src-uri-default)
- $(usex usr-portage -Dportdir-default=/usr/portage '')
- -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
- -Dportage-rootpath="${ROOTPATH}"
- -Deprefix-default="${EPREFIX}"
- )
- if use prefix; then
- emesonarge+=(
- -Deix-user=
- -Deix-uid=-1
- )
- fi
- meson_src_configure
- else
- local myconf=(
- $(use_enable jumbo-build)
- $(use_with sqlite)
- $(use_with protobuf)
- $(use_with doc extra-doc)
- $(use_enable nls)
- $(use_enable tools separate-tools)
- $(use_enable security)
- $(use_enable optimization)
- $(use_enable strong-security)
- $(use_enable strong-optimization)
- $(use_enable debug debugging)
- $(use_enable swap-remote)
- $(use_with prefix always-accept-keywords)
- $(use_with cpu_flags_x86_sse2 sse2)
- $(use_with dep dep-default)
- $(use_with required-use required-use-default)
- $(use_with src-uri src-uri-default)
- $(use_with usr-portage portdir-default /usr/portage)
- --with-zsh-completion
- --with-portage-rootpath="${ROOTPATH}"
- --with-eprefix-default="${EPREFIX}"
- )
- if use prefix; then
- myconf+=(
- --with-eix-user=
- --with-eix-uid=-1
- )
- fi
- econf "${myconf[@]}"
- fi
-}
-
-src_compile() {
- if use meson; then
- meson_src_compile
- else
- default
- fi
-}
-
-src_test() {
- if use meson; then
- meson_src_test
- else
- default
- fi
-}
-
-src_install() {
- if use meson; then
- meson_src_install
- else
- default
- fi
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
- use doc && dodoc src/output/eix.proto
-}
-
-pkg_postinst() {
- local obs="${EROOT}var/cache/eix.previous"
- if test -f "${obs}"; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
- tmpfiles_process eix.conf
-}
-
-pkg_postrm() {
- if [ -z "${REPLACED_BY_VERSION}" ]; then
- rm -rf -- "${EROOT}var/cache/${PN}"
- fi
-}