summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/zsh')
-rw-r--r--app-shells/zsh/Manifest2
-rw-r--r--app-shells/zsh/files/prompt_gentoo_setup-133
-rw-r--r--app-shells/zsh/files/zprofile-143
-rw-r--r--app-shells/zsh/files/zsh-5.1.0-gcc-5.patch16
-rw-r--r--app-shells/zsh/files/zsh-init.d-gentoo-r1.diff30
-rw-r--r--app-shells/zsh/metadata.xml40
-rw-r--r--app-shells/zsh/zsh-5.1.1-r1.ebuild301
-rw-r--r--app-shells/zsh/zsh-99999999.ebuild301
8 files changed, 766 insertions, 0 deletions
diff --git a/app-shells/zsh/Manifest b/app-shells/zsh/Manifest
new file mode 100644
index 00000000..74a49796
--- /dev/null
+++ b/app-shells/zsh/Manifest
@@ -0,0 +1,2 @@
+DIST zsh-5.1.1-doc.tar.xz 3061616 SHA256 f5944f29ec77100afdc3634f0bb8ffc4328a2d03147f23d1aa6280b6aa7d622f SHA512 868444662ca9b1cc91f2ecff56ce0944e5e75fc5f5a349eb538ca23a8eb8fb4ebaa8efc2ba1d8581424f25b0009305ed7a6f08ca06db1ecde467eeb5d6b71621 WHIRLPOOL c72760d754e19e7fe1f501bd395becc13877d4b0ba20fbf1f08855be5affb78aac07e2c14e779c1b554e21e29d8bfd5203dd41da5d3f21020dac7033510a4662
+DIST zsh-5.1.1.tar.xz 2788676 SHA256 74e9453b5470b3c0970f9f93cfd603d241c3d7b1968adc0e4b3951073e8d3dec SHA512 732f183a03125e83da11a38c638ca54a667326a23ca19418b0df27b1d5b3b1f360383d84f66bde064911effaa2ce9cbb9b6ab86deddb92f80e8f601af8a82b3e WHIRLPOOL 55199e45557c2667e8f9b7564af44b32b610fe09db451493bd64642c2987e12a638b2b96d6530a16427ba17a6ca8c20e73f88013cf47996eea24e5e1595691e7
diff --git a/app-shells/zsh/files/prompt_gentoo_setup-1 b/app-shells/zsh/files/prompt_gentoo_setup-1
new file mode 100644
index 00000000..046e2d87
--- /dev/null
+++ b/app-shells/zsh/files/prompt_gentoo_setup-1
@@ -0,0 +1,33 @@
+# gentoo prompt theme
+
+prompt_gentoo_help () {
+ cat <<'EOF'
+This prompt is color-scheme-able. You can invoke it thus:
+
+ prompt gentoo [<promptcolor> [<usercolor> [<rootcolor>]]]
+
+EOF
+}
+
+prompt_gentoo_setup () {
+ local prompt_gentoo_prompt=${1:-'blue'}
+ local prompt_gentoo_user=${2:-'green'}
+ local prompt_gentoo_root=${3:-'red'}
+
+ if [ "$USER" = 'root' ]
+ then
+ local base_prompt="%B%F{$prompt_gentoo_root}%m%k "
+ else
+ local base_prompt="%B%F{$prompt_gentoo_user}%n@%m%k "
+ fi
+ local post_prompt="%b%f%k"
+
+ #setopt noxtrace localoptions
+
+ local path_prompt="%B%F{$prompt_gentoo_prompt}%1~"
+ typeset -g PS1="$base_prompt$path_prompt %# $post_prompt"
+ typeset -g PS2="$base_prompt$path_prompt %_> $post_prompt"
+ typeset -g PS3="$base_prompt$path_prompt ?# $post_prompt"
+}
+
+prompt_gentoo_setup "$@"
diff --git a/app-shells/zsh/files/zprofile-1 b/app-shells/zsh/files/zprofile-1
new file mode 100644
index 00000000..0602c9c5
--- /dev/null
+++ b/app-shells/zsh/files/zprofile-1
@@ -0,0 +1,43 @@
+# @GENTOO_PORTAGE_EPREFIX@/etc/zsh/zprofile
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh/files/zprofile-1,v 1.1 2010/08/15 12:21:56 tove Exp $
+
+# Load environment settings from profile.env, which is created by
+# env-update from the files in /etc/env.d
+if [ -e "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.env ] ; then
+ . "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.env
+fi
+
+# You should override these in your ~/.zprofile (or equivalent) for per-user
+# settings. For system defaults, you can add a new file in /etc/profile.d/.
+export EDITOR=${EDITOR:-/bin/nano}
+export PAGER=${PAGER:-/usr/bin/less}
+
+# 077 would be more secure, but 022 is generally quite realistic
+umask 022
+
+# Set up PATH depending on whether we're root or a normal user.
+# There's no real reason to exclude sbin paths from the normal user,
+# but it can make tab-completion easier when they aren't in the
+# user's PATH to pollute the executable namespace.
+#
+# It is intentional in the following line to use || instead of -o.
+# This way the evaluation can be short-circuited and calling whoami is
+# avoided.
+if [ "$EUID" = "0" ] || [ "$USER" = "root" ] ; then
+ @ZSH_NOPREFIX@PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:${ROOTPATH}"
+ @ZSH_PREFIX@PATH="@GENTOO_PORTAGE_EPREFIX@/usr/sbin:@GENTOO_PORTAGE_EPREFIX@/usr/bin:@GENTOO_PORTAGE_EPREFIX@/sbin:@GENTOO_PORTAGE_EPREFIX@/bin:${ROOTPATH}:/usr/sbin:/usr/bin:/sbin:/bin"
+else
+ @ZSH_NOPREFIX@PATH="/usr/local/bin:/usr/bin:/bin:${PATH}"
+ @ZSH_PREFIX@PATH="@GENTOO_PORTAGE_EPREFIX@/usr/bin:@GENTOO_PORTAGE_EPREFIX@/bin:${PATH}:/usr/bin:/bin"
+fi
+export PATH
+unset ROOTPATH
+
+shopts=$-
+setopt nullglob
+for sh in "@GENTOO_PORTAGE_EPREFIX@"/etc/profile.d/*.sh ; do
+ [ -r "$sh" ] && . "$sh"
+done
+unsetopt nullglob
+set -$shopts
+unset sh shopts
diff --git a/app-shells/zsh/files/zsh-5.1.0-gcc-5.patch b/app-shells/zsh/files/zsh-5.1.0-gcc-5.patch
new file mode 100644
index 00000000..74756d29
--- /dev/null
+++ b/app-shells/zsh/files/zsh-5.1.0-gcc-5.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/547950
+http://www.zsh.org/mla/workers/2015/msg02660.html
+
+fix building w/gcc-5
+
+--- a/Src/Modules/system.mdd
++++ b/Src/Modules/system.mdd
+@@ -15,7 +15,7 @@
+ touch errtmp.out; \
+ else \
+ $(AWK) -f $(sdir)/errnames1.awk @ERRNO_H@ >errtmp.c; \
+- $(CPP) errtmp.c >errtmp.out; \
++ $(CPP) -P errtmp.c >errtmp.out; \
+ fi
+ $(AWK) -f $(sdir)/errnames2.awk errtmp.out > $@
+ rm -f errtmp.c errtmp.out
diff --git a/app-shells/zsh/files/zsh-init.d-gentoo-r1.diff b/app-shells/zsh/files/zsh-init.d-gentoo-r1.diff
new file mode 100644
index 00000000..9597a733
--- /dev/null
+++ b/app-shells/zsh/files/zsh-init.d-gentoo-r1.diff
@@ -0,0 +1,30 @@
+--- zsh-4.3.11/Completion/Unix/Command/_init_d
++++ zsh-4.3.11/Completion/Unix/Command/_init_d
+@@ -1,6 +1,6 @@
+ #compdef -p */(init|rc[0-9S]#).d/*
+
+-local cmds script
++local cmds script opts
+
+ _compskip=all
+
+@@ -83,10 +83,17 @@
+
+ script=$words[1]
+ [[ $script = */* ]] || script="$(_init_d_fullpath "$script")"
++[[ ! -f $script ]] &&
++ { _message "${words[1]:t} is not an init script" && return }
+
+ cmds=( $(_init_d_get_cmds) ) || return
+
+-(( $#cmds )) || zstyle -a ":completion:${curcontext}:commands" commands cmds ||
+- cmds=(start stop)
++(( $#cmds )) || zstyle -a ":completion:${curcontext}:commands" commands cmds
++opts=(start stop restart pause zap status ineed iuse needsme usesme broken)
++
++# If we didn't get $cmds from a zstyle, then read init script for opts.
++# If script doesn't specify opts, then default to the standard opts.
++(( $#cmds )) || cmds=( ${(eQz)${(M)${(f)"$( <$script)"}:#[[:blank:]]#opts=*}#*=} )
++(( $#cmds )) || cmds=($opts)
+
+ _sub_commands $cmds
diff --git a/app-shells/zsh/metadata.xml b/app-shells/zsh/metadata.xml
new file mode 100644
index 00000000..14b074fe
--- /dev/null
+++ b/app-shells/zsh/metadata.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>tove@gentoo.org</email>
+ <name>Torsten Veller</name>
+ <description>Interim maintainer</description>
+</maintainer>
+<maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ <description>Co-maintainer</description>
+</maintainer>
+<maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ <description>Maintainer of run-help, compile, and completion_* USE-flags</description>
+</maintainer>
+<longdescription>
+ Zsh is a shell designed for interactive use, although it is also a
+ powerful scripting language. Many of the useful features of bash, ksh,
+ and tcsh were incorporated into zsh; many original features were
+ added.
+</longdescription>
+<use>
+ <flag name="compile">Byte-compile. This costs disk space and may make things faster or slower. Do not use this if you are cross-compiling</flag>
+ <flag name='completion_AIX'>Install zsh completions for AIX</flag>
+ <flag name='completion_BSD'>Install zsh completions for BSD</flag>
+ <flag name='completion_Cygwin'>Install zsh completions for Cygwin</flag>
+ <flag name='completion_Darwin'>Install zsh completions for Darwin</flag>
+ <flag name='completion_Debian'>Install zsh completions for Debian</flag>
+ <flag name='completion_Linux'>Install zsh completions for Linux</flag>
+ <flag name='completion_Mandriva'>Install zsh completions for Mandriva</flag>
+ <flag name='completion_openSUSE'>Install zsh completions for openSUSE</flag>
+ <flag name='completion_Redhat'>Install zsh completions for Redhat</flag>
+ <flag name='completion_Solaris'>Install zsh completions for Solaris</flag>
+ <flag name='completion_Unix'>Install zsh completions for Unix</flag>
+ <flag name='completion_X'>Install zsh completions for X</flag>
+</use>
+</pkgmetadata>
diff --git a/app-shells/zsh/zsh-5.1.1-r1.ebuild b/app-shells/zsh/zsh-5.1.1-r1.ebuild
new file mode 100644
index 00000000..d5a8bc8e
--- /dev/null
+++ b/app-shells/zsh/zsh-5.1.1-r1.ebuild
@@ -0,0 +1,301 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib prefix readme.gentoo
+
+MY_PV=${PV/_p/-dev-}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+zsh_ftp="http://www.zsh.org/pub"
+
+ZSH_URI="${zsh_ftp}/${PN}-${MY_PV}.tar.xz"
+ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.xz"
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+case ${PV} in
+9999*)
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
+ inherit git-r3
+ WANT_LIBTOOL="none"
+ inherit autotools
+ KEYWORDS=""
+# Creating help files needs util-linux for colcrt.
+# Please let me know if you have an arch where "colcrt" (or at least "col")
+# is provided by a different package.
+ DEPEND="app-text/yodl
+ dev-lang/perl
+ sys-apps/man
+ sys-apps/util-linux
+ doc? (
+ sys-apps/texinfo
+ app-text/texi2html
+ virtual/latex-base
+ )"
+ PROPERTIES="live"
+ LIVE=:;;
+*)
+ SRC_URI="${ZSH_URI}
+ doc? ( ${ZSH_DOC_URI} )"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ #KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ DEPEND=""
+ LIVE=false;;
+esac
+
+LICENSE="ZSH gdbm? ( GPL-2 )"
+SLOT="0"
+IUSE="caps compile"
+COMPLETIONS="AIX BSD Cygwin Darwin Debian +Linux Mandriva openSUSE Redhat Solaris +Unix +X"
+for curr in ${COMPLETIONS}
+do case ${curr} in
+ [+-]*)
+ IUSE+=" ${curr%%[!+-]*}completion_${curr#?}"
+ continue;;
+ esac
+ IUSE+=" completion_${curr}"
+done
+IUSE+=" debug doc examples gdbm maildir pcre static unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1:0
+ static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
+ caps? ( sys-libs/libcap )
+ pcre? (
+ >=dev-libs/libpcre-3.9
+ static? ( >=dev-libs/libpcre-3.9[static-libs] )
+ )
+ gdbm? ( sys-libs/gdbm )
+"
+DEPEND+="
+ sys-apps/groff
+ ${RDEPEND}"
+PDEPEND="
+ examples? ( app-doc/zsh-lovers )
+"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="
+If you want to enable Portage completions and Gentoo prompt,
+emerge app-shells/zsh-completion and add
+ autoload -U compinit promptinit
+ compinit
+ promptinit; prompt gentoo
+to your ~/.zshrc
+
+Also, if you want to enable cache for the completions, add
+ zstyle ':completion::complete:*' use-cache 1
+to your ~/.zshrc
+
+If you want to use run-help add to your ~/.zshrc
+ unalias run-help
+ autoload -Uz run-help
+
+Note that a system zprofile startup file is installed. This will override
+PATH and possibly other variables that a user may set in ~/.zshenv.
+Custom PATH settings and similar overridden variables can be moved
+to ~/.zprofile or other user startup files that are sourced after the
+system zprofile.
+
+If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,
+one method is to use a separate path-setting file that is conditionally sourced
+in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the
+zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/.
+
+See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation.
+"
+
+src_prepare() {
+ # fix zshall problem with soelim
+ ln -s Doc man1 || die
+ mv Doc/zshall.1 Doc/zshall.1.soelim || die
+ soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
+
+ epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
+ epatch "${FILESDIR}"/${PN}-5.1.0-gcc-5.patch #547950
+
+ cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
+ eprefixify "${T}"/zprofile || die
+ if use prefix ; then
+ sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
+ else
+ sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
+ fi
+ set --
+ file='Src/Zle/complete.mdd'
+ for i in ${COMPLETIONS}
+ do case ${i} in
+ [+-]*)
+ i=${i#?};;
+ esac
+ grep -q "Completion\/${i}" -- "${S}/${file}" \
+ || die "${file} does not contain Completion/${i}"
+ use completion_${i} || set -- "${@}" -e "s/Completion\/${i}[^ ']*//"
+ done
+ [ ${#} -eq 0 ] || sed -i "${@}" -- "${S}/${file}" \
+ || die "patching ${file} failed"
+ epatch_user
+ ! ${LIVE} || eautoreconf
+ PVPATH=$(. "${S}"/Config/version.mk && printf '%s' "${VERSION}") && \
+ [ -n "${PVPATH}" ] || PVPATH=${PV}
+}
+
+src_configure() {
+ local myconf
+ myconf=()
+
+ if use static ; then
+ myconf+=( --disable-dynamic )
+ append-ldflags -static
+ fi
+ if use debug ; then
+ myconf+=(
+ --enable-zsh-debug
+ --enable-zsh-mem-debug
+ --enable-zsh-mem-warning
+ --enable-zsh-secure-free
+ --enable-zsh-hash-debug
+ )
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ myconf+=( --enable-libs=-liconv )
+ append-ldflags -Wl,-x
+ fi
+
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --enable-etcdir="${EPREFIX}"/etc/zsh \
+ --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PVPATH}/help \
+ --enable-fndir="${EPREFIX}"/usr/share/zsh/${PVPATH}/functions \
+ --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --with-tcsetpgrp \
+ $(use_enable maildir maildir-support) \
+ $(use_enable pcre) \
+ $(use_enable caps cap) \
+ $(use_enable unicode multibyte) \
+ $(use_enable gdbm ) \
+ "${myconf[@]}"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ # removed cap and curses because linking failes
+ sed -e "s,link=no,link=static,g" \
+ -e "/^name=zsh\/cap/s,link=static,link=no," \
+ -e "/^name=zsh\/curses/s,link=static,link=no," \
+ -i "${S}"/config.modules || die
+ if ! use gdbm ; then
+ sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
+ "${S}"/config.modules || die
+ fi
+ fi
+}
+
+src_compile() {
+ default
+ ! ${LIVE} || ! use doc || emake -C Doc everything
+}
+
+src_test() {
+ addpredict /dev/ptmx
+ local i
+ for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
+ rm "${S}"/Test/${i} || die
+ done
+ emake check
+}
+
+zcompile_dirs() {
+ use compile || return 0
+ einfo "compiling modules"
+ local i
+ i="${S}/Src/zshpaths.h"
+ test -f "${i}" || die "cannot find ${i}"
+ # We need this directory also in pkg_postinst
+ FPATH_DIR="$(sed -n -e \
+ 's/^#define FPATH_DIR .*\"\(.*\)\".*$/\1/p' -- "${i}" 2>/dev/null)" \
+ || FPATH_DIR=
+ [ -n "${FPATH_DIR}" ] || die "cannot parse ${i}"
+ pushd -- "${ED}" >/dev/null || die
+ test -d ".${FPATH_DIR}" || die "parsing ${i} gave strange result ${FPATH_DIR}"
+ find ".${FPATH_DIR}" -type d -exec "${ED}bin/zsh" -fc 'setopt nullglob
+for i
+do a=(${i}/*(.))
+ [[ ${#a} -eq 0 ]] && continue
+ echo "Compiling ${i#.}.zwc"
+ zcompile -U -M ${i}.zwc ${a} || exit
+done' zsh '{}' '+' || die 'compiling failed. If you are cross-compiling set USE=-compile'
+ popd >/dev/null
+}
+
+touch_zwc() {
+ use compile || return 0
+ einfo "touching *.zwc files"
+ # Make a sanity check that variables are preserved after zcompile_dirs:
+ # If the package mangler is not faulty, this *must* succeeed.
+ [ -n "${FPATH_DIR}" ] && test -d "${FPATH_DIR}" || die "strange FPATH_DIR"
+ # Now the actual action
+ find "${EPREFIX}${FPATH_DIR}" -type f -name '*.zwc' \
+ -exec "$(command -v touch)" -- '{}' '+'
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install install.info
+
+ insinto /etc/zsh
+ doins "${T}"/zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/"${PVPATH}"/functions/Prompts
+ newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
+
+ local i
+
+ # install miscellaneous scripts (bug #54520)
+ sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
+ -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
+ -i "${S}"/{Util,Misc}/* || die
+ for i in Util Misc ; do
+ insinto /usr/share/zsh/"${PVPATH}"/${i}
+ doins ${i}/*
+ done
+
+ # install header files (bug #538684)
+ insinto /usr/include/zsh
+ doins config.h Src/*.epro
+ for i in Src/{zsh.mdh,*.h} ; do
+ sed -e 's@\.\./config\.h@config.h@' \
+ -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
+ -i "${i}"
+ doins "${i}"
+ done
+
+ dodoc ChangeLog* META-FAQ NEWS README config.modules
+ readme.gentoo_create_doc
+
+ if use doc ; then
+ pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
+ dohtml -r Doc/*
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf}
+ popd >/dev/null
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+
+ zcompile_dirs
+
+ rm -vf -- "${ED}"/bin/zsh?*
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+ touch_zwc
+}
diff --git a/app-shells/zsh/zsh-99999999.ebuild b/app-shells/zsh/zsh-99999999.ebuild
new file mode 100644
index 00000000..d5a8bc8e
--- /dev/null
+++ b/app-shells/zsh/zsh-99999999.ebuild
@@ -0,0 +1,301 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic multilib prefix readme.gentoo
+
+MY_PV=${PV/_p/-dev-}
+S=${WORKDIR}/${PN}-${MY_PV}
+
+zsh_ftp="http://www.zsh.org/pub"
+
+ZSH_URI="${zsh_ftp}/${PN}-${MY_PV}.tar.xz"
+ZSH_DOC_URI="${zsh_ftp}/${PN}-${PV%_*}-doc.tar.xz"
+
+DESCRIPTION="UNIX Shell similar to the Korn shell"
+HOMEPAGE="http://www.zsh.org/"
+case ${PV} in
+9999*)
+ SRC_URI=""
+ EGIT_REPO_URI="git://git.code.sf.net/p/zsh/code"
+ inherit git-r3
+ WANT_LIBTOOL="none"
+ inherit autotools
+ KEYWORDS=""
+# Creating help files needs util-linux for colcrt.
+# Please let me know if you have an arch where "colcrt" (or at least "col")
+# is provided by a different package.
+ DEPEND="app-text/yodl
+ dev-lang/perl
+ sys-apps/man
+ sys-apps/util-linux
+ doc? (
+ sys-apps/texinfo
+ app-text/texi2html
+ virtual/latex-base
+ )"
+ PROPERTIES="live"
+ LIVE=:;;
+*)
+ SRC_URI="${ZSH_URI}
+ doc? ( ${ZSH_DOC_URI} )"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ #KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ DEPEND=""
+ LIVE=false;;
+esac
+
+LICENSE="ZSH gdbm? ( GPL-2 )"
+SLOT="0"
+IUSE="caps compile"
+COMPLETIONS="AIX BSD Cygwin Darwin Debian +Linux Mandriva openSUSE Redhat Solaris +Unix +X"
+for curr in ${COMPLETIONS}
+do case ${curr} in
+ [+-]*)
+ IUSE+=" ${curr%%[!+-]*}completion_${curr#?}"
+ continue;;
+ esac
+ IUSE+=" completion_${curr}"
+done
+IUSE+=" debug doc examples gdbm maildir pcre static unicode"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.1:0
+ static? ( >=sys-libs/ncurses-5.7-r4:0=[static-libs] )
+ caps? ( sys-libs/libcap )
+ pcre? (
+ >=dev-libs/libpcre-3.9
+ static? ( >=dev-libs/libpcre-3.9[static-libs] )
+ )
+ gdbm? ( sys-libs/gdbm )
+"
+DEPEND+="
+ sys-apps/groff
+ ${RDEPEND}"
+PDEPEND="
+ examples? ( app-doc/zsh-lovers )
+"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="
+If you want to enable Portage completions and Gentoo prompt,
+emerge app-shells/zsh-completion and add
+ autoload -U compinit promptinit
+ compinit
+ promptinit; prompt gentoo
+to your ~/.zshrc
+
+Also, if you want to enable cache for the completions, add
+ zstyle ':completion::complete:*' use-cache 1
+to your ~/.zshrc
+
+If you want to use run-help add to your ~/.zshrc
+ unalias run-help
+ autoload -Uz run-help
+
+Note that a system zprofile startup file is installed. This will override
+PATH and possibly other variables that a user may set in ~/.zshenv.
+Custom PATH settings and similar overridden variables can be moved
+to ~/.zprofile or other user startup files that are sourced after the
+system zprofile.
+
+If PATH must be set in ~/.zshenv to affect things like non-login ssh shells,
+one method is to use a separate path-setting file that is conditionally sourced
+in ~/.zshenv and also sourced from ~/.zprofile. For more information, see the
+zshenv example in ${EROOT}/usr/share/doc/${PF}/StartupFiles/.
+
+See https://wiki.gentoo.org/wiki/Zsh/HOWTO for more introduction documentation.
+"
+
+src_prepare() {
+ # fix zshall problem with soelim
+ ln -s Doc man1 || die
+ mv Doc/zshall.1 Doc/zshall.1.soelim || die
+ soelim Doc/zshall.1.soelim > Doc/zshall.1 || die
+
+ epatch "${FILESDIR}"/${PN}-init.d-gentoo-r1.diff
+ epatch "${FILESDIR}"/${PN}-5.1.0-gcc-5.patch #547950
+
+ cp "${FILESDIR}"/zprofile-1 "${T}"/zprofile || die
+ eprefixify "${T}"/zprofile || die
+ if use prefix ; then
+ sed -i -e 's|@ZSH_PREFIX@||' -e '/@ZSH_NOPREFIX@/d' "${T}"/zprofile || die
+ else
+ sed -i -e 's|@ZSH_NOPREFIX@||' -e '/@ZSH_PREFIX@/d' -e 's|""||' "${T}"/zprofile || die
+ fi
+ set --
+ file='Src/Zle/complete.mdd'
+ for i in ${COMPLETIONS}
+ do case ${i} in
+ [+-]*)
+ i=${i#?};;
+ esac
+ grep -q "Completion\/${i}" -- "${S}/${file}" \
+ || die "${file} does not contain Completion/${i}"
+ use completion_${i} || set -- "${@}" -e "s/Completion\/${i}[^ ']*//"
+ done
+ [ ${#} -eq 0 ] || sed -i "${@}" -- "${S}/${file}" \
+ || die "patching ${file} failed"
+ epatch_user
+ ! ${LIVE} || eautoreconf
+ PVPATH=$(. "${S}"/Config/version.mk && printf '%s' "${VERSION}") && \
+ [ -n "${PVPATH}" ] || PVPATH=${PV}
+}
+
+src_configure() {
+ local myconf
+ myconf=()
+
+ if use static ; then
+ myconf+=( --disable-dynamic )
+ append-ldflags -static
+ fi
+ if use debug ; then
+ myconf+=(
+ --enable-zsh-debug
+ --enable-zsh-mem-debug
+ --enable-zsh-mem-warning
+ --enable-zsh-secure-free
+ --enable-zsh-hash-debug
+ )
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]]; then
+ myconf+=( --enable-libs=-liconv )
+ append-ldflags -Wl,-x
+ fi
+
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --enable-etcdir="${EPREFIX}"/etc/zsh \
+ --enable-runhelpdir="${EPREFIX}"/usr/share/zsh/${PVPATH}/help \
+ --enable-fndir="${EPREFIX}"/usr/share/zsh/${PVPATH}/functions \
+ --enable-site-fndir="${EPREFIX}"/usr/share/zsh/site-functions \
+ --enable-function-subdirs \
+ --with-tcsetpgrp \
+ $(use_enable maildir maildir-support) \
+ $(use_enable pcre) \
+ $(use_enable caps cap) \
+ $(use_enable unicode multibyte) \
+ $(use_enable gdbm ) \
+ "${myconf[@]}"
+
+ if use static ; then
+ # compile all modules statically, see Bug #27392
+ # removed cap and curses because linking failes
+ sed -e "s,link=no,link=static,g" \
+ -e "/^name=zsh\/cap/s,link=static,link=no," \
+ -e "/^name=zsh\/curses/s,link=static,link=no," \
+ -i "${S}"/config.modules || die
+ if ! use gdbm ; then
+ sed -i '/^name=zsh\/db\/gdbm/s,link=static,link=no,' \
+ "${S}"/config.modules || die
+ fi
+ fi
+}
+
+src_compile() {
+ default
+ ! ${LIVE} || ! use doc || emake -C Doc everything
+}
+
+src_test() {
+ addpredict /dev/ptmx
+ local i
+ for i in C02cond.ztst V08zpty.ztst X02zlevi.ztst Y01completion.ztst Y02compmatch.ztst Y03arguments.ztst ; do
+ rm "${S}"/Test/${i} || die
+ done
+ emake check
+}
+
+zcompile_dirs() {
+ use compile || return 0
+ einfo "compiling modules"
+ local i
+ i="${S}/Src/zshpaths.h"
+ test -f "${i}" || die "cannot find ${i}"
+ # We need this directory also in pkg_postinst
+ FPATH_DIR="$(sed -n -e \
+ 's/^#define FPATH_DIR .*\"\(.*\)\".*$/\1/p' -- "${i}" 2>/dev/null)" \
+ || FPATH_DIR=
+ [ -n "${FPATH_DIR}" ] || die "cannot parse ${i}"
+ pushd -- "${ED}" >/dev/null || die
+ test -d ".${FPATH_DIR}" || die "parsing ${i} gave strange result ${FPATH_DIR}"
+ find ".${FPATH_DIR}" -type d -exec "${ED}bin/zsh" -fc 'setopt nullglob
+for i
+do a=(${i}/*(.))
+ [[ ${#a} -eq 0 ]] && continue
+ echo "Compiling ${i#.}.zwc"
+ zcompile -U -M ${i}.zwc ${a} || exit
+done' zsh '{}' '+' || die 'compiling failed. If you are cross-compiling set USE=-compile'
+ popd >/dev/null
+}
+
+touch_zwc() {
+ use compile || return 0
+ einfo "touching *.zwc files"
+ # Make a sanity check that variables are preserved after zcompile_dirs:
+ # If the package mangler is not faulty, this *must* succeeed.
+ [ -n "${FPATH_DIR}" ] && test -d "${FPATH_DIR}" || die "strange FPATH_DIR"
+ # Now the actual action
+ find "${EPREFIX}${FPATH_DIR}" -type f -name '*.zwc' \
+ -exec "$(command -v touch)" -- '{}' '+'
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install install.info
+
+ insinto /etc/zsh
+ doins "${T}"/zprofile
+
+ keepdir /usr/share/zsh/site-functions
+ insinto /usr/share/zsh/"${PVPATH}"/functions/Prompts
+ newins "${FILESDIR}"/prompt_gentoo_setup-1 prompt_gentoo_setup
+
+ local i
+
+ # install miscellaneous scripts (bug #54520)
+ sed -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
+ -e "s:/usr/local/bin/zsh:${EPREFIX}/bin/zsh:g" \
+ -i "${S}"/{Util,Misc}/* || die
+ for i in Util Misc ; do
+ insinto /usr/share/zsh/"${PVPATH}"/${i}
+ doins ${i}/*
+ done
+
+ # install header files (bug #538684)
+ insinto /usr/include/zsh
+ doins config.h Src/*.epro
+ for i in Src/{zsh.mdh,*.h} ; do
+ sed -e 's@\.\./config\.h@config.h@' \
+ -e 's@#\(\s*\)include "\([^"]\+\)"@#\1include <zsh/\2>@' \
+ -i "${i}"
+ doins "${i}"
+ done
+
+ dodoc ChangeLog* META-FAQ NEWS README config.modules
+ readme.gentoo_create_doc
+
+ if use doc ; then
+ pushd "${WORKDIR}/${PN}-${PV%_*}" >/dev/null
+ dohtml -r Doc/*
+ insinto /usr/share/doc/${PF}
+ doins Doc/zsh.{dvi,pdf}
+ popd >/dev/null
+ fi
+
+ docinto StartupFiles
+ dodoc StartupFiles/z*
+
+ zcompile_dirs
+
+ rm -vf -- "${ED}"/bin/zsh?*
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+ touch_zwc
+}