summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pyrep')
-rw-r--r--dev-util/pyrep/Manifest1
-rw-r--r--dev-util/pyrep/metadata.xml16
-rw-r--r--dev-util/pyrep/pyrep-1.4-r1.ebuild33
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/pyrep/Manifest b/dev-util/pyrep/Manifest
new file mode 100644
index 00000000..516923ed
--- /dev/null
+++ b/dev-util/pyrep/Manifest
@@ -0,0 +1 @@
+DIST pyrep-1.4.tar.gz 8622 SHA256 8051593becdd43ceaa3e0602f4d20c02f85b70233d443147ffbbb9ab715451f4 SHA512 9038b6368930628488f5e47a08262c9a51aec20172e8528d199d113653e445d37a69d4f07c00087cc8359e04fcf864ea72c749d9552b580d8f38ff62d8ec55f7 WHIRLPOOL 7a752cde3c1e84d2900dd3704ef2bdfb72ae06741c801cbcc6c3b11decf88674a108dce704dd4038a5e9c9b21c6b45d37a9e10fadc9853748f8c0bfb0f121fe9
diff --git a/dev-util/pyrep/metadata.xml b/dev-util/pyrep/metadata.xml
new file mode 100644
index 00000000..d9f498ac
--- /dev/null
+++ b/dev-util/pyrep/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/pyrep</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/pyrep/pyrep-1.4-r1.ebuild b/dev-util/pyrep/pyrep-1.4-r1.ebuild
new file mode 100644
index 00000000..c10ea901
--- /dev/null
+++ b/dev-util/pyrep/pyrep-1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+RESTRICT="mirror"
+PYTHON_COMPAT=( jython2_7 pypy{,3} python{2_7,3_{4,5}} )
+inherit eutils python-single-r1
+
+DESCRIPTION="Search and/or replace regular expressions within many files interactively"
+HOMEPAGE="https://github.com/vaeth/pyrep/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}"
+
+src_prepare() {
+ python_fix_shebang "${S}"
+ use prefix || sed -i \
+ -e '1s"^#!/usr/bin/env python$"#!'"${EPREFIX}/usr/bin/python"'"' \
+ -- "${PN}" || die
+ epatch_user
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc AUTHORS README
+}