summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/files/fix-zn1-looping-sound.patch2
-rw-r--r--games-emulation/xmame/xmame-0.106-r2.ebuild (renamed from games-emulation/xmame/xmame-0.106-r1.ebuild)6
-rw-r--r--games-emulation/xmess/files/xmess-0.106-overflow.patch4
-rw-r--r--games-emulation/xmess/xmess-0.106-r1.ebuild8
4 files changed, 10 insertions, 10 deletions
diff --git a/games-emulation/xmame/files/fix-zn1-looping-sound.patch b/games-emulation/xmame/files/fix-zn1-looping-sound.patch
index 66a03ed3..2bd051a0 100644
--- a/games-emulation/xmame/files/fix-zn1-looping-sound.patch
+++ b/games-emulation/xmame/files/fix-zn1-looping-sound.patch
@@ -1,3 +1,5 @@
+# backport fix for looping sounds in the ZN-1
+# by https://github.com/Francesco149/
diff --git a/src/sound/psx.c b/src/sound/psx.c
index aa887e2..9c86ace 100644
--- a/src/sound/psx.c
diff --git a/games-emulation/xmame/xmame-0.106-r1.ebuild b/games-emulation/xmame/xmame-0.106-r2.ebuild
index 0de58c20..f99f68f5 100644
--- a/games-emulation/xmame/xmame-0.106-r1.ebuild
+++ b/games-emulation/xmame/xmame-0.106-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -58,8 +58,6 @@ toggle_feature2() {
}
src_prepare() {
- default
-
local mycpu
case ${ARCH} in
@@ -144,7 +142,7 @@ EOF
-e 's/doinstallsuid/doinstall/' \
-e '/^QUIET/s:^:#:' src/unix/unix.mak \
|| die "sed src/unix/unix.mak failed"
- eapply_user
+ default
}
src_compile() {
diff --git a/games-emulation/xmess/files/xmess-0.106-overflow.patch b/games-emulation/xmess/files/xmess-0.106-overflow.patch
index 0c4c2ac1..c231c568 100644
--- a/games-emulation/xmess/files/xmess-0.106-overflow.patch
+++ b/games-emulation/xmess/files/xmess-0.106-overflow.patch
@@ -1,5 +1,5 @@
---- mess/machine/corvushd.c.old 2011-06-30 11:41:55.987772189 +0200
-+++ mess/machine/corvushd.c 2011-06-30 11:42:15.215986836 +0200
+--- a/mess/machine/corvushd.c
++++ b/mess/machine/corvushd.c
@@ -243,7 +243,7 @@
/* */
struct {
diff --git a/games-emulation/xmess/xmess-0.106-r1.ebuild b/games-emulation/xmess/xmess-0.106-r1.ebuild
index 612d0068..643a9060 100644
--- a/games-emulation/xmess/xmess-0.106-r1.ebuild
+++ b/games-emulation/xmess/xmess-0.106-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2016 Gentoo Foundation
+# Copyright 2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ TARGET="${PN}"
DESCRIPTION="Multiple Arcade Machine Emulator for X11"
HOMEPAGE="http://x.mame.net/"
-SRC_URI="http://x.mame.net/download/xmame-${PV}.tar.bz2"
+SRC_URI="http://gentoo.osuosl.org/distfiles/xmame-${PV}.tar.bz2"
LICENSE="XMAME"
SLOT="0"
@@ -43,6 +43,7 @@ DEPEND="${RDEPEND}
# icc? ( dev-lang/icc )
S=${WORKDIR}/xmame-${PV}
+PATCHES=("${FILESDIR}"/${P}-overflow.patch)
toggle_feature() {
if use $1 ; then
@@ -141,8 +142,7 @@ EOF
-e 's/doinstallsuid/doinstall/' \
-e '/^QUIET/s:^:#:' src/unix/unix.mak \
|| die "sed src/unix/unix.mak failed"
- eapply -p0 "${FILESDIR}"/${P}-overflow.patch
- eapply_user
+ default
}
src_compile() {