summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/m5figur-mv')
-rw-r--r--games-rpg/m5figur-mv/Manifest1
-rw-r--r--games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild50
-rw-r--r--games-rpg/m5figur-mv/metadata.xml19
3 files changed, 70 insertions, 0 deletions
diff --git a/games-rpg/m5figur-mv/Manifest b/games-rpg/m5figur-mv/Manifest
new file mode 100644
index 00000000..b4a5da20
--- /dev/null
+++ b/games-rpg/m5figur-mv/Manifest
@@ -0,0 +1 @@
+DIST m5figur-mv-2.4.tar.gz 19263 SHA256 f01e88d8d05ff780fc9d4d97671dc7cd353df37094ddf5307f85e16e5041ef2e SHA512 2229896d120e78573f0add5c8e14f8d589da6d1cf4dc590f4cbc46e9112bda0926404b68f755d2b9ffb9b846b53eb556c53bc6bc1c45d4c0d5b20088bd5ccd4d WHIRLPOOL 073c6e67dc1e8ca183b5c1aca48dd20c944879193c4dd4f703f298d5e63cd915fcdbba8ce6f334e9ae2aea6179262e4e6815c53d122c00b09c7dd990f73c6c79
diff --git a/games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild b/games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild
new file mode 100644
index 00000000..068b1bdc
--- /dev/null
+++ b/games-rpg/m5figur-mv/m5figur-mv-2.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+# Do *not* inherit latex-package: It DEPENDS unconditionally on texinfo.
+# Moreover, it would attempt to compile the *.tex example with texinfo to dvi.
+inherit eutils
+RESTRICT="mirror"
+
+DESCRIPTION="LaTeX2e character sheet layout for the Midgard Role Playing Game (Edition M5)"
+HOMEPAGE="https://github.com/vaeth/m5figur-mv/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples"
+# We need texlive-latexextra for toolbox.sty
+RDEPEND="virtual/latex-base
+ dev-texlive/texlive-latexextra"
+DEPEND="examples? ( ${RDEPEND} )"
+
+src_compile() {
+ if use examples
+ then einfo "Compiling example character sheet as pdf"
+ export VARTEXFONTS="${T}/fonts"
+ pdflatex *.tex && test -s *.pdf || die "could not create example"
+ fi
+}
+
+src_install() {
+ TEXMF="/usr/share/texmf-site"
+ insinto "${TEXMF}/tex/latex/${PN}"
+ doins *.cls
+ insinto "${TEXMF}/doc/latex/${PN}"
+ doins *.tex
+ if use examples
+ then doins *.pdf
+ fi
+ dodoc README
+}
+
+pkg_postinst() {
+ texconfig rehash
+}
+
+pkg_postrm() {
+ texconfig rehash
+}
diff --git a/games-rpg/m5figur-mv/metadata.xml b/games-rpg/m5figur-mv/metadata.xml
new file mode 100644
index 00000000..f388f698
--- /dev/null
+++ b/games-rpg/m5figur-mv/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>martin@mvath.de</email>
+ <name>Martin Väth</name>
+ </maintainer>
+ <bugs-to>mailto:martin@mvath.de</bugs-to>
+ <remote-id type="github">vaeth/m5figur-mv</remote-id>
+ </upstream>
+ <use>
+ <flag name="examples">Compile example character sheet as PDF</flag>
+ </use>
+</pkgmetadata>