summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squash_dir')
-rw-r--r--sys-fs/squash_dir/Manifest2
-rw-r--r--sys-fs/squash_dir/squash_dir-13.8.ebuild23
2 files changed, 14 insertions, 11 deletions
diff --git a/sys-fs/squash_dir/Manifest b/sys-fs/squash_dir/Manifest
index d20b18bb..8a037cd9 100644
--- a/sys-fs/squash_dir/Manifest
+++ b/sys-fs/squash_dir/Manifest
@@ -1 +1 @@
-DIST squash_dir-13.8.tar.gz 31453 SHA256 f123d76ef3d6572ca9e1cb1c239e2fff925cdc8ae65b4047d8b50e351004b5d1 SHA512 0f86f387077a5878612e9847602d1c2e255b79bfcbae5573a6bf413d72ff8b3246b12583ea7050188feb116e55e7704ae9dd2d02df35ce072a2205c1eadfad32 WHIRLPOOL 46bde67d35b7540a28c0a768438a46bec035dbd9c92289e42448de744b054fed4e6bc79a75cea5ab126740a486877896f31b892a661a15bfe8541eb6ed6f9671
+DIST squash_dir-13.8.tar.gz 31453 SHA256 f123d76ef3d6572ca9e1cb1c239e2fff925cdc8ae65b4047d8b50e351004b5d1
diff --git a/sys-fs/squash_dir/squash_dir-13.8.ebuild b/sys-fs/squash_dir/squash_dir-13.8.ebuild
index 73072d21..7db07095 100644
--- a/sys-fs/squash_dir/squash_dir-13.8.ebuild
+++ b/sys-fs/squash_dir/squash_dir-13.8.ebuild
@@ -2,11 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
RESTRICT="mirror"
WANT_LIBTOOL=none
AUTOTOOLS_IN_SOURCE_BUILD=true
-inherit autotools autotools-utils eutils linux-info readme.gentoo systemd
+inherit autotools eutils linux-info readme.gentoo systemd
DESCRIPTION="Keep directories compressed with squashfs. Useful for portage tree, texmf-dist"
HOMEPAGE="http://forums.gentoo.org/viewtopic-t-465367.html"
@@ -52,7 +52,7 @@ src_prepare() {
-e '1s"^#!/usr/bin/env sh$"#!'"${EPREFIX}/bin/sh"'"' \
-- bin/* sbin/* || die
fi
- epatch_user
+ eapply_user
eautoreconf
}
@@ -61,21 +61,23 @@ src_configure() {
use unionfs-fuse && order=unionfs-fuse
use aufs && order=aufs
use overlayfs && order=overlayfs
- local myeconfargs=(
- --with-zsh-completion
- "$(use_enable bundled-openrc-wrapper openrc-wrapper)"
- "$(systemd_with_unitdir)"
+ econf --with-zsh-completion \
+ "$(use_enable bundled-openrc-wrapper openrc-wrapper)" \
+ --with-systemdsystemunitdir="$(systemd_get_unitdir)" \
${order:+"--with-first-order=${order}"}
- )
- autotools-utils_src_configure
}
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+
linux_config_missing() {
! linux_config_exists || ! linux_chkconfig_present "${1}"
}
pkg_postinst() {
- readme.gentoo_pkg_postinst
local fs=overlayfs
use unionfs-fuse && fs=unionfs-fuse
use aufs && fs=aufs
@@ -97,4 +99,5 @@ pkg_postinst() {
esac
optfeature "improved output" 'sys-fs/squashfs-tools[progress-redirect]'
optfeature "status bar support" 'app-shells/runtitle'
+ readme.gentoo_print_elog
}