summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Kaiser <nikai@nikai.net>2010-07-19 13:03:33 +0200
committerNicolas Kaiser <nikai@nikai.net>2010-07-19 13:03:33 +0200
commit9864e32b810b442c78169d87ae6f0c4f155a3966 (patch)
tree8be8d193ea3d1b2d5e01d51392ed48c72c5af322 /games-simulation/vegastrike-data
downloadnikai-9864e32b810b442c78169d87ae6f0c4f155a3966.tar.gz
nikai-9864e32b810b442c78169d87ae6f0c4f155a3966.tar.bz2
nikai-9864e32b810b442c78169d87ae6f0c4f155a3966.zip
initial commit
Diffstat (limited to 'games-simulation/vegastrike-data')
-rw-r--r--games-simulation/vegastrike-data/Manifest2
-rw-r--r--games-simulation/vegastrike-data/metadata.xml9
-rw-r--r--games-simulation/vegastrike-data/vegastrike-data-9999.ebuild71
3 files changed, 82 insertions, 0 deletions
diff --git a/games-simulation/vegastrike-data/Manifest b/games-simulation/vegastrike-data/Manifest
new file mode 100644
index 0000000..f6a80fb
--- /dev/null
+++ b/games-simulation/vegastrike-data/Manifest
@@ -0,0 +1,2 @@
+EBUILD vegastrike-data-9999.ebuild 1754 RMD160 d6d86ce9cc0430533491ca5dd87277e91b6990a1 SHA1 b01077088de681976f305efd021fec8c8987909d SHA256 0257f145422ca0d9066d7dca4d580be1cab61505ced1189cf094ff448faa6aef
+MISC metadata.xml 599 RMD160 f72a40de6ab575b080e83159f217823c9ae242e8 SHA1 e95e0172986a1fd0c89288d7ce2c9c3d9f2ec0fd SHA256 fc132bb4479504e400941fcf25eb0434468a556386f7f01f06da4009805dddfe
diff --git a/games-simulation/vegastrike-data/metadata.xml b/games-simulation/vegastrike-data/metadata.xml
new file mode 100644
index 0000000..cda9271
--- /dev/null
+++ b/games-simulation/vegastrike-data/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>nikai@nikai.net</email>
+</maintainer>
+<longdescription>Vega Strike is an Open Source 3D Action-Space-Sim that lets you trade, fight, and explore in a vast universe. The data branch of Vega Strike contains 3D models, textures and backgrounds, and also documentation. Parts of this branch are generated from original master files in the master branch. The data branch is required to play the game.</longdescription>
+</pkgmetadata>
diff --git a/games-simulation/vegastrike-data/vegastrike-data-9999.ebuild b/games-simulation/vegastrike-data/vegastrike-data-9999.ebuild
new file mode 100644
index 0000000..d6751bd
--- /dev/null
+++ b/games-simulation/vegastrike-data/vegastrike-data-9999.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Derived from bug 65084
+
+inherit eutils games
+[ "$PV" == "9999" ] && inherit subversion
+
+ESVN_REPO_URI="https://vegastrike.svn.sourceforge.net/svnroot/vegastrike/trunk"
+ESVN_PROJECT="vegastrike"
+ESVN_BOOTSTRAP="vegastrike/bootstrap-sh"
+
+DESCRIPTION="A 3D space simulator that allows you to trade and bounty hunt"
+HOMEPAGE="http://vegastrike.sourceforge.net/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ games_pkg_setup
+}
+
+src_unpack() {
+ cd "${S}"
+ local svn=${ESVN_TOP_DIR}
+
+ if ([ ! -d "${svn}/data" ] && [ ! -d "${svn}/data" ]); then
+ ESVN_MODULE="data"
+ ESVN_MODULE_DIR="${ESVN_REPO_URI}/${ESVN_MODULE}"
+ subversion_fetch $ESVN_MODULE_DIR $ESVN_MODULE || die "Fetching data failed"
+ fi
+
+ einfo "Copying data to work directory..."
+ cp -a "${svn}"/{data} "${S}" >&/dev/null
+
+ cd "${S}"/data
+ # Clean up data dir
+ esvn_clean "${S}"
+ find "${S}" -name "*.pyc" -type f -exec rm -f '{}' \; >&/dev/null
+
+ # Sort out directory references
+ sed -i \
+ -e "s!/usr/local/share/doc!/usr/share/doc!" \
+ -e "s!/usr/local/share/vegastrike!${GAMES_DATADIR}/vegastrike!" \
+ -e "s!/usr/local/bin!${GAMES_BINDIR}!" \
+ -e "s!/usr/local/lib/man!/usr/share/man!" \
+ "${S}/data/documentation/vegastrike.1" \
+ || die "sed data/documentation/vegastrike.1 failed"
+}
+
+src_install() {
+ doman "${S}"/data/documentation/*.1
+ dodoc "${S}"/data/documentation/*.txt
+
+ doicon "${S}/data/vegastrike.xpm"
+
+ dodir "${GAMES_DATADIR}/vegastrike"
+ cp -r data/ "${D}/${GAMES_DATADIR}/vegastrike/" || die "cp failed (data)"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+}