summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtur Maciąg <maciag.artur@gmail.com>2010-04-22 15:55:36 +0200
committerArtur Maciąg <maciag.artur@gmail.com>2010-04-22 15:55:36 +0200
commit273f9c095a4a0c07c2d0784c177c1cffbb415728 (patch)
treeb71cc6e46d6312125d36d30a158edbf3cfb844b3
parentskipfish ebuilds removal; present in main tree (diff)
downloadpiczu-273f9c095a4a0c07c2d0784c177c1cffbb415728.tar.gz
piczu-273f9c095a4a0c07c2d0784c177c1cffbb415728.tar.bz2
piczu-273f9c095a4a0c07c2d0784c177c1cffbb415728.zip
django-evolution live ebuild updated
-rw-r--r--dev-python/django-evolution/Manifest2
-rw-r--r--dev-python/django-evolution/django-evolution-9999.ebuild21
2 files changed, 17 insertions, 6 deletions
diff --git a/dev-python/django-evolution/Manifest b/dev-python/django-evolution/Manifest
index f6faf04..6d43932 100644
--- a/dev-python/django-evolution/Manifest
+++ b/dev-python/django-evolution/Manifest
@@ -1 +1 @@
-EBUILD django-evolution-9999.ebuild 495 RMD160 8d2d5f51485a7d3a3bf928d52da6cabff954e93d SHA1 a9e3766d3a2229abc49fb1d454907c62bfed76c2 SHA256 9bfe5888fd7a208504c48cfd0e0e3d452c6279f33e6ade25d5adf22a2f48954a
+EBUILD django-evolution-9999.ebuild 691 RMD160 9c80bffa9cdfdcec57525beaf270a09cfe825110 SHA1 ebd0243b89ba75c039714a9e0dc22a8beed692d2 SHA256 f4d0da627366b1b28f143ca97fde0bfcea789b1305e17ecb744f2897f59f456e
diff --git a/dev-python/django-evolution/django-evolution-9999.ebuild b/dev-python/django-evolution/django-evolution-9999.ebuild
index ad44634..0bdc3ac 100644
--- a/dev-python/django-evolution/django-evolution-9999.ebuild
+++ b/dev-python/django-evolution/django-evolution-9999.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: Exp $
+# $Header: $
+
+EAPI="2"
ESVN_REPO_URI="http://django-evolution.googlecode.com/svn/trunk/"
-inherit distutils eutils subversion
+inherit distutils subversion
DESCRIPTION="Schema Evolution for the Django Project"
HOMEPAGE="http://code.google.com/p/django-evolution/"
@@ -14,7 +16,16 @@ KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""
RDEPEND=">=dev-python/django-1.0"
-DEPEND="${RDEPEND}"
+DEPEND="dev-python/setuptools"
+
+PYTHON_MODNAME="django_evolution"
-DOCS="docs/* AUTHORS README"
+src_test() {
+ python setup.py test || die "tests failed"
+}
+src_install () {
+ distutils_src_install
+ rm -fr "${D}"usr/lib*/python*/site-packages/tests
+ dodoc docs/*
+}