summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/rtmpdump/files/rtmpdump-darwin-10.6.patch')
-rw-r--r--media-video/rtmpdump/files/rtmpdump-darwin-10.6.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-video/rtmpdump/files/rtmpdump-darwin-10.6.patch b/media-video/rtmpdump/files/rtmpdump-darwin-10.6.patch
new file mode 100644
index 0000000..5a229b3
--- /dev/null
+++ b/media-video/rtmpdump/files/rtmpdump-darwin-10.6.patch
@@ -0,0 +1,48 @@
+--- librtmp/Makefile.orig 2010-11-14 19:05:15 +0100
++++ librtmp/Makefile 2010-11-14 19:10:05 +0100
+@@ -25,12 +25,12 @@
+ CRYPTO_REQ=$(REQ_$(CRYPTO))
+ CRYPTO_DEF=$(DEF_$(CRYPTO))
+
+-SO_posix=so.0
++SO_posix=0.dylib
+ SO_mingw=dll
+ SO_EXT=$(SO_$(SYS))
+
+ SHARED=yes
+-SODEF_yes=-fPIC
++SODEF_yes=-fPIC -fno-common
+ SOLIB_yes=librtmp.$(SO_EXT)
+ SOINST_yes=install_$(SO_EXT)
+ SO_DEF=$(SODEF_$(SHARED))
+@@ -55,14 +55,14 @@
+ all: librtmp.a $(SO_LIB)
+
+ clean:
+- rm -f *.o *.a *.so *.$(SO_EXT)
++ rm -f *.o *.a *.dylib *.$(SO_EXT)
+
+ librtmp.a: $(OBJS)
+ $(AR) rs $@ $?
+
+ librtmp.$(SO_EXT): $(OBJS)
+- $(CC) -shared -Wl,-soname,$@ $(LDFLAGS) -o $@ $^ $> $(CRYPTO_LIB)
+- ln -sf $@ librtmp.so
++ $(CC) -shared -current_version 1.0.0 -compatibility_version 1.0.0 $(LDFLAGS) -o $@ $^ $> $(CRYPTO_LIB)
++ ln -sf $@ librtmp.dylib
+
+ log.o: log.c log.h Makefile
+ rtmp.o: rtmp.c rtmp.h rtmp_sys.h handshake.h dh.h log.h amf.h Makefile
+@@ -83,9 +83,9 @@
+ cp librtmp.pc $(LIBDIR)/pkgconfig
+ cp librtmp.3 $(MANDIR)/man3
+
+-install_so.0: librtmp.so.0
+- cp librtmp.so.0 $(LIBDIR)
+- cd $(LIBDIR); ln -sf librtmp.so.0 librtmp.so
++install_0.dylib: librtmp.0.dylib
++ cp librtmp.0.dylib $(LIBDIR)
++ cd $(LIBDIR); ln -sf librtmp.0.dylib librtmp.dylib
+
+ install_dll: librtmp.dll
+ cp librtmp.dll $(BINDIR)