summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2022-03-15 13:54:04 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2022-03-15 13:54:04 +0800
commit073022939b70b856777bbe6604c1a2123891d4e0 (patch)
treecf1fde0db0dae89aeee835524642b75ea86e2268
parent[net-analyzer/amass] new ebuild (diff)
downloadpigfoot-073022939b70b856777bbe6604c1a2123891d4e0.tar.gz
pigfoot-073022939b70b856777bbe6604c1a2123891d4e0.tar.bz2
pigfoot-073022939b70b856777bbe6604c1a2123891d4e0.zip
[net-analyzer/amass] apply new go-module guideline
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--net-analyzer/amass/amass-9999.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/net-analyzer/amass/amass-9999.ebuild b/net-analyzer/amass/amass-9999.ebuild
index f868e67..50a1017 100644
--- a/net-analyzer/amass/amass-9999.ebuild
+++ b/net-analyzer/amass/amass-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
EGO_PN="github.com/OWASP/Amass"
@@ -13,18 +13,23 @@ if [[ ${PV} == *9999* ]]; then
src_unpack() {
git-r3_src_unpack
- #go-module_live_vendor
+ go-module_live_vendor
}
else
EGO_VER="v${PV}"
- SRC_URI="https://${EGO_PN}/archive/${EGO_VER}.tar.gz -> ${P}.tar.gz"
+ #SRC_URI="https://${EGO_PN}/archive/${EGO_VER}.tar.gz -> ${P}.tar.gz"
- #EGO_SUM=(
- #)
- #go-module_set_globals
+ #SRC_URI+="${EGO_SUM_SRC_URI}"
+ #S="${WORKDIR}/Amass-${PV}"
+ inherit git-r3
+ EGIT_REPO_URI="https://${EGO_PN}.git"
+ EGIT_COMMIT="${EGO_VER}"
+
+ src_unpack() {
+ git-r3_src_unpack
+ go-module_live_vendor
+ }
- SRC_URI+="${EGO_SUM_SRC_URI}"
- S="${WORKDIR}/Amass-${PV}"
KEYWORDS="~amd64 ~x86 ~arm64 ~arm"
fi
@@ -42,9 +47,8 @@ src_compile() {
local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
set -- env \
- GOCACHE="${T}/go-cache" \
CGO_ENABLED=0 \
- go build -o "bin/${PN}" -mod=readonly -v -work -x ${build_flags} \
+ go build -o "bin/${PN}" -mod=vendor -v -work -x ${build_flags} \
./cmd/${PN}
echo "$@"
"$@" || die