summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2017-05-19 14:09:35 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2017-05-19 14:09:35 +0800
commit5d774dbd3b916a7dd87fa45d26ab0044d06749c1 (patch)
tree3eedb82bdcdd224d953977c2d1d33f34acfdac96
parent[net-libs/nodejs] Remove due to https://github.com/gentoo/libressl/issues/154 (diff)
downloadpigfoot-5d774dbd3b916a7dd87fa45d26ab0044d06749c1.tar.gz
pigfoot-5d774dbd3b916a7dd87fa45d26ab0044d06749c1.tar.bz2
pigfoot-5d774dbd3b916a7dd87fa45d26ab0044d06749c1.zip
[app-admin/google-compute-engine] Version bump 2.3.6
-rw-r--r--app-admin/google-compute-engine/google-compute-engine-2.3.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/google-compute-engine/google-compute-engine-2.3.6.ebuild b/app-admin/google-compute-engine/google-compute-engine-2.3.6.ebuild
new file mode 100644
index 0000000..84767b9
--- /dev/null
+++ b/app-admin/google-compute-engine/google-compute-engine-2.3.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy{,3} )
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Scripts and tools for Google Compute Engine Linux images."
+HOMEPAGE="https://github.com/GoogleCloudPlatform/compute-image-packages"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-python/boto[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+
+python_install_all() {
+ for _s in google-accounts-daemon \
+ google-clock-skew-daemon \
+ google-instance-setup \
+ google-ip-forwarding-daemon \
+ google-network-setup \
+ google-shutdown-scripts \
+ google-startup-scripts;
+ do
+ newinitd "${FILESDIR}/sysvinit/${_s}-20160803" "${_s}"
+ systemd_newunit "${FILESDIR}/systemd/${_s}.service-20160803" "${_s}.service"
+ done
+
+ # Install google-compute-engine python modules.
+ distutils-r1_python_install_all
+}