summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2020-02-20 13:59:09 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2020-02-20 13:59:09 +0800
commit92d1927bd1dfff2cedbb3f827aaef487e97615f4 (patch)
treec9c4f7a730757e0e375611072854c48c553a51e8
parentAdd sys-apps/go-tldr v20200111 (diff)
downloadpigfoot-92d1927bd1dfff2cedbb3f827aaef487e97615f4.tar.gz
pigfoot-92d1927bd1dfff2cedbb3f827aaef487e97615f4.tar.bz2
pigfoot-92d1927bd1dfff2cedbb3f827aaef487e97615f4.zip
[net-misc/BaiduPCS-Go] Version bump to 3.6.1
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
-rw-r--r--net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.1.ebuild (renamed from net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.ebuild)5
-rw-r--r--net-misc/BaiduPCS-Go/Manifest1
-rw-r--r--net-misc/grive/Manifest1
-rw-r--r--net-misc/grive/grive-0.5.1_pre20161004.ebuild35
-rw-r--r--net-misc/grive/metadata.xml11
5 files changed, 5 insertions, 48 deletions
diff --git a/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.ebuild b/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.1.ebuild
index 1748464..7ff3760 100644
--- a/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.ebuild
+++ b/net-misc/BaiduPCS-Go/BaiduPCS-Go-3.6.1.ebuild
@@ -16,12 +16,15 @@ SRC_URI="${ARCHIVE_URI}"
RESTRICT="mirror"
LICENSE="MIT"
-SLOT="0"
+SLOT="0/${PVR}"
KEYWORDS="~amd64 ~x86 ~arm"
IUSE="+pie"
src_compile() {
+ # -buildmode=pie forces external linking mode, even CGO_ENABLED=0
+ # https://github.com/golang/go/issues/18968
use pie && local build_pie="-buildmode=pie"
+
local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
diff --git a/net-misc/BaiduPCS-Go/Manifest b/net-misc/BaiduPCS-Go/Manifest
index c8cc582..4f86124 100644
--- a/net-misc/BaiduPCS-Go/Manifest
+++ b/net-misc/BaiduPCS-Go/Manifest
@@ -1 +1,2 @@
+DIST BaiduPCS-Go-3.6.1.tar.gz 909054 BLAKE2B 6c4c772580c5f103047943ac09c160d22ddde68453a2ab9f6592653c1c408370dc2d1e5af6c3c6f3acca5774264daf2cf5d145136d80d072cbb83924399b6c81 SHA512 796e204ab940417b7a1de04bdbd3723febb3c913bb76db362ddf3af7faf05ef71307f90dc4b0b6a0bcf6c41c4cf4b364a4128ca7cbd391f127d948f3deb8429a
DIST BaiduPCS-Go-3.6.tar.gz 524914 BLAKE2B 8d29542d509d75ece8756b5d909dd94ca827a74a14edca668a9223df026183a79a29c3e0fd067d5cc482c2852a26a90e77231d497b1db38c20e857db228e5864 SHA512 62082f0a1bedfb495d9b096ae06effacbf917cc721ff537522fb95b15e32300927a6cbaccd94f4c2881953af8eb69782d43ac35b195c647b3b67b7c664e3f3d0
diff --git a/net-misc/grive/Manifest b/net-misc/grive/Manifest
deleted file mode 100644
index 3d892d5..0000000
--- a/net-misc/grive/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST grive-0.5.1_pre20161004.tar.gz 163085 SHA256 d3ca4b728ba38ff735afbd308effaf18a6c1586487e9e15c8b4854144eb916f7 SHA512 1de5c2956d898d0a67e28469d7cf054e83b63f6dca736a60f875fbaac3197bc425432c43db2472e87113df2fa5da49eff9e17cd33610ccda7ba5bf0c2d4966c0 WHIRLPOOL 76148f8fe94cb0f5846e178d3bc9f35d61bded9181cc2835ae78040ee1b37fedeca6e1d7e8db7a55ed6e9390aca4135fda4e7f1aaa40621d618aab908c33e075
diff --git a/net-misc/grive/grive-0.5.1_pre20161004.ebuild b/net-misc/grive/grive-0.5.1_pre20161004.ebuild
deleted file mode 100644
index a88fa90..0000000
--- a/net-misc/grive/grive-0.5.1_pre20161004.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-2
- EGIT_REPO_URI="git://github.com/vitalif/${PN}2.git"
-else
- inherit vcs-snapshot
- COMMIT="7bbb01c3014cc996ec24a7e5c0684f24b604b735"
- SRC_URI="https://github.com/vitalif/${PN}2/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="An open source Linux client for Google Drive"
-HOMEPAGE="https://github.com/vitalif/grive2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/expat
- >=dev-libs/json-c-0.11-r1:=
- dev-libs/libgcrypt:0=
- || ( net-misc/curl[curl_ssl_openssl] net-misc/curl[curl_ssl_gnutls] net-misc/curl[curl_ssl_libressl] )
- sys-libs/binutils-libs:0=
- sys-libs/glibc
- dev-libs/yajl
-"
-DEPEND="${RDEPEND}"
diff --git a/net-misc/grive/metadata.xml b/net-misc/grive/metadata.xml
deleted file mode 100644
index f17224c..0000000
--- a/net-misc/grive/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>junghans@gentoo.org</email>
- <name>Christoph Junghans</name>
- </maintainer>
- <upstream>
- <remote-id type="github">Grive/grive</remote-id>
- </upstream>
-</pkgmetadata>