summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChen, Chih-Chia <pigfoot@gmail.com>2022-03-17 12:00:53 +0800
committerChen, Chih-Chia <pigfoot@gmail.com>2022-03-17 12:00:53 +0800
commitbc7acd1e0db4cef1aa9d829ed251d551b3540c2c (patch)
tree3fad3dbbd32dd108199ed98fd8b56a32d6d33172
parentapply new go-module guideline (diff)
downloadpigfoot-bc7acd1e0db4cef1aa9d829ed251d551b3540c2c.tar.gz
pigfoot-bc7acd1e0db4cef1aa9d829ed251d551b3540c2c.tar.bz2
pigfoot-bc7acd1e0db4cef1aa9d829ed251d551b3540c2c.zip
[net-misc/ipinfo] apply new go-module guideline
Signed-off-by: Chen, Chih-Chia <pigfoot@gmail.com>
l---------net-misc/ipinfo/ipinfo-2.7.0-r1.ebuild (renamed from net-misc/ipinfo/ipinfo-2.7.0.ebuild)0
-rw-r--r--net-misc/ipinfo/ipinfo-9999.ebuild32
2 files changed, 18 insertions, 14 deletions
diff --git a/net-misc/ipinfo/ipinfo-2.7.0.ebuild b/net-misc/ipinfo/ipinfo-2.7.0-r1.ebuild
index b96626e..b96626e 120000
--- a/net-misc/ipinfo/ipinfo-2.7.0.ebuild
+++ b/net-misc/ipinfo/ipinfo-2.7.0-r1.ebuild
diff --git a/net-misc/ipinfo/ipinfo-9999.ebuild b/net-misc/ipinfo/ipinfo-9999.ebuild
index 5f894a3..46d954f 100644
--- a/net-misc/ipinfo/ipinfo-9999.ebuild
+++ b/net-misc/ipinfo/ipinfo-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
EGO_PN="github.com/ipinfo/cli"
@@ -10,25 +10,29 @@ inherit go-module
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://${EGO_PN}.git"
+ EGO_VER="devel"
src_unpack() {
git-r3_src_unpack
#go-module_live_vendor
}
else
- EGO_VER="${P}"
- SRC_URI="https://${EGO_PN}/archive/${EGO_VER}.tar.gz -> ${P}.tar.gz"
-
- EGO_SUM=(
- )
- go-module_set_globals
-
- SRC_URI+="${EGO_SUM_SRC_URI}"
- S="${WORKDIR}/cli-${EGO_VER}"
+ EGO_VER="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${P}.tar.gz -> ${P}.tar.gz"
+ #inherit git-r3
+ #EGIT_REPO_URI="https://${EGO_PN}.git"
+ #EGIT_COMMIT="${EGO_VER}"
+
+ #src_unpack() {
+ # git-r3_src_unpack
+ # go-module_live_vendor
+ #}
+
+ S="${WORKDIR}/cli-${P}"
KEYWORDS="~amd64 ~x86 ~arm64 ~arm"
fi
-DESCRIPTION="Official Command Line Interface for the IPinfo API "
+DESCRIPTION="Official Command Line Interface for the IPinfo API"
LICENSE="Apache-2.0"
SLOT="0/${PVR}"
RESTRICT="mirror"
@@ -40,16 +44,16 @@ src_compile() {
use pie && local build_pie="-buildmode=pie"
local build_flags="$( echo ${EGO_BUILD_FLAGS} ) $( echo ${build_pie} )"
+ local ld_flags="$( echo "" )"
set -- env \
- GOCACHE="${T}/go-cache" \
CGO_ENABLED=0 \
- go build -o "bin/${PN}" -mod=vendor -v -work -x ${build_flags} \
+ go build -o "bin/${PN}" -mod=vendor -v -work -x ${build_flags} -ldflags "${ld_flags}" \
./${PN}
echo "$@"
"$@" || die
}
src_install() {
- dobin bin/${PN}
+ dobin bin/*
}