summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/lyx')
-rw-r--r--app-office/lyx/Manifest3
-rw-r--r--app-office/lyx/files/2.1-python.patch29
2 files changed, 32 insertions, 0 deletions
diff --git a/app-office/lyx/Manifest b/app-office/lyx/Manifest
index 2886014..170f676 100644
--- a/app-office/lyx/Manifest
+++ b/app-office/lyx/Manifest
@@ -1,6 +1,9 @@
+AUX 2.1-python.patch 1019 BLAKE2B 1ca2692b77850998f49e93f43dc371d05e33438f867c352bdbf085a86a280e11fa5d00d738661875ede0041907683ced98407ce75676d638f35ae0a92cfd0f54 SHA512 039d3521bc1d646669fcccb43d04354dfe7ed32477a338c27a576c77e5ffcf15fcf0419c14df43aa37d727431cce6ab0327aa04199d09ce1749051ab12686df8
AUX 2.3-python.patch 1049 BLAKE2B 94591099e6b0d52429fa1e066475283ae35ba89a5d07f190dd80aa38ad040cbf53dda3f85f4f12894fc39822309aa7b4cc2bf947d8720caf228c734b7fcee8b1 SHA512 8f2fda91c4c35ffdf3325fc6613df1c5ecd87ced88e4d690aef5c7085edda1b66c0ae704e266521627f7a82eb8b4e2f35fed0f14b37feb367422ef1c5693e31d
AUX 2.3.patches 5131 BLAKE2B ec1dc5f3bf9c59e6763f1c24e844fb47d9d1e902ee85d6435edc0ab48e4600bf737533286fcd1f97864e2f2b8be29eaf125d73b874a0bf384c9fa05c713348c8 SHA512 95bc5cc7026af7488ec852cc043d77126e89ca960578b9c2a487d3bc7387413b33446969bbed56d355ad02d4bd48bfa95197ae516f853b7afc705b9e699acc87
AUX legacy.patch 1491 BLAKE2B 0e6164120f436b4620e314b827686b3977ea925f48ce566170228cecb8cd8a3fb97341a30ba80e99b372c38726e7646ee02842bbbb38d086c2faf6aaa952f49a SHA512 c2a02a20f10a24e2c06ce0a1958b62809ec0149f05c875ddff223f2ee12f15e8991ff93f7f7b7672b68d7b2ff27f9320fc181a4a96b1e8ad412fa7948b832e8f
+DIST lyx-2.2.4.tar.xz 15596628 BLAKE2B f60d1a4ba66d5d42629d02f084ec5a168a4d6f46a88d4f0432fb7a331fdee74c82b42eb62c14d7e11eb3a4146a03b5109619dee9e3f23ffaf5ed627e8e85f092 SHA512 0c3907abedf40a05af2584d4566c805522cd0f3e1d427da982170824944d15a41f0ed0aae2a11204a4c6b61dfc366ea849411a3d718f12f4152e9450fef2c990
DIST lyx-2.3.0.tar.xz 15676680 BLAKE2B 4b09f4c3979f51a8b30825c07fe3b24f080bfc8f42d54e94809e342087b683ca24edcb835994583b28d5b9c13868736f850d6c88b229e2d7f6f6bc0fd64c722c SHA512 77366d365f600069564b6d508ba2169744bbc7bc4dc9cb7e9d5f44941796dd7a027ca9ad08f5a67fd6863cbd1f6308ce5233b6e8685ebc6cf78ed19eef84ccb5
+EBUILD lyx-2.2.4.ebuild 4369 BLAKE2B 139a8f7198de12dde8b5ac21e185b4ee3ff239e4f7a0bbfbc615585166a15fa7adc346028d2b8ec41c97401a1c359bfed0f72a69a947b21364e780ae52c3e2bd SHA512 5a7e911ff23ff6a3839cc873d6c15fdbb921c6675c8e3ed0e5cd609fcf2316dda1beb0f63dbad4bc898b4c5b6842cbbd269fe84e2ebb07dbcab0407b38b78143
EBUILD lyx-2.3.0.ebuild 4369 BLAKE2B 048eaea8382d02d0e7294faef31c27bbdd0e92d75f525a969ac441d46c8fa443a7ecbfb877830ebbd72ba01700ffdde62e72d96384602cd46443bf0c8e031cb3 SHA512 13142c571c5f46f960898e7a5086db0e0943ba8632455c43ac654d12677afc97033fbefffb8aa0b3cef73066302a3c0fddeb585757a85329b831dcf181ce93d2
EBUILD lyx-2.3.99.ebuild 4505 BLAKE2B 33fc0583a3131be2d65e7319334f6519ec0b097fac32807d56d70f56c03edb4e855621cc5962f861514f1a7bf3ddef20a1c314db9a806a5f95c8aeaabad7469a SHA512 d53f7d8cc74b39b773559dcda686b121ea6c8fee4c90309b76a097fc85f7492c7f89f07af4b96f70f4afbae06e746a57f767ab6e65a00527cce75251ccebdf39
diff --git a/app-office/lyx/files/2.1-python.patch b/app-office/lyx/files/2.1-python.patch
new file mode 100644
index 0000000..5fb2165
--- /dev/null
+++ b/app-office/lyx/files/2.1-python.patch
@@ -0,0 +1,29 @@
+diff --git a/src/graphics/GraphicsConverter.cpp b/src/graphics/GraphicsConverter.cpp
+index 97c4f68..8f05e62 100644
+--- a/src/graphics/GraphicsConverter.cpp
++++ b/src/graphics/GraphicsConverter.cpp
+@@ -262,7 +262,7 @@ static void build_script(FileName const & from_file,
+ LYXERR(Debug::GRAPHICS, "build_script ... ");
+ typedef Graph::EdgePath EdgePath;
+
+- script << "#!/usr/bin/env python\n"
++ script << "#!/usr/bin/env python2\n"
+ "# -*- coding: utf-8 -*-\n"
+ "import os, shutil, sys\n\n"
+ "def unlinkNoThrow(file):\n"
+diff --git a/src/support/os.cpp b/src/support/os.cpp
+index 8f60c68..2f1cb91 100644
+--- a/src/support/os.cpp
++++ b/src/support/os.cpp
+@@ -63,9 +63,9 @@ int timeout_min()
+ string const python(bool reset)
+ {
+ // Check whether the first python in PATH is the right one.
+- static string command = python2("python -tt");
++ static string command = python2("python2 -tt");
+ if (reset) {
+- command = python2("python -tt");
++ command = python2("python2 -tt");
+ }
+
+ if (command.empty()) {