summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-08-02 14:13:09 -0400
committerRuben Bressler <ruben.bressler@cerpamid.co.cu>2010-08-02 14:13:09 -0400
commit45d5a3f606770509abef7be79fc46d72c85a9968 (patch)
tree34a395c1f892c25fbd77582c723c48bad221d7eb
parentActualización del overlay (diff)
downloadrubenqba-45d5a3f606770509abef7be79fc46d72c85a9968.tar.gz
rubenqba-45d5a3f606770509abef7be79fc46d72c85a9968.tar.bz2
rubenqba-45d5a3f606770509abef7be79fc46d72c85a9968.zip
20100802 - Cambio automático
-rw-r--r--x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.21.4-readd-deprecated-apis.patch176
-rw-r--r--x11-libs/gdk-pixbuf/gdk-pixbuf-2.21.4.ebuild98
2 files changed, 0 insertions, 274 deletions
diff --git a/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.21.4-readd-deprecated-apis.patch b/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.21.4-readd-deprecated-apis.patch
deleted file mode 100644
index 3710791..0000000
--- a/x11-libs/gdk-pixbuf/files/gdk-pixbuf-2.21.4-readd-deprecated-apis.patch
+++ /dev/null
@@ -1,176 +0,0 @@
-From 0969a103e7c143545cbde7e458967b42a9415307 Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mclasen@redhat.com>
-Date: Sun, 27 Jun 2010 23:12:06 +0000
-Subject: Bring back deprecated api
-
-Grudgingly, in the name of api stability.
----
-diff --git a/docs/reference/gdk-pixbuf/gdk-pixbuf-sections.txt b/docs/reference/gdk-pixbuf/gdk-pixbuf-sections.txt
-index 8e70fa3..58ea4ab 100644
---- a/docs/reference/gdk-pixbuf/gdk-pixbuf-sections.txt
-+++ b/docs/reference/gdk-pixbuf/gdk-pixbuf-sections.txt
-@@ -54,6 +54,8 @@ gdk_pixbuf_error_get_type
-
- <SECTION>
- <FILE>refcounting</FILE>
-+gdk_pixbuf_ref
-+gdk_pixbuf_unref
- GdkPixbufDestroyNotify
- </SECTION>
-
-@@ -118,6 +120,8 @@ gdk_pixbuf_fill
- GdkPixbufAnimation
- GdkPixbufAnimationIter
- gdk_pixbuf_animation_new_from_file
-+gdk_pixbuf_animation_ref
-+gdk_pixbuf_animation_unref
- gdk_pixbuf_animation_get_width
- gdk_pixbuf_animation_get_height
- gdk_pixbuf_animation_get_iter
-diff --git a/gdk-pixbuf/gdk-pixbuf-animation.c b/gdk-pixbuf/gdk-pixbuf-animation.c
-index 907e0e7..5b500f6 100644
---- a/gdk-pixbuf/gdk-pixbuf-animation.c
-+++ b/gdk-pixbuf/gdk-pixbuf-animation.c
-@@ -256,6 +256,36 @@ gdk_pixbuf_animation_new_from_file (const char *filename,
- #endif
-
- /**
-+ * gdk_pixbuf_animation_ref:
-+ * @animation: An animation.
-+ *
-+ * Adds a reference to an animation.
-+ *
-+ * Return value: The same as the @animation argument.
-+ *
-+ * Deprecated: 2.0: Use g_object_ref().
-+ **/
-+GdkPixbufAnimation *
-+gdk_pixbuf_animation_ref (GdkPixbufAnimation *animation)
-+{
-+ return (GdkPixbufAnimation*) g_object_ref (animation);
-+}
-+
-+/**
-+ * gdk_pixbuf_animation_unref:
-+ * @animation: An animation.
-+ *
-+ * Removes a reference from an animation.
-+ *
-+ * Deprecated: 2.0: Use g_object_unref().
-+ **/
-+void
-+gdk_pixbuf_animation_unref (GdkPixbufAnimation *animation)
-+{
-+ g_object_unref (animation);
-+}
-+
-+/**
- * gdk_pixbuf_animation_is_static_image:
- * @animation: a #GdkPixbufAnimation
- *
-diff --git a/gdk-pixbuf/gdk-pixbuf-animation.h b/gdk-pixbuf/gdk-pixbuf-animation.h
-index a67e3c9..3143c70 100644
---- a/gdk-pixbuf/gdk-pixbuf-animation.h
-+++ b/gdk-pixbuf/gdk-pixbuf-animation.h
-@@ -58,6 +58,11 @@ GType gdk_pixbuf_animation_get_type (void) G_GNUC_CONST;
- GdkPixbufAnimation *gdk_pixbuf_animation_new_from_file (const char *filename,
- GError **error);
-
-+#ifndef GDK_PIXBUF_DISABLE_DEPRECATED
-+GdkPixbufAnimation *gdk_pixbuf_animation_ref (GdkPixbufAnimation *animation);
-+void gdk_pixbuf_animation_unref (GdkPixbufAnimation *animation);
-+#endif
-+
- int gdk_pixbuf_animation_get_width (GdkPixbufAnimation *animation);
- int gdk_pixbuf_animation_get_height (GdkPixbufAnimation *animation);
- gboolean gdk_pixbuf_animation_is_static_image (GdkPixbufAnimation *animation);
-diff --git a/gdk-pixbuf/gdk-pixbuf-core.h b/gdk-pixbuf/gdk-pixbuf-core.h
-index 4ea1693..079a3a7 100644
---- a/gdk-pixbuf/gdk-pixbuf-core.h
-+++ b/gdk-pixbuf/gdk-pixbuf-core.h
-@@ -84,6 +84,13 @@ GQuark gdk_pixbuf_error_quark (void);
-
- GType gdk_pixbuf_get_type (void) G_GNUC_CONST;
-
-+/* Reference counting */
-+
-+#ifndef GDK_PIXBUF_DISABLE_DEPRECATED
-+GdkPixbuf *gdk_pixbuf_ref (GdkPixbuf *pixbuf);
-+void gdk_pixbuf_unref (GdkPixbuf *pixbuf);
-+#endif
-+
- /* GdkPixbuf accessors */
-
- GdkColorspace gdk_pixbuf_get_colorspace (const GdkPixbuf *pixbuf);
-diff --git a/gdk-pixbuf/gdk-pixbuf.c b/gdk-pixbuf/gdk-pixbuf.c
-index 1b2728b..c38b782 100644
---- a/gdk-pixbuf/gdk-pixbuf.c
-+++ b/gdk-pixbuf/gdk-pixbuf.c
-@@ -186,6 +186,39 @@ gdk_pixbuf_finalize (GObject *object)
- G_OBJECT_CLASS (gdk_pixbuf_parent_class)->finalize (object);
- }
-
-+
-+/**
-+ * gdk_pixbuf_ref:
-+ * @pixbuf: A pixbuf.
-+ *
-+ * Adds a reference to a pixbuf.
-+ *
-+ * Return value: The same as the @pixbuf argument.
-+ *
-+ * Deprecated: 2.0: Use g_object_ref().
-+ **/
-+GdkPixbuf *
-+gdk_pixbuf_ref (GdkPixbuf *pixbuf)
-+{
-+ return (GdkPixbuf *) g_object_ref (pixbuf);
-+}
-+
-+/**
-+ * gdk_pixbuf_unref:
-+ * @pixbuf: A pixbuf.
-+ *
-+ * Removes a reference from a pixbuf.
-+ *
-+ * Deprecated: 2.0: Use g_object_unref().
-+ **/
-+void
-+gdk_pixbuf_unref (GdkPixbuf *pixbuf)
-+{
-+ g_object_unref (pixbuf);
-+}
-+
-+
-+
- /* Used as the destroy notification function for gdk_pixbuf_new() */
- static void
- free_buffer (guchar *pixels, gpointer data)
-diff --git a/gdk-pixbuf/gdk-pixbuf.symbols b/gdk-pixbuf/gdk-pixbuf.symbols
-index b1c7e17..03bd08a 100644
---- a/gdk-pixbuf/gdk-pixbuf.symbols
-+++ b/gdk-pixbuf/gdk-pixbuf.symbols
-@@ -15,6 +15,10 @@
- #if IN_FILE(__GDK_PIXBUF_C__)
- gdk_pixbuf_error_quark
- gdk_pixbuf_get_type G_GNUC_CONST
-+#ifndef GDK_PIXBUF_DISABLE_DEPRECATED
-+gdk_pixbuf_ref
-+gdk_pixbuf_unref
-+#endif
- gdk_pixbuf_new
- gdk_pixbuf_get_bits_per_sample
- gdk_pixbuf_get_colorspace
-@@ -120,6 +124,10 @@ gdk_pixbuf_animation_new_from_file PRIVATE
- #ifdef G_OS_WIN32
- gdk_pixbuf_animation_new_from_file_utf8
- #endif
-+#ifndef GDK_PIXBUF_DISABLE_DEPRECATED
-+gdk_pixbuf_animation_ref
-+gdk_pixbuf_animation_unref
-+#endif
- gdk_pixbuf_non_anim_new
- gdk_pixbuf_non_anim_get_type G_GNUC_CONST
- #endif
---
-cgit v0.8.3.1
diff --git a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.21.4.ebuild b/x11-libs/gdk-pixbuf/gdk-pixbuf-2.21.4.ebuild
deleted file mode 100644
index 2fc8fb1..0000000
--- a/x11-libs/gdk-pixbuf/gdk-pixbuf-2.21.4.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.20.1-r1.ebuild,v 1.2 2010/06/20 11:15:18 nirbheek Exp $
-
-EAPI="3"
-
-inherit gnome.org flag-o-matic multilib libtool autotools virtualx
-
-DESCRIPTION="Image loading library for GTK+"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+X debug doc +introspection jpeg jpeg2k tiff test"
-
-RDEPEND="
- >=dev-libs/glib-2.25.9
- >=media-libs/libpng-1.2.43-r2:0
- jpeg? ( >=media-libs/jpeg-6b-r9:0 )
- jpeg2k? ( media-libs/jasper )
- tiff? ( >=media-libs/tiff-3.9.2 )
- X? ( x11-libs/libX11 )
- !<gnome-base/gail-1000
- !<x11-libs/gtk+-2.21.3:2
- !<x11-libs/gtk+-2.90.4:3"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9
- >=sys-devel/gettext-0.17
- x86-interix? (
- sys-libs/itx-bind
- )
- >=dev-util/gtk-doc-am-1.11
- doc? (
- >=dev-util/gtk-doc-1.11
- ~app-text/docbook-xml-dtd-4.1.2 )
- introspection? ( >=dev-libs/gobject-introspection-0.6.7 )"
-
-src_prepare() {
- # From upstream, adds some APIs used by "older" programs
- epatch "${FILESDIR}"/${P}-readd-deprecated-apis.patch
-
- # Only build against libX11 if the user wants to do so
- epatch "${FILESDIR}"/${P}-fix-automagic-x11.patch
-
- elibtoolize
- eautoreconf
-}
-
-src_configure() {
- # -O3 and company cause random crashes in applications. Bug #133469
- replace-flags -O3 -O2
- strip-flags
-
- use ppc64 && append-flags -mminimal-toc
-
- if use x86-interix; then
- # activate the itx-bind package...
- append-flags "-I${EPREFIX}/usr/include/bind"
- append-ldflags "-L${EPREFIX}/usr/lib/bind"
- fi
-
- # png always on to display icons (foser)
- local myconf="
- $(use_enable doc gtk-doc)
- $(use_with jpeg libjpeg)
- $(use_with jpeg2k libjasper)
- $(use_with tiff libtiff)
- $(use_enable introspection)
- $(use_with X x11)
- --with-libpng"
-
- # Passing --disable-debug is not recommended for production use
- use debug && myconf="${myconf} --enable-debug=yes"
-
- econf ${myconf}
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- Xemake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- dodoc AUTHORS NEWS* README* || die "dodoc failed"
-}
-
-pkg_postinst() {
- gdk-pixbuf-query-loaders > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
-
- if [ -e "${EROOT}"usr/lib/gtk-2.0/2.*/loaders ]; then
- elog "You need to rebuild ebuilds that installed into" "${EROOT}"usr/lib/gtk-2.0/2.*/loaders
- elog "to do that you can use qfile from portage-utils:"
- elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.*/loaders)"
- fi
-}