summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRandall Wald <rdwald@gmail.com>2012-11-16 18:11:29 -0500
committerRandall Wald <rdwald@gmail.com>2012-11-16 18:11:29 -0500
commit4bfcd7dfaf378d01a1278e4e3e883039912f45af (patch)
treeed4d2975d45e88f4c3acc07e43a98d6034ba4ada
parentNew ebuild x11-misc/hybrid-screenclone to perform rendering on (diff)
downloadrwald-4bfcd7dfaf378d01a1278e4e3e883039912f45af.tar.gz
rwald-4bfcd7dfaf378d01a1278e4e3e883039912f45af.tar.bz2
rwald-4bfcd7dfaf378d01a1278e4e3e883039912f45af.zip
Added net-im/skype4pidgin ebuild based on bug #257832
-rw-r--r--net-im/skype4pidgin/ChangeLog9
-rw-r--r--net-im/skype4pidgin/Manifest2
-rw-r--r--net-im/skype4pidgin/skype4pidgin-9999.ebuild62
3 files changed, 73 insertions, 0 deletions
diff --git a/net-im/skype4pidgin/ChangeLog b/net-im/skype4pidgin/ChangeLog
new file mode 100644
index 0000000..ad32ed6
--- /dev/null
+++ b/net-im/skype4pidgin/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-im/skype4pidgin
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*skype4pidgin-9999 (16 Nov 2012)
+
+ 16 Nov 2012; Randall Wald <rwald@gentoo.org> +skype4pidgin-9999.ebuild:
+ Ebuild copied from bug #257832
+
diff --git a/net-im/skype4pidgin/Manifest b/net-im/skype4pidgin/Manifest
new file mode 100644
index 0000000..0c3c6b4
--- /dev/null
+++ b/net-im/skype4pidgin/Manifest
@@ -0,0 +1,2 @@
+EBUILD skype4pidgin-9999.ebuild 1553 SHA256 519b52fbac683aa10b0b818b401c9569ebb8a6ac86a905089d77de9eb7a2fb0b SHA512 e921afa074828c960d53755c9b895d1cc5d189d46cc7dd27afe92c508b69f4336f39a5c89d7117721bb043411b6b7289b59ca641783186621dab6f0a76f570fe WHIRLPOOL fc89073ceda7c5533888c2b282e13f1b998e6f6858aafe2f582e8883678110a4deaf1156af40245d0e443ddac3b751cb0d49b1f09af06c3292b4a07ec9359804
+MISC ChangeLog 262 SHA256 d0049290639a173a0b0104638c8231715882f57834c4891b950e07e9209d274d SHA512 6b53f5968df5dde678d316635c5dba36e945e37622af4fb57b4f3bac687dbd2146ed0f566f61e75161c164e8bc1a2ca6aad7145a913cd340f13782645678c2be WHIRLPOOL 1a1e463967bd43df064e9572126de2a59c1fdd7e816a87d478d115e2f05e5e029e2f8bf2b4c5fa23a463504858e34c80544716e6d5e1c599e395ea05e5a35449
diff --git a/net-im/skype4pidgin/skype4pidgin-9999.ebuild b/net-im/skype4pidgin/skype4pidgin-9999.ebuild
new file mode 100644
index 0000000..49337c4
--- /dev/null
+++ b/net-im/skype4pidgin/skype4pidgin-9999.ebuild
@@ -0,0 +1,62 @@
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+DESCRIPTION="Skype API PLugin for Pidgin"
+HOMEPAGE="https://code.google.com/p/skype4pidgin/"
+ESVN_REPO_URI="http://skype4pidgin.googlecode.com/svn/trunk/"
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-NonCommercial-3.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus nls"
+SLOT="0"
+SRC_URI=""
+
+RDEPEND="net-im/pidgin
+ dbus? ( >sys-apps/dbus-1.0 )
+ net-im/skype"
+
+DEPEND="${RDEPEND}
+ >dev-libs/glib-2.0"
+
+src_compile() {
+ GLIB_CFLAGS="-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
+ -I/usr/include"
+ LIBPURPLE_CFLAGS="-I/usr/include/libpurple -DPURPLE_PLUGINS"
+
+ if use nls; then
+ LIBPURPLE_CFLAGS="${LIBPURPLE_CFLAGS} -DENABLE_NLS"
+ fi
+
+ CFLAGS="${CFLAGS} ${LIBPURPLE_CFLAGS} -Wall -pthread ${GLIB_CFLAGS} -I.
+ -shared -fPIC -DPIC"
+
+ if use amd64; then
+ CFLAGS="${CFLAGS} -m32 -m64"
+ fi
+
+ cc ${CFLAGS} -o libskype.so libskype.c || die 'Error compiling library!'
+ cc ${CFLAGS} -DSKYPENET -o libskypenet.so libskype.c || die 'Error compiling library!'
+
+ if use dbus; then
+ DBUS_CFLAGS="-DSKYPE_DBUS -I/usr/include/dbus-1.0
+ -I/usr/lib/dbus-1.0/include -o libskype_dbus.so"
+ cc ${CFLAGS} ${DBUS_CFLAGS} -o libskype_dbus.so libskype.c || die 'Error compiling library!'
+ fi
+}
+
+src_install() {
+ insinto /usr/lib/purple-2
+ doins "libskype.so"
+ doins "libskypenet.so"
+ if use dbus; then
+ doins "libskype_dbus.so"
+ fi
+
+ insinto /usr/share/pixmaps/pidgin/emotes/default-skype
+ doins "theme"
+
+ cd icons
+ insinto /usr/share/pixmaps/pidgin/protocols/
+ doins -r ??
+}