summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Willich <sabotageandi@gmail.com>2011-08-06 22:56:54 +0200
committerAndreas Willich <sabotageandi@gmail.com>2011-08-06 22:56:54 +0200
commit05e2888845ef46a6851eeb8817811e7f2a5172f1 (patch)
tree01f71afdf31b80285ceaec7fe6dbb4f05a430ce5 /x11-apps
downloadsabotageandi-05e2888845ef46a6851eeb8817811e7f2a5172f1.tar.gz
sabotageandi-05e2888845ef46a6851eeb8817811e7f2a5172f1.tar.bz2
sabotageandi-05e2888845ef46a6851eeb8817811e7f2a5172f1.zip
ebuild push
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/ccv-bin/Manifest3
-rw-r--r--x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild54
-rw-r--r--x11-apps/ginn/Manifest2
-rw-r--r--x11-apps/ginn/ginn-0.2.4.ebuild27
4 files changed, 86 insertions, 0 deletions
diff --git a/x11-apps/ccv-bin/Manifest b/x11-apps/ccv-bin/Manifest
new file mode 100644
index 0000000..52b775c
--- /dev/null
+++ b/x11-apps/ccv-bin/Manifest
@@ -0,0 +1,3 @@
+DIST ccv-1.4-lin-32-bin.tar.gz 4446215 RMD160 fbd5e14fda6dfa74b9212ae4502d38507d29f74d SHA1 b4e87be6bb78769443351172e47055cc42431371 SHA256 4fededd637ed6e07c1c13008d35ea796fdcfa4b660f83a231384bb4584442930
+DIST ccv-1.4.0-lin-64-bin.tar.gz 6546794 RMD160 f8d090ccbefbbc1ee12059d973811bb5062b7d61 SHA1 5dffb631fc3a9548dca6fb1d863c1cf8a312f3cd SHA256 88dc14dfa0cf981468c68d9b9dabddbcad1edf9deac9c886373f262591a2a6fd
+EBUILD ccv-bin-1.4.0.ebuild 979 RMD160 64923bf2f0fdf7d76629eb516ebc90ca48c390e3 SHA1 0d77c0cea43043b1f2a76579503019d5abe6e4ba SHA256 34b4a4e83cf33daf9775d1867582ed7432d80667b76c8f0cf8d6068781162bfb
diff --git a/x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild b/x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild
new file mode 100644
index 0000000..4051a0f
--- /dev/null
+++ b/x11-apps/ccv-bin/ccv-bin-1.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION=""
+HOMEPAGE="http://http://nuicode.com/projects/ccv"
+SRC_URI="amd64? ( http://nuicode.com/attachments/download/186/ccv-1.4.0-lin-64-bin.tar.gz )
+ x86? ( http://nuicode.com/attachments/download/184/ccv-1.4-lin-32-bin.tar.gz
+ )"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+
+RDEPEND=""
+
+#S=${WORKDIR}
+
+src_unpack() {
+ unpack "${A}"
+
+ EXTRACT_DIR=${WORKDIR}
+
+ if use amd64 ; then
+ EXTRACT_DIR=${WORKDIR}/ccv-1.4.0-lin-64-bin
+ fi
+
+ if use x86 ; then
+ EXTRACT_DIR=${WORKDIR}/ccv-1.4.lin-bin
+ fi
+
+ mv ${EXTRACT_DIR}/* ${WORKDIR}
+
+ rmdir ${EXTRACT_DIR}
+}
+
+src_install() {
+ insinto /opt/ccv
+
+ doins -r * || die
+
+ fperms 0755 /opt/ccv/clickToLaunchApp.sh
+ fperms 0755 /opt/ccv/Community_Core_Vision/clickToLaunchApp.sh
+ fperms 0755 /opt/ccv/Community_Core_Vision/Community_Core_Vision
+}
+
diff --git a/x11-apps/ginn/Manifest b/x11-apps/ginn/Manifest
new file mode 100644
index 0000000..49c8d34
--- /dev/null
+++ b/x11-apps/ginn/Manifest
@@ -0,0 +1,2 @@
+DIST ginn-0.2.4.tar.gz 310648 RMD160 f32c016d9edfa19173ce7e3a3a2fc1294b22351b SHA1 68027da2f37ce8c0794931265364321440440324 SHA256 44e64f81ade40fa8b094b69a51ad80fcc1c69407486cecd6b4e27a6aa91c9745
+EBUILD ginn-0.2.4.ebuild 541 RMD160 630e482ebd597d55ca44860f64f953276f1ee446 SHA1 9323198ec29e04753fd443d777da84e43e064958 SHA256 ae60e49e3fa7d746a731030a2441ba816c35772fa5f120ee140beef339ea8f2d
diff --git a/x11-apps/ginn/ginn-0.2.4.ebuild b/x11-apps/ginn/ginn-0.2.4.ebuild
new file mode 100644
index 0000000..44a73ca
--- /dev/null
+++ b/x11-apps/ginn/ginn-0.2.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Gesture Injector: No-GEIS, No-Toolkits"
+SRC_URI="http://launchpad.net/ginn/0.x/${PV}/+download/ginn-${PV}.tar.gz"
+HOMEPAGE="http://launchpad.net/canonical-multitouch/ginn"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="LGPL-3"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-libs/utouch-geis
+ x11-libs/bamf
+ "
+
+src_compile() {
+ econf
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+}