summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-evdev/Manifest2
-rw-r--r--x11-drivers/xf86-input-evdev/files/xf86-input-evdev-fix_valuator_procimity_handling.patch44
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0-r2.ebuild35
3 files changed, 81 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-evdev/Manifest b/x11-drivers/xf86-input-evdev/Manifest
index 8eedb32..34ca949 100644
--- a/x11-drivers/xf86-input-evdev/Manifest
+++ b/x11-drivers/xf86-input-evdev/Manifest
@@ -1,4 +1,6 @@
+AUX xf86-input-evdev-fix_valuator_procimity_handling.patch 1685 RMD160 5a0a221ea9bd40f7a13fa9066d8a71fe523a4b46 SHA1 5d3677b89da04f76686aa6c16282a2afd1d9b782 SHA256 3984bf16170ad7f0cfd195ea3b9981ee84173ea14c972b4b0ccb95a515effd3b
AUX xf86-input-evdev-gestures.patch 23436 RMD160 839e8cd97fe0c47b4b02ce6f6d8ddc0d5f4b84e3 SHA1 6da156d429f3cc3f9fd03e03a7799b1b19835164 SHA256 9e868d28efbe7baaa3ccc405d866668a656b8526c8d7d91ebb6f3fc2437e8541
AUX xf86-input-evdev-xi2.1.patch 56543 RMD160 4d09c9be27161762d5014eba1311217b9efd36e8 SHA1 da47585a3754e3e4882286ca359b273176eab755 SHA256 330ecd8a59ddd7c7ee78dcca6f71d3b6f880958570074edbb183923f8f97e085
DIST xf86-input-evdev-2.6.0.tar.bz2 322773 RMD160 cde3345f882a4774dffe3ec9c716ef077f25febf SHA1 fb6f7a6f5168ae07efe890e4ace9fb8af1d4e1e0 SHA256 b0e7f3991a8183a4743196c3e16d7184d439b80bf43653aa2f45b0756a6753ac
EBUILD xf86-input-evdev-2.6.0-r1.ebuild 794 RMD160 d3c76f941d924eb4e02ae6cff5b9fe23e2cf7235 SHA1 9504818534f71ebd60d95c3a4342ddd9952519bc SHA256 3f1c8e772a21092ebd4cbeca0d91542bdfd58dd1d229fd4e30aad4ef6d841284
+EBUILD xf86-input-evdev-2.6.0-r2.ebuild 851 RMD160 c548491c2e4f1a0d355d9a41abca94ba1d2f1593 SHA1 12d52747c9018ad601d40890f95cd232d09b4e84 SHA256 4514ec670659299264f49a445037bd9a6deeccee9b5e95058ab703ec7b80c477
diff --git a/x11-drivers/xf86-input-evdev/files/xf86-input-evdev-fix_valuator_procimity_handling.patch b/x11-drivers/xf86-input-evdev/files/xf86-input-evdev-fix_valuator_procimity_handling.patch
new file mode 100644
index 0000000..8b014ae
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/files/xf86-input-evdev-fix_valuator_procimity_handling.patch
@@ -0,0 +1,44 @@
+From 6139f903bc1942b160d3d94828d9aa66d9d3febd Mon Sep 17 00:00:00 2001
+From: Chase Douglas <chase.douglas@canonical.com>
+Date: Thu, 14 Apr 2011 15:48:10 -0400
+Subject: [PATCH] Copy out of proximity values into current values selectively
+
+Otherwise, an event that causes us to go into proximity with some new
+valuator values will retain some old valuator values from when last in
+proximity. This change ensures that all values posted while out of
+proximity are accounted for.
+
+Signed-off-by: Chase Douglas <chase.douglas@canonical.com>
+---
+ src/evdev.c | 15 ++++++++-------
+ 1 files changed, 8 insertions(+), 7 deletions(-)
+
+diff --git a/src/evdev.c b/src/evdev.c
+index b767b0e..f31f492 100644
+--- a/src/evdev.c
++++ b/src/evdev.c
+@@ -525,13 +525,14 @@ EvdevProcessProximityState(InputInfoPtr pInfo)
+ {
+ /* We're about to go into/out of proximity but have no abs events
+ * within the EV_SYN. Use the last coordinates we have. */
+- if (!pEvdev->abs_queued &&
+- valuator_mask_num_valuators(pEvdev->prox) > 0)
+- {
+- valuator_mask_copy(pEvdev->vals, pEvdev->prox);
+- valuator_mask_zero(pEvdev->prox);
+- pEvdev->abs_queued = 1;
+- }
++ for (i = 0; i < valuator_mask_size(pEvdev->prox); i++)
++ if (!valuator_mask_isset(pEvdev->vals, i) &&
++ valuator_mask_isset(pEvdev->prox, i))
++ valuator_mask_set(pEvdev->vals, i,
++ valuator_mask_get(pEvdev->prox, i));
++ valuator_mask_zero(pEvdev->prox);
++
++ pEvdev->abs_queued = valuator_mask_size(pEvdev->vals);
+ }
+
+ pEvdev->in_proximity = prox_state;
+--
+1.7.4.1
+
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0-r2.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0-r2.ebuild
new file mode 100644
index 0000000..3162c09
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.6.0.ebuild,v 1.7 2011/03/05 18:09:14 xarthisius Exp $
+
+EAPI=3
+XORG_EAUTORECONF=yes
+
+inherit xorg-2
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86"
+IUSE="utouch"
+
+RDEPEND=">=x11-base/xorg-server-1.6.3"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6
+ x11-proto/inputproto
+ x11-proto/xproto
+ x11-libs/mtdev"
+
+src_prepare() {
+ if use utouch ; then
+ epatch "${FILESDIR}/xf86-input-evdev-xi2.1.patch"
+ epatch "${FILESDIR}/xf86-input-evdev-gestures.patch"
+ epatch "${FILESDIR}/xf86-input-evdev-fix_valuator_procimity_handling.patch"
+ fi
+
+ xorg-2_src_prepare
+}
+
+src_install() {
+ xorg-2_src_install
+}
+
+