summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/utouch-frame/utouch-frame-1.1.3.ebuild17
-rw-r--r--x11-libs/utouch-geis/utouch-geis-2.1.2.ebuild22
-rw-r--r--x11-libs/utouch-grail/utouch-grail-2.0.0.ebuild21
3 files changed, 60 insertions, 0 deletions
diff --git a/x11-libs/utouch-frame/utouch-frame-1.1.3.ebuild b/x11-libs/utouch-frame/utouch-frame-1.1.3.ebuild
new file mode 100644
index 0000000..5cd0107
--- /dev/null
+++ b/x11-libs/utouch-frame/utouch-frame-1.1.3.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit base
+
+DESCRIPTION="Touch Frame Library "
+SRC_URI="http://launchpad.net/utouch-frame/trunk/v${PV}/+download/utouch-frame-${PV}.tar.gz"
+HOMEPAGE="https://launchpad.net/utouch-frame"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPV-3"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-libs/utouch-evemu"
diff --git a/x11-libs/utouch-geis/utouch-geis-2.1.2.ebuild b/x11-libs/utouch-geis/utouch-geis-2.1.2.ebuild
new file mode 100644
index 0000000..3e2c7e2
--- /dev/null
+++ b/x11-libs/utouch-geis/utouch-geis-2.1.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+inherit base
+
+DESCRIPTION="An implementation of the GEIS (Gesture Engine Interface and Support) interface."
+SRC_URI="http://launchpad.net/utouch-geis/trunk/${PV}/+download/utouch-geis-${PV}.tar.gz"
+HOMEPAGE="https://launchpad.net/utouch-geis"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2 LGPL-3"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-libs/utouch-grail"
+
+src_prepare() {
+ sed -i 's/python >= 2.7/python-2.7 >= 2.7/g' configure;
+}
diff --git a/x11-libs/utouch-grail/utouch-grail-2.0.0.ebuild b/x11-libs/utouch-grail/utouch-grail-2.0.0.ebuild
new file mode 100644
index 0000000..5a81ed7
--- /dev/null
+++ b/x11-libs/utouch-grail/utouch-grail-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit base
+
+DESCRIPTION="Gesture Recognition And Instantiation Library"
+SRC_URI="http://launchpad.net/utouch-grail/trunk/v${PV}/+download/utouch-grail-${PV}.tar.gz"
+HOMEPAGE="https://launchpad.net/utouch-grail"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPV-3"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ x11-libs/mtdev
+ x11-libs/utouch-evemu
+ x11-libs/utouch-frame
+ "
+