aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2010-11-21 16:36:04 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2010-11-21 16:36:04 +0100
commita37e7b39e9b09cddd5947472c68ca65ff27bb9e4 (patch)
treee3ce3add97def3d5d2cd5de06b3aa5bff51ded2b /dev-libs
parentAdd Purple-Presence (diff)
downloadsardemff7-a37e7b39e9b09cddd5947472c68ca65ff27bb9e4.tar.gz
sardemff7-a37e7b39e9b09cddd5947472c68ca65ff27bb9e4.tar.bz2
sardemff7-a37e7b39e9b09cddd5947472c68ca65ff27bb9e4.zip
Add DBus-C++ and suppor for dbus in gnote
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/dbus-c++/Manifest1
-rw-r--r--dev-libs/dbus-c++/dbus-c++-0.5.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/dbus-c++/Manifest b/dev-libs/dbus-c++/Manifest
new file mode 100644
index 0000000..d0fcea0
--- /dev/null
+++ b/dev-libs/dbus-c++/Manifest
@@ -0,0 +1 @@
+EBUILD dbus-c++-0.5.0.ebuild 810 RMD160 e213e064732e80d6bbf04f51cf43f5d0cf3a8d80 SHA1 22766784f9bf5621ffd8f36435e45206cd3e40f9 SHA256 e2b3d1b7067ee1d0cd2369e32f2e365e9e3a00c1d6db2a668b8884b9d6ff7b1d
diff --git a/dev-libs/dbus-c++/dbus-c++-0.5.0.ebuild b/dev-libs/dbus-c++/dbus-c++-0.5.0.ebuild
new file mode 100644
index 0000000..bd53357
--- /dev/null
+++ b/dev-libs/dbus-c++/dbus-c++-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Mat
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+EAPI="3"
+
+inherit base autotools git
+
+DESCRIPTION="dbus-c++ attempts to provide a C++ API for D-BUS."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/dbus-c++"
+
+EGIT_REPO_URI="git://gitorious.org/dbus-cplusplus/mainline.git"
+: ${EGIT_COMMIT:=9ac4f0252f0784e8594b41e578e6d04f89835d13}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug glib"
+
+ACLOCAL_AMFLAG="-I config"
+MAKEOPTS+=" -j1"
+
+# probably needs more/less crap listed here ...
+RDEPEND="sys-apps/dbus"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ econf \
+ --disable-doxygen-docs \
+ $(use_enable debug) \
+ $(use_enable glib) \
+ || die "configure failed"
+}