aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-06-27 14:20:01 +0200
committerSardem FF7 <sardemff7.pub@gmail.com>2011-06-27 14:20:33 +0200
commit0d64e171042fe59648c21c3170d42a31d28eab0d (patch)
tree1e6231e929aafbc8b80cd588088844de751555ad /www-client/firefox
parentmozilla-config.eclass: Fix pango dependency (diff)
downloadsardemff7-0d64e171042fe59648c21c3170d42a31d28eab0d.tar.gz
sardemff7-0d64e171042fe59648c21c3170d42a31d28eab0d.tar.bz2
sardemff7-0d64e171042fe59648c21c3170d42a31d28eab0d.zip
Merge firefox and xulrunner
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/files/gcc46.patch69
-rw-r--r--www-client/firefox/firefox-9999.ebuild36
2 files changed, 70 insertions, 35 deletions
diff --git a/www-client/firefox/files/gcc46.patch b/www-client/firefox/files/gcc46.patch
new file mode 100644
index 0000000..f5fee20
--- /dev/null
+++ b/www-client/firefox/files/gcc46.patch
@@ -0,0 +1,69 @@
+diff -urN a/layout/style/nsCSSRuleProcessor.cpp b/layout/style/nsCSSRuleProcessor.cpp
+--- a/layout/style/nsCSSRuleProcessor.cpp 2011-03-18 19:34:00.000000000 -0400
++++ b/layout/style/nsCSSRuleProcessor.cpp 2011-04-03 08:12:35.205741696 -0400
+@@ -1317,7 +1317,7 @@
+ return PR_FALSE;
+
+ const nsDefaultStringComparator defaultComparator;
+- const nsASCIICaseInsensitiveStringComparator ciComparator;
++ const nsASCIICaseInsensitiveStringComparator ciComparator = nsASCIICaseInsensitiveStringComparator();
+ const nsStringComparator& comparator =
+ (aAttrSelector->mCaseSensitive || !isHTML)
+ ? static_cast<const nsStringComparator&>(defaultComparator)
+diff -urN a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
+--- a/toolkit/xre/nsAppRunner.cpp 2011-04-03 08:17:35.091741681 -0400
++++ b/toolkit/xre/nsAppRunner.cpp 2011-04-03 08:12:12.305741698 -0400
+@@ -1003,7 +1003,7 @@
+
+ #endif
+
+-static const nsXULAppInfo kAppInfo;
++static const nsXULAppInfo kAppInfo = nsXULAppInfo();
+ static nsresult AppInfoConstructor(nsISupports* aOuter,
+ REFNSIID aIID, void **aResult)
+ {
+diff -urN a/xpcom/base/nsDebugImpl.cpp b/xpcom/base/nsDebugImpl.cpp
+--- a/xpcom/base/nsDebugImpl.cpp 2011-03-18 19:34:13.000000000 -0400
++++ b/xpcom/base/nsDebugImpl.cpp 2011-04-03 08:12:15.530741697 -0400
+@@ -511,7 +511,7 @@
+ #endif
+ }
+
+-static const nsDebugImpl kImpl;
++static const nsDebugImpl kImpl = nsDebugImpl();
+
+ nsresult
+ nsDebugImpl::Create(nsISupports* outer, const nsIID& aIID, void* *aInstancePtr)
+diff -urN a/xpcom/base/nsTraceRefcntImpl.cpp b/xpcom/base/nsTraceRefcntImpl.cpp
+--- a/xpcom/base/nsTraceRefcntImpl.cpp 2011-03-18 19:34:13.000000000 -0400
++++ b/xpcom/base/nsTraceRefcntImpl.cpp 2011-04-03 08:12:15.529741697 -0400
+@@ -1356,7 +1356,7 @@
+ return NS_OK;
+ }
+
+-static const nsTraceRefcntImpl kTraceRefcntImpl;
++static const nsTraceRefcntImpl kTraceRefcntImpl = nsTraceRefcntImpl();
+
+ NS_METHOD
+ nsTraceRefcntImpl::Create(nsISupports* outer, const nsIID& aIID, void* *aInstancePtr)
+diff -urN a/xpcom/glue/nsEnumeratorUtils.cpp b/xpcom/glue/nsEnumeratorUtils.cpp
+--- a/xpcom/glue/nsEnumeratorUtils.cpp 2011-03-18 19:34:13.000000000 -0400
++++ b/xpcom/glue/nsEnumeratorUtils.cpp 2011-04-03 08:12:15.574741697 -0400
+@@ -113,7 +113,7 @@
+ return NS_ERROR_UNEXPECTED;
+ }
+
+-const EmptyEnumeratorImpl EmptyEnumeratorImpl::kInstance;
++const EmptyEnumeratorImpl EmptyEnumeratorImpl::kInstance = EmptyEnumeratorImpl();
+
+ nsresult
+ NS_NewEmptyEnumerator(nsISimpleEnumerator** aResult)
+diff -urN a/xpcom/io/nsUnicharInputStream.cpp b/xpcom/io/nsUnicharInputStream.cpp
+--- a/xpcom/io/nsUnicharInputStream.cpp 2011-03-18 19:34:13.000000000 -0400
++++ b/xpcom/io/nsUnicharInputStream.cpp 2011-04-03 08:12:16.023741697 -0400
+@@ -464,4 +464,4 @@
+ }
+
+ const nsSimpleUnicharStreamFactory
+-nsSimpleUnicharStreamFactory::kInstance;
++nsSimpleUnicharStreamFactory::kInstance = nsSimpleUnicharStreamFactory();
diff --git a/www-client/firefox/firefox-9999.ebuild b/www-client/firefox/firefox-9999.ebuild
index c98d64f..387137d 100644
--- a/www-client/firefox/firefox-9999.ebuild
+++ b/www-client/firefox/firefox-9999.ebuild
@@ -4,43 +4,9 @@
EAPI="3"
-inherit mozilla-scm mozilla-config pax-utils
+inherit mozilla-app
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="http://www.mozilla.com/en-US/firefox"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-src_prepare() {
- # tmp fix
- sed -i \
- -e '/XPIDL_LINK =/s|$(LIBXUL_DIST)/sdk/bin|$(DEPTH)/xpcom/typelib/xpt/tools|' \
- config/config.mk \
- js/src/config/config.mk \
- || die "tmp fix failed (maybe the time to remove it)"
-
- # Gentoo install dirs
- sed -i \
- -e 's:$(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_VERSION):$(includedir)/idl:' \
- -e 's:$(MOZ_APP_NAME)-$(MOZ_APP_VERSION):firefox:' \
- -e 's:$(MOZ_APP_NAME)-devel-$(MOZ_APP_VERSION):firefox:' \
- config/autoconf.mk.in \
- || die "${MAJ_XUL_PV} sed failed!"
-
- eautoreconf
-}
-
-src_configure() {
- mozconfig_configure
-}
-
-src_install() {
- mozilla-scm_src_install
- mozilla_application_install
-
- pax-mark m "${ED}"/${MOZILLA_FIVE_HOME}/firefox
-
- # Plugins dir
- dosym ../nsbrowser/plugins "${MOZILLA_FIVE_HOME}"/plugins \
- || die "failed to symlink"
-}