aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSardem FF7 <sardemff7.pub@gmail.com>2011-02-25 12:22:13 +0100
committerSardem FF7 <sardemff7.pub@gmail.com>2011-02-25 12:24:02 +0100
commit29c01a0e0934a90b76262611f42331cf713b941a (patch)
tree650e53f882541340d1ddd425be909e71c94c9b6e /www-client
parentBump gs-gnote (diff)
downloadsardemff7-29c01a0e0934a90b76262611f42331cf713b941a.tar.gz
sardemff7-29c01a0e0934a90b76262611f42331cf713b941a.tar.bz2
sardemff7-29c01a0e0934a90b76262611f42331cf713b941a.zip
Merge mozconfig eclasses to mozilla-scm
Factorize some mozconfig stuff to a big mozconfig_configure function Clean some options
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/Manifest2
-rw-r--r--www-client/firefox/firefox-9999.ebuild111
2 files changed, 5 insertions, 108 deletions
diff --git a/www-client/firefox/Manifest b/www-client/firefox/Manifest
index 4ecde9a..c2a89c0 100644
--- a/www-client/firefox/Manifest
+++ b/www-client/firefox/Manifest
@@ -1,4 +1,4 @@
AUX default-prefs.js 95 RMD160 805cdfec6fb31c224322cb71125547ad7a515f49 SHA1 7fab69d85b12a9f1b0c87fbb1821bdafd7485ac9 SHA256 8bc4cb870bc402db1f20b135a689f8c5dbfa5de8f1755b1926198d627c12c5f1
AUX firefox.desktop 255 RMD160 4ef1cf548f11057274620b82f0728958a3424bea SHA1 6a440f817072fb60516c1a1d999dffb6d3fa1583 SHA256 9bf6e1264d986c68d64831d166ed6b506bff6df8b56d21bfc166aee09cbc753f
AUX gentoo-specific.patch 3937 RMD160 d167b98c03ff88d955e865aee78203d396620cf7 SHA1 92a372a945734b737ed2d4b534fc8a6ef9e39bbf SHA256 dd6115dcca2972d637f966c6c7faef6d19d8e2622e3c44a0950e98c8f18ec747
-EBUILD firefox-9999.ebuild 4390 RMD160 b64ce84e762da164aa6d28344436a2015420a6d0 SHA1 184bdcda3eadb5665cb1fcc02e4d9d0bb3f4bc4b SHA256 cca350d2e9dfe8495a4295d884ee9e31e6e7728652f17573611d4ba75f93eae8
+EBUILD firefox-9999.ebuild 1134 RMD160 4320d6ba2b97ab51277e8acb09211b7daea25b2a SHA1 5e7e145dfd6d5dc8292b6bc373aba4b4c91b7bb0 SHA256 4ce80cf5d9f15169e78000c8990bd1d5ce6978afde84e6b53041ea78e5061510
diff --git a/www-client/firefox/firefox-9999.ebuild b/www-client/firefox/firefox-9999.ebuild
index e098ee4..bac7ea3 100644
--- a/www-client/firefox/firefox-9999.ebuild
+++ b/www-client/firefox/firefox-9999.ebuild
@@ -1,27 +1,15 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="3"
+
inherit mozilla-scm
DESCRIPTION="Firefox Web Browser"
-HOMEPAGE="http://www.mozilla.com/firefox"
+HOMEPAGE="http://www.mozilla.com/en-US/firefox"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2.1 )"
-IUSE=""
-
-DEPEND="
- webm? ( dev-lang/yasm )
- "
-
-SRC_URI=""
-S="${WORKDIR}/mozilla-central"
-
-QA_PRESTRIPPED="usr/$(get_libdir)/${PN}/firefox"
src_prepare() {
# Gentoo specific stuff
@@ -48,93 +36,7 @@ src_prepare() {
}
src_configure() {
- MOZILLA_FIVE_HOME="/usr/$(get_libdir)/${PN}"
-
- ####################################
- #
- # mozconfig, CFLAGS and CXXFLAGS setup
- #
- ####################################
-
- mozconfig_init
- mozconfig_config
-
- # It doesn't compile on alpha without this LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- mozconfig_annotate '' --enable-extensions="${MEXTENSIONS}"
- mozconfig_annotate '' --enable-application=browser
- mozconfig_annotate '' --enable-official-branding
- mozconfig_annotate '' --disable-mailnews
- mozconfig_annotate '' --disable-crashreporter
- mozconfig_annotate '' --enable-image-encoder=all
- mozconfig_annotate '' --enable-canvas
- mozconfig_annotate 'gtk' --enable-default-toolkit=cairo-gtk2
-
- # Bug 60668: Galeon doesn't build without oji enabled, so enable it
- # regardless of java setting.
- mozconfig_annotate '' --enable-oji --enable-mathml
- mozconfig_annotate 'places' --enable-storage --enable-places
- mozconfig_annotate '' --enable-safe-browsing
-
- # System-wide install specs
- mozconfig_annotate '' --disable-installer
- mozconfig_annotate '' --disable-updater
- mozconfig_annotate '' --disable-strip
- mozconfig_annotate '' --disable-install-strip
-
- # Use system libraries
- mozconfig_annotate '' --enable-system-cairo
- mozconfig_annotate '' --enable-system-hunspell
- mozconfig_annotate '' --with-system-nspr --with-nspr-prefix="${EPREFIX}"/usr
- mozconfig_annotate '' --with-system-nss --with-nss-prefix="${EPREFIX}"/usr
- mozconfig_annotate '' --x-includes="${EPREFIX}"/usr/include --x-libraries="${EPREFIX}"/usr/$(get_libdir)
- mozconfig_annotate '' --with-system-bz2
- mozconfig_annotate '' --with-system-png
- if use webm ; then
- mozconfig_annotate '' --with-system-libvpx
- fi
- mozconfig_annotate '' --with-system-libxul
- mozconfig_annotate '' --with-libxul-sdk="${EPREFIX}"/usr/$(get_libdir)/xulrunner-devel-${MAJ_XUL_PV}
-
- mozconfig_use_enable ipc # +ipc, upstream default
- mozconfig_use_enable libnotify
- mozconfig_use_enable wifi necko-wifi
- mozconfig_use_enable alsa ogg
- mozconfig_use_enable alsa wave
- mozconfig_use_enable system-sqlite
- mozconfig_use_enable webm
-
- # NOTE: Uses internal copy of libvpx
- if use webm && ! use alsa; then
- ewarn "USE=webm needs USE=alsa, disabling WebM support."
- mozconfig_annotate '+webm -alsa' --disable-webm
- fi
-
- if use amd64 || use x86 || use arm || use sparc; then
- mozconfig_annotate '' --enable-tracejit
- fi
-
- # Other ff-specific settings
- mozconfig_annotate '' --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME}
-
- # omni.jar breaks ff on xr
- mozconfig_annotate '' --enable-chrome-format=jar
-
- # Finalize and report settings
- mozconfig_final
-
- if [[ $(gcc-major-version) -lt 4 ]]; then
- append-cxxflags -fno-stack-protector
- fi
-
- ####################################
- #
- # Configure and build
- #
- ####################################
-
- CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" PYTHON="$(PYTHON)" econf
+ mozconfig_configure
}
src_install() {
@@ -146,9 +48,4 @@ src_install() {
# Plugins dir
dosym ../nsbrowser/plugins "${MOZILLA_FIVE_HOME}"/plugins \
|| die "failed to symlink"
-
- # very ugly hack to make firefox not sigbus on sparc
- use sparc && { sed -e 's/Firefox/FirefoxGentoo/g' \
- -i "${ED}/${MOZILLA_FIVE_HOME}/application.ini" || \
- die "sparc sed failed"; }
}