aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/geany-plugins/geany-plugins-9999.ebuild')
-rw-r--r--dev-util/geany-plugins/geany-plugins-9999.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/dev-util/geany-plugins/geany-plugins-9999.ebuild b/dev-util/geany-plugins/geany-plugins-9999.ebuild
deleted file mode 100644
index e0ce34e..0000000
--- a/dev-util/geany-plugins/geany-plugins-9999.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-EGIT_REPO_URI="git://github.com/geany/geany-plugins"
-inherit base git-2 autotools
-
-DESCRIPTION="A collection of different plugins for Geany"
-HOMEPAGE="http://plugins.geany.org/geany-plugins"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="
- debugger
- devhelp
- enchant
- gendoc
- gtkspell
- lua
- nls
- webkit
- "
-
-RDEPEND="
- =dev-util/geany-9999
- debugger? ( x11-libs/vte:0 )
- devhelp? (
- >=dev-util/devhelp-2
- <dev-util/devhelp-2.32
- net-libs/webkit-gtk:2
- )
- enchant? ( app-text/enchant )
- gendoc? ( >=dev-libs/ctpl-0.3 )
- gtkspell? ( app-text/gtkspell )
- lua? ( dev-lang/lua )
- webkit? (
- net-libs/webkit-gtk:2
- x11-libs/gtk+:2
- x11-libs/gdk-pixbuf:2
- )
- "
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- "
-
-src_prepare() {
- # LINGUAS hack
- pushd po &>/dev/null
- for l in $LINGUAS; do
- test -f ${l}.po || LINGUAS=${LINGUAS/$l/}
- done
- popd &>/dev/null
-
- mkdir -p build/cache
- intltoolize --force --copy --automake || die "intltoolize failed"
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-fast-install \
- $(use_enable debugger) \
- $(use_enable devhelp) \
- $(use_enable enchant spellcheck) \
- $(use_enable gendoc geanygendoc) \
- $(use_enable gtkspell) \
- $(use_enable lua geanylua) \
- $(use_enable webkit webhelper) \
- $(use_enable nls)
-}
-
-src_install() {
- base_src_install
- find "${ED}" -name '*.la' -exec rm -f '{}' + || die
-}