summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuetzaly Daniela Solano Gómez <gentoo@sattvik.com>2023-05-08 21:45:59 -0500
committerQuetzaly Daniela Solano Gómez <gentoo@sattvik.com>2023-05-08 21:45:59 -0500
commit139c8136e6beea8c77d45609863f9ff30705c83d (patch)
tree0c72593ec225b3fcd1da5293b60f340a05703c77 /media-libs
parentapp-emulation/*: Sync with stefantalpalaru-overlay (diff)
downloadsattvik-139c8136e6beea8c77d45609863f9ff30705c83d.tar.gz
sattvik-139c8136e6beea8c77d45609863f9ff30705c83d.tar.bz2
sattvik-139c8136e6beea8c77d45609863f9ff30705c83d.zip
media-libs/elgato-streamdeck: Update elgato-streamdeck
Signed-off-by: Quetzaly Daniela Solano Gómez <gentoo@sattvik.com>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/elgato-streamdeck/Manifest2
-rw-r--r--media-libs/elgato-streamdeck/elgato-streamdeck-0.9.3.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/elgato-streamdeck/Manifest b/media-libs/elgato-streamdeck/Manifest
index 1510d66..42123bc 100644
--- a/media-libs/elgato-streamdeck/Manifest
+++ b/media-libs/elgato-streamdeck/Manifest
@@ -1,3 +1,5 @@
DIST elgato-streamdeck-0.9.2.tar.gz 2551240 BLAKE2B f64bc57bcc80f101019e149d8999254e1413434d6925e8882f485e00e597cb529e1da5baaf99d8abda884f7587eee88666a383b0dfbdd076711d2a887750767c SHA512 77a29707eb237f1e75f2e0734d163be2cb598525b565fe2616cf30b90b46411cb613e3d55a31bb462c49d6f4c7c67389f4f6728465f6155ead565a14c0dd03fd
+DIST elgato-streamdeck-0.9.3.tar.gz 2551267 BLAKE2B 3db8b15111ccc0ff01908347de517faaee32df25640b24e37245aa2bd7775c9bb10567d47f466886f17819ab3646ed8687d207ffe4b7b97dcd3314001e11495e SHA512 96e9765fb6d579b692a2aa55b19bb82d4145821a3eee05adbc30409b319aca36c6afd783df22f1b33f0532a392e6b7609c047eb3bfb4d22af5cec01d3ddebf71
EBUILD elgato-streamdeck-0.9.2.ebuild 695 BLAKE2B 5b0273793f50a24be6a04a66716a2af45121b75e705628a1cba9543915c9845ab526ac2f00cd1c1169c3e0f11b266bc7c70377009db9a61ccfef3c642bb3b3f4 SHA512 c55835fb689cdf4833baff7d2162bbfcdad4e60a5653ce7898168266665e51c289ca19daade758e7c20f4056848fea4513ca18566dd8a1a81b1ddb0a4fac1a86
+EBUILD elgato-streamdeck-0.9.3.ebuild 695 BLAKE2B 5b0273793f50a24be6a04a66716a2af45121b75e705628a1cba9543915c9845ab526ac2f00cd1c1169c3e0f11b266bc7c70377009db9a61ccfef3c642bb3b3f4 SHA512 c55835fb689cdf4833baff7d2162bbfcdad4e60a5653ce7898168266665e51c289ca19daade758e7c20f4056848fea4513ca18566dd8a1a81b1ddb0a4fac1a86
MISC metadata.xml 349 BLAKE2B 68b8afab75b2a9cc9f8059a61db0c3c2cc48109bb743f831362e4a13cee23221eb4febc65f496bf0f812c949eab2a68ab6d504dc22cdba9b21d907ba72018df2 SHA512 ab698da97f91600c16ad1059b000a3cbb7ec3057cf311452316b493c124f05cbd9acffd9fccb61f4b3209b50bc7de14e6c4ece3b16d4acf9d3df7729fae94a2e
diff --git a/media-libs/elgato-streamdeck/elgato-streamdeck-0.9.3.ebuild b/media-libs/elgato-streamdeck/elgato-streamdeck-0.9.3.ebuild
new file mode 100644
index 0000000..f3a8e8a
--- /dev/null
+++ b/media-libs/elgato-streamdeck/elgato-streamdeck-0.9.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10,11} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to control the Elgato Stream Deck"
+HOMEPAGE="https://github.com/abcminiuser/python-elgato-streamdeck"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/abcminiuser/python-elgato-streamdeck.git"
+else
+ SRC_URI="https://github.com/abcminiuser/python-elgato-streamdeck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python-${P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/pillow-9.0.0[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"