summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Solano Gómez <daniel@solanogomez.org>2009-10-26 09:54:14 -0500
committerDaniel Solano Gómez <daniel@solanogomez.org>2009-10-26 09:54:14 -0500
commitaf61ac2ea38bd12f5f54649df86eac9184c0d46d (patch)
treee8fda175a7f558fa8f8e94bbbbad3e4619732ab2 /media-libs
downloadsattvik-af61ac2ea38bd12f5f54649df86eac9184c0d46d.tar.gz
sattvik-af61ac2ea38bd12f5f54649df86eac9184c0d46d.tar.bz2
sattvik-af61ac2ea38bd12f5f54649df86eac9184c0d46d.zip
Initial commit from backup.
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libgphoto2/Manifest6
l---------media-libs/libgphoto2/files1
-rw-r--r--media-libs/libgphoto2/libgphoto2-2.4.5.ebuild192
3 files changed, 199 insertions, 0 deletions
diff --git a/media-libs/libgphoto2/Manifest b/media-libs/libgphoto2/Manifest
new file mode 100644
index 0000000..ef09ebf
--- /dev/null
+++ b/media-libs/libgphoto2/Manifest
@@ -0,0 +1,6 @@
+AUX gphoto2-ixany.patch 533 RMD160 84c48af39a8e843765816060656132a4dd467b22 SHA1 2021fdc650a29c0faef13d5feba91ba635fc3d00 SHA256 abaffc4911b4cc60b0df55ad7055a0a71b2b1d79390ba21a20dd9c911954ffca
+AUX libgphoto2-2.4.0-rpm.patch 452 RMD160 694c3f602a6b20fbcd135586d69551e335328f84 SHA1 ebbee5e9c4a6c1659e6fe7278733ce9b1702d430 SHA256 39501ccdfc6c780b3aa6a105584b32e9e4a6ad7195a14a341210be9f2e871149
+AUX libgphoto2-2.4.3-automagic.patch 2111 RMD160 6cf8795ebfde7f20815979fa0a37152966ba768b SHA1 24d0e1278640918dbc182df38b2955fe5fab370c SHA256 5e259e288924cb1183c7953367e6f8933f99f358e4d43a1967b3273769725a90
+AUX libgphoto2-2.4.3-gcc43.patch 518 RMD160 d7e97ebe24b021ec6cdf8e9cc6372349ca233da2 SHA1 5617c07b8667313151d0a0f0c04b7fbcad21f91b SHA256 72f955095498e4ae53f02ec68f2e0c433240340ebd542e7cfbd5c7921472453e
+DIST libgphoto2-2.4.5.tar.bz2 5251180 RMD160 b5add1b9d13079578c113f45a11eafa8372c1c84 SHA1 b1f51f0587afbe454db411f9005bd6ce5138156b SHA256 d32df1ba44ade8aace11258c2e8d5a1ec7182fc5e6375a6cf2e7c9d5256f37de
+EBUILD libgphoto2-2.4.5.ebuild 6172 RMD160 2fcae7f27ff5718bbe985e61f08c17a61f9db33e SHA1 3f87fee27c36c2336c462082e15c6b172c58058e SHA256 e32e814cc5f2da3e9eeb21cb19b33e9418ef170db8e311c2626eafaec9e80cd7
diff --git a/media-libs/libgphoto2/files b/media-libs/libgphoto2/files
new file mode 120000
index 0000000..6bd574b
--- /dev/null
+++ b/media-libs/libgphoto2/files
@@ -0,0 +1 @@
+/usr/portage/media-libs/libgphoto2/files \ No newline at end of file
diff --git a/media-libs/libgphoto2/libgphoto2-2.4.5.ebuild b/media-libs/libgphoto2/libgphoto2-2.4.5.ebuild
new file mode 100644
index 0000000..c39189a
--- /dev/null
+++ b/media-libs/libgphoto2/libgphoto2-2.4.5.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libgphoto2/libgphoto2-2.4.4.ebuild,v 1.3 2009/04/05 21:28:12 mr_bones_ Exp $
+
+# TODO
+# 1. Track upstream bug --disable-docs does not work.
+# http://sourceforge.net/tracker/index.php?func=detail&aid=1643870&group_id=8874&atid=108874
+# 3. Track upstream bug regarding rpm usage.
+# http://sourceforge.net/tracker/index.php?func=detail&aid=1643813&group_id=8874&atid=358874
+
+EAPI="2"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Library that implements support for numerous digital cameras"
+HOMEPAGE="http://www.gphoto.org/"
+SRC_URI="mirror://sourceforge/gphoto/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="bonjour doc exif hal nls kernel_linux"
+RESTRICT="test"
+
+# By default, drivers for all supported cameras will be compiled.
+# If you want to only compile for specific camera(s), set CAMERAS
+# environment to a space-separated list (no commas) of drivers that
+# you want to build.
+IUSE_CAMERAS="adc65 agfa_cl20 aox barbie canon casio_qv clicksmart310
+digigr8 digita dimera3500 directory enigma13 fuji gsmart300 hp215 iclick
+jamcam jd11 jl2005a kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200
+konica konica_qm150 largan lg_gsm mars dimagev mustek panasonic_coolshot
+panasonic_l859 panasonic_dc1000 panasonic_dc1580 pccam300 pccam600
+polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung
+sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55
+soundvision spca50x sq905 stv0674 stv0680 sx330z template toshiba_pdrm11
+topfield"
+
+# jl2005c is still experimental -> not enabled
+
+for camera in ${IUSE_CAMERAS}; do
+ IUSE="${IUSE} cameras_${camera}"
+done
+
+# libgphoto2 actually links to libtool
+RDEPEND=">=dev-libs/libusb-0.1.8
+ bonjour? ( || (
+ net-dns/avahi[mdnsresponder-compat]
+ net-misc/mDNSResponder ) )
+ exif? ( >=media-libs/libexif-0.5.9 )
+ hal? (
+ >=sys-apps/hal-0.5
+ >=sys-apps/dbus-1 )
+ sys-devel/libtool"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/flex
+ >=sys-devel/gettext-0.14.1
+ doc? ( app-doc/doxygen )"
+# FIXME: gtk-doc is broken
+# >=dev-util/gtk-doc-1.10 )"
+
+RDEPEND="${RDEPEND}
+ !<sys-fs/udev-114"
+
+pkg_setup() {
+ if ! echo "${USE}" | grep "cameras_" > /dev/null 2>&1; then
+ einfo "libgphoto2 supports: all ${IUSE_CAMERAS}"
+ einfo "All camera drivers will be built since you did not specify"
+ einfo "via the CAMERAS variable what camera you use."
+ ewarn "NOTICE: Upstream will not support you if you do not compile all camera drivers first"
+ fi
+
+ if use cameras_template || use cameras_sipix_blink; then
+ einfo "Upstream considers sipix_blink & template driver as obsolete"
+ fi
+
+ enewgroup plugdev
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.0-rpm.patch
+
+ # Fix pkgconfig file when USE="-exif"
+ use exif || sed -i "s/, @REQUIREMENTS_FOR_LIBEXIF@//" libgphoto2.pc.in || die " libgphoto2.pc sed failed"
+
+ # Fix bug #216206, libusb detection
+ sed -i "s:usb_busses:usb_find_busses:g" libgphoto2_port/configure || die "libusb sed failed"
+
+ # Fix building on alpha, bug #221853 comment #6
+ epatch "${FILESDIR}/gphoto2-ixany.patch"
+
+ cd "${S}/libgphoto2_port"
+ eautoreconf
+}
+
+src_configure() {
+ local cameras
+ local cam
+ for cam in ${IUSE_CAMERAS} ; do
+ use "cameras_${cam}" && cameras="${cameras},${cam}"
+ done
+
+ [ -z "${cameras}" ] \
+ && cameras="all" \
+ || cameras="${cameras:1}"
+
+ einfo "Enabled camera drivers: ${cameras}"
+ [ "${cameras}" != "all" ] && \
+ ewarn "Upstream will not support you if you do not compile all camera drivers first"
+
+ econf \
+ --disable-docs \
+ --disable-gp2ddb \
+ $(use_with bonjour) \
+ $(use_with hal) \
+ $(use_enable nls) \
+ $(use_with exif libexif) \
+ --with-drivers=${cameras} \
+ --with-doc-dir=/usr/share/doc/${PF} \
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ --with-hotplug-doc-dir=/usr/share/doc/${PF}/hotplug \
+ --with-rpmbuild=$(type -P true) \
+ udevscriptdir=/$(get_libdir)/udev
+
+# FIXME: gtk-doc is currently broken
+# $(use_enable doc docs)
+}
+
+src_compile() {
+ emake || die "make failed"
+
+ if use doc; then
+ doxygen doc/Doxyfile || die "Documentation generation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ # FIXME: fixup autoconf bug
+ if ! use doc && [ -d "${D}/usr/share/doc/${PF}/apidocs.html" ]; then
+ rm -fr "${D}/usr/share/doc/${PF}/apidocs.html"
+ fi
+ # end fixup
+
+ dodoc ChangeLog NEWS* README AUTHORS TESTERS MAINTAINERS HACKING
+
+ HAL_FDI="/usr/share/hal/fdi/information/20thirdparty/10-camera-libgphoto2.fdi"
+ UDEV_RULES="/etc/udev/rules.d/70-libgphoto2.rules"
+ CAM_LIST="/usr/$(get_libdir)/libgphoto2/print-camera-list"
+
+ if [ -x "${D}"${CAM_LIST} ]; then
+ # Let print-camera-list find libgphoto2.so
+ export LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
+ # Let libgphoto2 find its camera-modules
+ export CAMLIBS="${D}/usr/$(get_libdir)/libgphoto2/${PV}"
+
+ if use hal && [ -n "$("${D}"${CAM_LIST} idlist)" ]; then
+ einfo "Generating HAL FDI files ..."
+ mkdir -p "${D}"/${HAL_FDI%/*}
+ "${D}"${CAM_LIST} hal-fdi >> "${D}"/${HAL_FDI} \
+ || die "failed to create hal-fdi"
+ else
+ ewarn "No HAL FDI file generated because no real camera driver enabled"
+ fi
+
+ einfo "Generating UDEV-rules ..."
+ mkdir -p "${D}"/${UDEV_RULES%/*}
+ echo -e "# do not edit this file, it will be overwritten on update\n#" \
+ > "${D}"/${UDEV_RULES}
+ "${D}"${CAM_LIST} udev-rules version 0.98 group plugdev >> "${D}"/${UDEV_RULES} \
+ || die "failed to create udev-rules"
+ else
+ eerror "Unable to find print-camera-list"
+ eerror "and therefore unable to generate hotplug usermap or HAL FDI files."
+ eerror "You will have to manually generate it by running:"
+ eerror " ${CAM_LIST} udev-rules version 0.98 group plugdev > ${UDEV_RULES}"
+ eerror " ${CAM_LIST} hal-fdi > ${HAL_FDI}"
+ fi
+
+}
+
+pkg_postinst() {
+ elog "Don't forget to add yourself to the plugdev group "
+ elog "if you want to be able to access your camera."
+ local OLD_UDEV_RULES="${ROOT}"etc/udev/rules.d/99-libgphoto2.rules
+ if [[ -f ${OLD_UDEV_RULES} ]]; then
+ rm -f "${OLD_UDEV_RULES}"
+ fi
+}