summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorg Gast <georg@schorsch-tech.de>2016-03-07 20:00:02 +0100
committerGeorg Gast <georg@schorsch-tech.de>2016-03-07 20:00:02 +0100
commit233d840cbed3459b433c45cfc1f2270fc850b7f9 (patch)
tree23da52e09381b8ee5f9916928724944e7cfc3f8e /dev-libs/actor-framework
parentInitial commit (diff)
downloadschorsch_76-233d840cbed3459b433c45cfc1f2270fc850b7f9.tar.gz
schorsch_76-233d840cbed3459b433c45cfc1f2270fc850b7f9.tar.bz2
schorsch_76-233d840cbed3459b433c45cfc1f2270fc850b7f9.zip
actor framework and google-benchmarks
Diffstat (limited to 'dev-libs/actor-framework')
-rw-r--r--dev-libs/actor-framework/Manifest1
-rw-r--r--dev-libs/actor-framework/actor-framework-9999.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/actor-framework/Manifest b/dev-libs/actor-framework/Manifest
new file mode 100644
index 0000000..d2ce287
--- /dev/null
+++ b/dev-libs/actor-framework/Manifest
@@ -0,0 +1 @@
+EBUILD actor-framework-9999.ebuild 762 SHA256 42a38cf23dffa7a9f613d31bb4751b86bff491167f2a6b4fa6c959829bb03513 SHA512 80a54ef825122d8c671e132219521e7024928d380982237ae4dba6683344270cf28485f257ec0b228424114f9dff00f8f7ed19ef3ea55aa6bf83eff79feea56a WHIRLPOOL 55202f4716cf6337e7b0ca898f72e9f7f74fdc67acbc5945c65735c91154b1596bfa49b9f2ed7332963ae61bdee9d38a5fa27518d2ce5b535b83d665fb532f4e
diff --git a/dev-libs/actor-framework/actor-framework-9999.ebuild b/dev-libs/actor-framework/actor-framework-9999.ebuild
new file mode 100644
index 0000000..5fa0bc3
--- /dev/null
+++ b/dev-libs/actor-framework/actor-framework-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:$
+
+EAPI="5"
+
+inherit git-2 cmake-utils flag-o-matic
+
+EGIT_REPO_URI="https://github.com/actor-framework/actor-framework"
+EGIT_BRANCH="master"
+
+DESCRIPTION="An Open Source Implementation of the Actor Model in C++"
+HOMEPAGE="https://actor-framework.org/"
+
+LICENSE="Boost-1.0"
+
+SLOT="0"
+
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/protobuf-2.5.0
+ dev-libs/libpthread-stubs
+ dev-util/cmake
+ >=sys-devel/gcc-4.8.0
+ >=net-misc/curl-7.45.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+KEYWORDS="~amd64"
+
+src_configure()
+{
+ append-cxxflags -std=c++11 -Wextra -Wall -pedantic -ftemplate-depth=512 -pthread -fPIC -Wno-deprecated-declarations
+ cmake-utils_src_configure
+}