summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorg Gast <georg@schorsch-tech.de>2016-03-07 20:00:02 +0100
committerGeorg Gast <georg@schorsch-tech.de>2016-03-07 20:00:02 +0100
commit233d840cbed3459b433c45cfc1f2270fc850b7f9 (patch)
tree23da52e09381b8ee5f9916928724944e7cfc3f8e /dev-libs/google-benchmark
parentInitial commit (diff)
downloadschorsch_76-233d840cbed3459b433c45cfc1f2270fc850b7f9.tar.gz
schorsch_76-233d840cbed3459b433c45cfc1f2270fc850b7f9.tar.bz2
schorsch_76-233d840cbed3459b433c45cfc1f2270fc850b7f9.zip
actor framework and google-benchmarks
Diffstat (limited to 'dev-libs/google-benchmark')
-rw-r--r--dev-libs/google-benchmark/Manifest1
-rw-r--r--dev-libs/google-benchmark/google-benchmark-9999.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/google-benchmark/Manifest b/dev-libs/google-benchmark/Manifest
new file mode 100644
index 0000000..29b51bb
--- /dev/null
+++ b/dev-libs/google-benchmark/Manifest
@@ -0,0 +1 @@
+EBUILD google-benchmark-9999.ebuild 708 SHA256 48a156557409036ae635aa713fbda9cba17de64be775a907948d4d9fcfddfdde SHA512 90e102e3038c6da631efcd65d0a33e69dd0fbd340a8c106a64ec44053585da0da4acd0666adb063421eab473f94b51bc130a533e2cfb2d0d6ddd64820acb56ad WHIRLPOOL f940e96309f83241da5c113f3c8616a6169880f4d3dee4b8c5738273adc08b7e9b172a64676746cb8293e95a07a65ef2a6d623bc9221a9ee44ef4208ad66f783
diff --git a/dev-libs/google-benchmark/google-benchmark-9999.ebuild b/dev-libs/google-benchmark/google-benchmark-9999.ebuild
new file mode 100644
index 0000000..7149e44
--- /dev/null
+++ b/dev-libs/google-benchmark/google-benchmark-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header:$
+
+EAPI="5"
+
+inherit git-2 cmake-utils flag-o-matic
+
+EGIT_REPO_URI="https://github.com/google/benchmark"
+EGIT_BRANCH="master"
+
+DESCRIPTION="A microbenchmark support library"
+HOMEPAGE="https://github.com/google/benchmark"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/protobuf-2.5.0
+ dev-util/cmake
+ >=sys-devel/gcc-4.8.0
+ >=net-misc/curl-7.45.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+KEYWORDS="~amd64"
+
+src_configure()
+{
+# local mycmakeargs=(
+# $(cmake-utils_use cgi BUILD_CGI)
+# )
+ append-cxxflags -std=c++11 -Wno-deprecated-declarations
+ cmake-utils_src_configure
+
+}