summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2017-06-01 13:41:56 +0200
committerSven Eden <sven.eden@gmx.de>2017-06-01 13:41:56 +0200
commit2528a0baf8119c8c801785c96c78641ab51169b3 (patch)
tree3ba732d61da39efc5bfa1da77cd41054391f331a
parentUpdate and cleanup elogind, networkmanager-qt and gvfs (diff)
downloadseden-2528a0baf8119c8c801785c96c78641ab51169b3.tar.gz
seden-2528a0baf8119c8c801785c96c78641ab51169b3.tar.bz2
seden-2528a0baf8119c8c801785c96c78641ab51169b3.zip
sys-apps/accountsservice-0.6.43-r3 : Cleaned up the elogind patch.
-rw-r--r--profiles/package.mask/elogind2
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.43-r3.ebuild (renamed from sys-apps/accountsservice/accountsservice-0.6.43-r2.ebuild)0
-rw-r--r--sys-apps/accountsservice/files/accountsservice-enable-elogind.patch93
3 files changed, 52 insertions, 43 deletions
diff --git a/profiles/package.mask/elogind b/profiles/package.mask/elogind
index eecc207..9ae38c2 100644
--- a/profiles/package.mask/elogind
+++ b/profiles/package.mask/elogind
@@ -1,7 +1,7 @@
# Sven Eden <yamakuzure@gmx.net> (10 Nov 2016)
# Testing ebuilds for elogind integration
=gnome-base/gvfs-1.30.4-r1
-=sys-apps/accountsservice-0.6.43-r2
+=sys-apps/accountsservice-0.6.43-r3
=sys-auth/elogind-229.9999
=sys-auth/pambase-20150213-r2
=sys-process/procps-3.3.12-r2
diff --git a/sys-apps/accountsservice/accountsservice-0.6.43-r2.ebuild b/sys-apps/accountsservice/accountsservice-0.6.43-r3.ebuild
index f3aeb8d..f3aeb8d 100644
--- a/sys-apps/accountsservice/accountsservice-0.6.43-r2.ebuild
+++ b/sys-apps/accountsservice/accountsservice-0.6.43-r3.ebuild
diff --git a/sys-apps/accountsservice/files/accountsservice-enable-elogind.patch b/sys-apps/accountsservice/files/accountsservice-enable-elogind.patch
index 5c3a950..6aa8f90 100644
--- a/sys-apps/accountsservice/files/accountsservice-enable-elogind.patch
+++ b/sys-apps/accountsservice/files/accountsservice-enable-elogind.patch
@@ -1,82 +1,91 @@
---- a/configure.ac 2017-01-10 14:41:49.303134338 +0100
-+++ b/configure.ac 2017-01-10 14:49:17.627133630 +0100
-@@ -264,6 +264,49 @@
+--- a/config.h.in 2017-06-01 13:38:32.406980179 +0200
++++ b/config.h.in 2017-06-01 13:38:46.546980454 +0200
+@@ -144,6 +144,9 @@
+ /* Version number of package */
+ #undef VERSION
+
++/* Define to enable elogind support */
++#undef WITH_ELOGIND
++
+ /* Define to enable systemd support */
+ #undef WITH_SYSTEMD
+
+--- a/configure.ac 2017-06-01 13:06:23.669942591 +0200
++++ b/configure.ac 2017-06-01 13:20:51.570959505 +0200
+@@ -264,6 +264,39 @@
dnl ---------------------------------------------------------------------------
AC_PATH_PROG([XSLTPROC], [xsltproc])
+# elogind
+
++have_elogind=no
++
++AC_MSG_CHECKING([whether to use elogind])
++
+AC_ARG_ENABLE([elogind],
+ AS_HELP_STRING([--enable-elogind], [Use elogind]),
-+ [enable_elogind=$enableval],
-+ [enable_elogind=auto])
++ [enable_elogind=$enableval])
++
++AC_MSG_RESULT($enable_elogind)
+
+if test "x$enable_elogind" != "xno"; then
-+ PKG_CHECK_MODULES(ELOGIND, [libelogind >= 219],
-+ [have_elogind=yes],
-+ [have_elogind=no])
-+else
-+ have_elogind=no
++ PKG_CHECK_MODULES(ELOGIND, [libelogind >= 219],
++ [have_elogind=yes],
++ [have_elogind=no])
+fi
+
-+AC_MSG_CHECKING([whether to use elogind])
-+
-+if test "x$enable_elogind" = "xauto" ; then
-+ if test "x$have_elogind" = "xno" ; then
-+ enable_elogind=no
++if test "x$enable_elogind" != "xno"; then
++ if test "x$have_elogind" != "xyes"; then
++ AC_MSG_ERROR([elogind support explicitly required, but libelogind not found])
+ else
-+ enable_elogind=yes
-+ fi
-+fi
++ AC_SUBST(ELOGIND_CFLAGS)
++ AC_SUBST(ELOGIND_LIBS)
+
-+AC_MSG_RESULT($enable_elogind)
++ LIBACCOUNTSSERVICE_LIBS="$LIBACCOUNTSSERVICE_LIBS $ELOGIND_LIBS"
++ LIBACCOUNTSSERVICE_CFLAGS="$LIBACCOUNTSSERVICE_CFLAGS $ELOGIND_CFLAGS"
+
-+if test "x$enable_elogind" = "xyes"; then
-+ if test "x$have_elogind" = "xno"; then
-+ AC_MSG_ERROR([elogind support explicitly required, but libelogind not found])
++ AC_DEFINE(WITH_ELOGIND, 1, [Define to enable elogind support])
+ fi
+fi
-+AC_SUBST(ELOGIND_CFLAGS)
-+AC_SUBST(ELOGIND_LIBS)
-+
-+LIBACCOUNTSSERVICE_LIBS="$LIBACCOUNTSSERVICE_LIBS $ELOGIND_LIBS"
-+LIBACCOUNTSSERVICE_CFLAGS="$LIBACCOUNTSSERVICE_CFLAGS $ELOGIND_CFLAGS"
-+
-+if test "x$have_elogind" != "xno" ; then
-+ AC_DEFINE(WITH_ELOGIND, 1, [Define to enable elogind support])
-+fi
+
+
# systemd
AC_ARG_ENABLE([systemd],
-@@ -272,8 +315,14 @@
+@@ -272,8 +305,15 @@
[enable_systemd=auto])
if test x$enable_systemd != xno; then
-+ if test "x$have_elogind" != "xno"; then
+- PKG_CHECK_MODULES(SYSTEMD, [libsystemd >= 186],
+- [have_systemd=yes], [have_systemd=no])
++ if test "x$enable_elogind" != "xno"; then
+ AC_MSG_NOTICE([Systemd support requested, but elogind found])
+ have_systemd=no
+ enable_systemd=no
+ else
- PKG_CHECK_MODULES(SYSTEMD, [libsystemd >= 186],
- [have_systemd=yes], [have_systemd=no])
++ PKG_CHECK_MODULES(SYSTEMD, [libsystemd >= 186],
++ [have_systemd=yes],
++ [have_systemd=no])
+ fi
else
have_systemd=no
fi
---- a/src/libaccountsservice/act-user-manager.c 2016-11-08 09:11:28.489353842 +0100
-+++ b/src/libaccountsservice/act-user-manager.c 2016-11-08 09:18:47.768357775 +0100
-@@ -42,7 +42,12 @@
- #include <gio/gunixinputstream.h>
+--- a/src/libaccountsservice/act-user-manager.c 2017-06-01 13:06:17.869942478 +0200
++++ b/src/libaccountsservice/act-user-manager.c 2017-06-01 13:19:09.037957507 +0200
+@@ -43,8 +43,16 @@
#ifdef WITH_SYSTEMD
#include <systemd/sd-login.h>
-+#else
++#endif
++
+#ifdef WITH_ELOGIND
+#include <elogind/sd-login.h>
-+#define WITH_SYSTEMD 1 /* Do not clutter the sources */
-+#endif /* check against elogind substitution
++/* Re-Use WITH_SYSTEMD as elogind substitutes systemd-login */
++#define WITH_SYSTEMD 1
++#endif
/* check if logind is running */
++#ifdef WITH_SYSTEMD
#define LOGIND_RUNNING() (access("/run/systemd/seats/", F_OK) >= 0)
+ #endif
+