summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2017-07-27 22:13:09 +0200
committerSven Eden <sven.eden@gmx.de>2017-07-27 22:13:09 +0200
commit7eba9fb54d0e8734f8d8306cc19892e36f87a77f (patch)
tree4ece670ca9012538c30a6991e1b1b532b71cc924
parentsys-auth/elogind-234: In this Version, the path to elogind changes, just like... (diff)
downloadseden-7eba9fb54d0e8734f8d8306cc19892e36f87a77f.tar.gz
seden-7eba9fb54d0e8734f8d8306cc19892e36f87a77f.tar.bz2
seden-7eba9fb54d0e8734f8d8306cc19892e36f87a77f.zip
sys-auth/elogind: Update of all live ebuilds:
- --disable-lto switch added. LTO activation must be users choice. - Moved elogind to "${EPREFIX}"/$(get_libdir)/libexec
-rw-r--r--sys-auth/elogind/elogind-229.9999.ebuild7
-rw-r--r--sys-auth/elogind/elogind-231.9999.ebuild7
-rw-r--r--sys-auth/elogind/elogind-232.9999.ebuild7
-rw-r--r--sys-auth/elogind/elogind-233.9999.ebuild7
-rw-r--r--sys-auth/elogind/elogind-234.9999.ebuild9
-rw-r--r--sys-auth/elogind/files/elogind.conf7
-rw-r--r--sys-auth/elogind/files/elogind.conf.in (renamed from sys-auth/elogind/files/elogind-234.conf)2
7 files changed, 27 insertions, 19 deletions
diff --git a/sys-auth/elogind/elogind-229.9999.ebuild b/sys-auth/elogind/elogind-229.9999.ebuild
index 162e1ca..cedfd6d 100644
--- a/sys-auth/elogind/elogind-229.9999.ebuild
+++ b/sys-auth/elogind/elogind-229.9999.ebuild
@@ -60,9 +60,10 @@ src_configure() {
--with-udevrulesdir="$(get_udevdir)"/rules.d \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
--with-rootlibdir="${EPREFIX}"/$(get_libdir) \
+ --with-rootlibexecdir="${EPREFIX}"/$(get_libdir)/libexec \
--enable-smack \
- --disable-lto \
--disable-kdbus \
+ --disable-lto \
$(use_enable debug debug elogind) \
$(use_enable acl) \
$(use_enable pam) \
@@ -74,7 +75,9 @@ src_install() {
find "${D}" -name '*.la' -delete || die
newinitd "${FILESDIR}"/${PN}.init ${PN}
- newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
}
pkg_postinst() {
diff --git a/sys-auth/elogind/elogind-231.9999.ebuild b/sys-auth/elogind/elogind-231.9999.ebuild
index f1ae58f..c9b10ac 100644
--- a/sys-auth/elogind/elogind-231.9999.ebuild
+++ b/sys-auth/elogind/elogind-231.9999.ebuild
@@ -60,9 +60,10 @@ src_configure() {
--with-udevrulesdir="$(get_udevdir)"/rules.d \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
--with-rootlibdir="${EPREFIX}"/$(get_libdir) \
+ --with-rootlibexecdir="${EPREFIX}"/$(get_libdir)/libexec \
--enable-smack \
- --disable-lto \
--with-cgroup-controller=openrc \
+ --disable-lto \
$(use_enable debug debug elogind) \
$(use_enable acl) \
$(use_enable pam) \
@@ -74,7 +75,9 @@ src_install() {
find "${D}" -name '*.la' -delete || die
newinitd "${FILESDIR}"/${PN}.init ${PN}
- newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
}
pkg_postinst() {
diff --git a/sys-auth/elogind/elogind-232.9999.ebuild b/sys-auth/elogind/elogind-232.9999.ebuild
index 888e7c3..d475e40 100644
--- a/sys-auth/elogind/elogind-232.9999.ebuild
+++ b/sys-auth/elogind/elogind-232.9999.ebuild
@@ -60,9 +60,10 @@ src_configure() {
--with-udevrulesdir="$(get_udevdir)"/rules.d \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
--with-rootlibdir="${EPREFIX}"/$(get_libdir) \
+ --with-rootlibexecdir="${EPREFIX}"/$(get_libdir)/libexec \
--enable-smack \
- --disable-lto \
--with-cgroup-controller=openrc \
+ --disable-lto \
$(use_enable debug debug elogind) \
$(use_enable acl) \
$(use_enable pam) \
@@ -74,7 +75,9 @@ src_install() {
find "${D}" -name '*.la' -delete || die
newinitd "${FILESDIR}"/${PN}.init ${PN}
- newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
}
pkg_postinst() {
diff --git a/sys-auth/elogind/elogind-233.9999.ebuild b/sys-auth/elogind/elogind-233.9999.ebuild
index e2e625d..46eeca1 100644
--- a/sys-auth/elogind/elogind-233.9999.ebuild
+++ b/sys-auth/elogind/elogind-233.9999.ebuild
@@ -60,9 +60,10 @@ src_configure() {
--with-udevrulesdir="$(get_udevdir)"/rules.d \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
--with-rootlibdir="${EPREFIX}"/$(get_libdir) \
+ --with-rootlibexecdir="${EPREFIX}"/$(get_libdir)/libexec \
--enable-smack \
- --disable-lto \
--with-cgroup-controller=openrc \
+ --disable-lto \
$(use_enable debug debug elogind) \
$(use_enable acl) \
$(use_enable pam) \
@@ -74,7 +75,9 @@ src_install() {
find "${D}" -name '*.la' -delete || die
newinitd "${FILESDIR}"/${PN}.init ${PN}
- newconfd "${FILESDIR}"/${PN}.conf ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
}
pkg_postinst() {
diff --git a/sys-auth/elogind/elogind-234.9999.ebuild b/sys-auth/elogind/elogind-234.9999.ebuild
index 8567288..2466fcf 100644
--- a/sys-auth/elogind/elogind-234.9999.ebuild
+++ b/sys-auth/elogind/elogind-234.9999.ebuild
@@ -8,7 +8,7 @@ inherit autotools git-r3 linux-info pam udev
DESCRIPTION="The systemd project's logind, extracted to a standalone package"
HOMEPAGE="https://github.com/elogind/elogind"
EGIT_REPO_URI="https://github.com/elogind/elogind.git"
-EGIT_BRANCH="dev_v234"
+EGIT_BRANCH="v234-stable"
LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
SLOT="0"
@@ -60,10 +60,11 @@ src_configure() {
--with-udevrulesdir="$(get_udevdir)"/rules.d \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
--with-rootlibdir="${EPREFIX}"/$(get_libdir) \
+ --with-rootlibexecdir="${EPREFIX}"/$(get_libdir)/libexec \
--with-rootprefix="/" \
--enable-smack \
- --disable-lto \
--with-cgroup-controller=openrc \
+ --disable-lto \
$(use_enable debug debug elogind) \
$(use_enable acl) \
$(use_enable pam) \
@@ -75,7 +76,9 @@ src_install() {
find "${D}" -name '*.la' -delete || die
newinitd "${FILESDIR}"/${PN}.init ${PN}
- newconfd "${FILESDIR}"/${PN}-234.conf ${PN}
+
+ sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
+ newconfd ${PN}.conf ${PN}
}
pkg_postinst() {
diff --git a/sys-auth/elogind/files/elogind.conf b/sys-auth/elogind/files/elogind.conf
deleted file mode 100644
index 73d1336..0000000
--- a/sys-auth/elogind/files/elogind.conf
+++ /dev/null
@@ -1,7 +0,0 @@
-# /etc/conf.d/elogind: config file for /etc/init.d/elogind
-
-# this is the elogind executable
-ELOGIND_EXEC="/usr/libexec/elogind/elogind"
-
-# this is where elogind will store its pid file
-ELOGIND_PIDFILE="/var/run/elogind.pid"
diff --git a/sys-auth/elogind/files/elogind-234.conf b/sys-auth/elogind/files/elogind.conf.in
index 6e24ffd..d000c3f 100644
--- a/sys-auth/elogind/files/elogind-234.conf
+++ b/sys-auth/elogind/files/elogind.conf.in
@@ -1,7 +1,7 @@
# /etc/conf.d/elogind: config file for /etc/init.d/elogind
# this is the elogind executable
-ELOGIND_EXEC="/lib/elogind/elogind"
+ELOGIND_EXEC="/@libdir@/libexec/elogind"
# this is where elogind will store its pid file
ELOGIND_PIDFILE="/var/run/elogind.pid"