summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2018-12-21 05:49:58 +0100
committerSven Eden <sven.eden@gmx.de>2018-12-21 05:49:58 +0100
commitec1e8c51d10b39e6e9523acef56e69e97b86247e (patch)
tree4f7e1c0505ef9ff6c4dfc3d69f22f5c743759de4 /app-text
parentapp-text/getRandomName: New ebuild for version 0.9.0 (diff)
downloadseden-ec1e8c51d10b39e6e9523acef56e69e97b86247e.tar.gz
seden-ec1e8c51d10b39e6e9523acef56e69e97b86247e.tar.bz2
seden-ec1e8c51d10b39e6e9523acef56e69e97b86247e.zip
app-text/getRandomName: Bump 0.9.1 ; Add 9999
Fixed ebuild to actually work with the projects Makefile instead of blasting its mechanics. Signed-Off-By: Sven Eden <sven.eden@gmx.de> Package-Manager: Portage-2.3.52, Repoman-2.3.12
Diffstat (limited to 'app-text')
-rw-r--r--app-text/getRandomName/Manifest2
-rw-r--r--app-text/getRandomName/getRandomName-0.9.0.ebuild48
-rw-r--r--app-text/getRandomName/getRandomName-0.9.1.ebuild46
-rw-r--r--app-text/getRandomName/getRandomName-9999.ebuild48
-rw-r--r--app-text/getRandomName/metadata.xml5
5 files changed, 100 insertions, 49 deletions
diff --git a/app-text/getRandomName/Manifest b/app-text/getRandomName/Manifest
index 59c17bd..992d463 100644
--- a/app-text/getRandomName/Manifest
+++ b/app-text/getRandomName/Manifest
@@ -1 +1 @@
-DIST getRandomName-0.9.0.tar.gz 9557 SHA256 7525961c20215fda6e8c11a90d8353d96d01e0488214ee12dbb84ec03bd2b3ea SHA512 9ddae233fc076baa1a5fa19be4009f54adf8500b5bf232bba5b1470ebcb3defc6a7356ce5aa8525fb814dae44ed6b26302d01ab299ed7ec1b839410eebf3e15c WHIRLPOOL 1bfdf35f344ee9d9de64bd265156234b2b3fdd3ad495548d1856edb5e122ca3a6cb87154e2853b1520dd8113b5fa846ca9f0288fe0efbf413a5d2e0bf9d80e65
+DIST getRandomName-0.9.1.tar.gz 10245 SHA256 67984eef545f31b745ac236f5427929cd1c2a15d0744bc8efbe62564d42bffa9 SHA512 81359a33d11f4b14c3377cdd5b713943a9a8410fec7aee3c0eaa9c9ffb374a1009bfceac361e67f4c08a953752244c7d03b1ea45cb94efbbcc732999270cbaa6 WHIRLPOOL de779ea3d89f4cbbcaab0ef496d288786edfd8e2cc20d71a0ac7db01a86a4c81c67f7b8aa5b2ddfe8203a6e5bc3e28fd4646febbd891306f481c0aeebb1ee275
diff --git a/app-text/getRandomName/getRandomName-0.9.0.ebuild b/app-text/getRandomName/getRandomName-0.9.0.ebuild
deleted file mode 100644
index 5728b52..0000000
--- a/app-text/getRandomName/getRandomName-0.9.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Create random names using linguistic rules"
-HOMEPAGE="https://prydeworx.com/getRandomNames"
-SRC_URI="https://github.com/Yamakuzure/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-COMMON_DEPEND="
- dev-cpp/pwxlib
-"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-
-DOCS=()
-
-src_prepare() {
- # Makefile is a symlink to Makefile.Linux, avoid that we patch it by
- # accident using patch <2.7, see bug #435492
- rm Makefile || die
-
- EPATCH_SUFFIX="patch" epatch "${WORKDIR}/${PN}-gentoo-patches-${PATCHVER}"
-
- # Re-add convenience symlink, see above
- ln -s Makefile.Linux Makefile
-
- epatch "${FILESDIR}"/${P}-CVE-2014-8123.patch
-}
-
-src_configure() { :; }
-
-src_compile() {
- emake PREFIX="${EPREFIX}/usr" CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- CXX="$(tc-getCXX)" LD="$(tc-getCC)" LDFLAGS="${LDFLAGS}" \
- || die "emake failed"
-}
-
-src_install() {
- emake PREFIX="${EPREFIX}" DESTDIR="${D}" \
- DOCDIR="${EPREFIX}"/usr/share/doc/${PF} install \
- || die "install failed"
-}
diff --git a/app-text/getRandomName/getRandomName-0.9.1.ebuild b/app-text/getRandomName/getRandomName-0.9.1.ebuild
new file mode 100644
index 0000000..a3d650f
--- /dev/null
+++ b/app-text/getRandomName/getRandomName-0.9.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Create random names using linguistic rules"
+HOMEPAGE="https://prydeworx.com/getRandomNames"
+SRC_URI="https://github.com/Yamakuzure/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="asan debug lsan tsan"
+
+REQUIRED_USE="
+ asan? ( debug )
+ lsan? ( debug )
+ tsan? ( debug )
+"
+
+COMMON_DEPEND="
+ dev-cpp/pwxlib
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS=()
+
+src_compile() {
+ PREFIX="${EPREFIX}"usr CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CXX="$(tc-getCXX)" LD="$(tc-getCC)" \
+ DEBUG="$(usex debug YES NO)" \
+ SANITIZE_ADDRESS="$(usex asan YES NO)" \
+ SANITIZE_LEAK="$(usex lsan YES NO)" \
+ SANITIZE_THREAD="$(usex tsan YES NO)" \
+ emake || die "emake failed"
+}
+
+src_install() {
+ PREFIX="${EPREFIX}"usr DESTDIR="${D}" \
+ DOCDIR="${EPREFIX}"usr/share/doc/${PF} \
+ emake install || die "install failed"
+}
diff --git a/app-text/getRandomName/getRandomName-9999.ebuild b/app-text/getRandomName/getRandomName-9999.ebuild
new file mode 100644
index 0000000..0f6e09d
--- /dev/null
+++ b/app-text/getRandomName/getRandomName-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils git-r3 toolchain-funcs
+
+DESCRIPTION="Create random names using linguistic rules"
+HOMEPAGE="https://prydeworx.com/getRandomNames"
+EGIT_REPO_URI="https://github.com/Yamakuzure/getRandomName.git"
+EGIT_BRANCH="master"
+EGIT_SUBMODULES=()
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="asan debug lsan tsan"
+
+REQUIRED_USE="
+ asan? ( debug )
+ lsan? ( debug )
+ tsan? ( debug )
+"
+
+COMMON_DEPEND="
+ dev-cpp/pwxlib
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS=()
+
+src_compile() {
+ PREFIX="${EPREFIX}"usr CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CXX="$(tc-getCXX)" LD="$(tc-getCC)" \
+ DEBUG="$(usex debug YES NO)" \
+ SANITIZE_ADDRESS="$(usex asan YES NO)" \
+ SANITIZE_LEAK="$(usex lsan YES NO)" \
+ SANITIZE_THREAD="$(usex tsan YES NO)" \
+ emake || die "emake failed"
+}
+
+src_install() {
+ PREFIX="${EPREFIX}"usr DESTDIR="${D}" \
+ DOCDIR="${EPREFIX}"usr/share/doc/${PF} \
+ emake install || die "install failed"
+}
diff --git a/app-text/getRandomName/metadata.xml b/app-text/getRandomName/metadata.xml
index 58c7603..af88435 100644
--- a/app-text/getRandomName/metadata.xml
+++ b/app-text/getRandomName/metadata.xml
@@ -5,6 +5,11 @@
<email>yamakuzure@gmx.net</email>
<name>Sven Eden</name>
</maintainer>
+ <use>
+ <flag name="asan">Enable address sanitizer</flag>
+ <flag name="lsan">Enable leak sanitizer</flag>
+ <flag name="tsan">Enable thread sanitizer</flag>
+ </use>
<upstream>
<remote-id type="github">Yamakuzure/getRandomName</remote-id>
</upstream>