summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2018-12-20 19:38:10 +0100
committerSven Eden <sven.eden@gmx.de>2018-12-20 19:38:10 +0100
commit53588cb3f8c23a9a246a2a43e082985413651e89 (patch)
treeaf93676e79f6efd24c7d33b8b5da2b21a33c988a /dev-cpp
parentdev-cpp/pwxlib: New ebuild for version 0.8.9 (diff)
downloadseden-53588cb3f8c23a9a246a2a43e082985413651e89.tar.gz
seden-53588cb3f8c23a9a246a2a43e082985413651e89.tar.bz2
seden-53588cb3f8c23a9a246a2a43e082985413651e89.zip
dev-cpp/pwxlib: Remove graphite USE flag, it does nothing.
signed-Off-By: Sven Eden <sven.eden@gmx.de> Package-Manager: Portage-2.3.52, Repoman-2.3.12
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/pwxlib/metadata.xml1
-rw-r--r--dev-cpp/pwxlib/pwxlib-0.8.9.ebuild6
2 files changed, 3 insertions, 4 deletions
diff --git a/dev-cpp/pwxlib/metadata.xml b/dev-cpp/pwxlib/metadata.xml
index 39075aa..0b39e77 100644
--- a/dev-cpp/pwxlib/metadata.xml
+++ b/dev-cpp/pwxlib/metadata.xml
@@ -13,7 +13,6 @@
<flag name="debug-thread">
Produce massive debugging output. Do not enable lightly!
</flag>
- <flag name="graphite">Enable gcc graphite extensions.</flag>
<flag name="spinlocks">
Use spinlocks instead of mutexes. Improves performance.
</flag>
diff --git a/dev-cpp/pwxlib/pwxlib-0.8.9.ebuild b/dev-cpp/pwxlib/pwxlib-0.8.9.ebuild
index dc27856..e2efeac 100644
--- a/dev-cpp/pwxlib/pwxlib-0.8.9.ebuild
+++ b/dev-cpp/pwxlib/pwxlib-0.8.9.ebuild
@@ -12,10 +12,11 @@ SRC_URI="https://github.com/Yamakuzure/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="annotations debug debug-thread doc graphite profile +spinlocks test torture +yielding"
+IUSE="annotations debug debug-thread doc profile +spinlocks test torture +yielding"
REQUIRED_USE="
?? ( annotations debug-thread )
+ annotations? ( !spinlocks !yielding )
profile? ( !debug !debug-thread )
yielding? ( spinlocks )
"
@@ -24,7 +25,7 @@ COMMON_DEPEND="
"
DEPEND="${COMMON_DEPEND}
doc? ( app-doc/doxygen )
- >=sys-devel/gcc-8.2.0[graphite?]
+ >=sys-devel/gcc-8.2.0
virtual/pkgconfig
"
RDEPEND="${COMMON_DEPEND}"
@@ -41,7 +42,6 @@ src_configure() {
-Dannotations=$(usex annotations true false)
-Ddebug-extra=$(usex debug true false)
-Ddebug-thread=$(usex debug-thread true false)
- -Dgraphite=$(usex graphite true false)
-Dhtml=$(usex doc true false)
-Dinstall-tests=$(usex test true false)
-Dprofile=$(usex profile true false)