summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2018-07-24 19:47:32 +0200
committerSven Eden <sven.eden@gmx.de>2018-07-24 19:47:32 +0200
commit14be22f678669681f2e7c08b97f76abe01cedd47 (patch)
tree225b202138828293f3bacaa084c21a94005b40c5 /dev-games
parentdev-games/ogre: Bump all three ebuilds, not tested yet. (diff)
downloadseden-14be22f678669681f2e7c08b97f76abe01cedd47.tar.gz
seden-14be22f678669681f2e7c08b97f76abe01cedd47.tar.bz2
seden-14be22f678669681f2e7c08b97f76abe01cedd47.zip
dev-games/ogre-1.10.12 : Fix ebuild and metadata.xml
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch29
-rw-r--r--dev-games/ogre/metadata.xml14
-rw-r--r--dev-games/ogre/ogre-1.10.12.ebuild53
3 files changed, 40 insertions, 56 deletions
diff --git a/dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch b/dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch
deleted file mode 100644
index 53d7a09..0000000
--- a/dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-# HG changeset patch
-# User niparx <koliap@gmail.com>
-# Date 1515160111 -7200
-# Node ID 88f0d5be23c521e7504e3f6cb2a153428efcf159
-# Parent bc4fb04c1de686c23c6207eee69ae0ca9fddcb7c
-[OGRE-592] RTShaderSystem compile error when using double precision (#622)
-
-RTShaderSystem: compile error when using double precision
-
-https://ogre3d.atlassian.net/browse/OGRE-592
-
-diff --git a/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp b/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp
---- a/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp
-+++ b/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp
-@@ -654,8 +654,12 @@
- curFuncInvocation->pushOperand(ParameterFactory::createConstParam(Vector4(alphaValue)), Operand::OPS_IN);
- }
- else
-- {
-- curFuncInvocation->pushOperand(ParameterFactory::createConstParam(Vector4(colourValue.ptr())), Operand::OPS_IN);
-+ {
-+ curFuncInvocation->pushOperand(ParameterFactory::createConstParam(Vector4((Real)colourValue.r,
-+ (Real)colourValue.g,
-+ (Real)colourValue.b,
-+ (Real)colourValue.a)),
-+ Operand::OPS_IN);
- }
-
- curFuncInvocation->pushOperand(arg, Operand::OPS_OUT);
diff --git a/dev-games/ogre/metadata.xml b/dev-games/ogre/metadata.xml
index e1f1179..bb9a9d2 100644
--- a/dev-games/ogre/metadata.xml
+++ b/dev-games/ogre/metadata.xml
@@ -77,15 +77,19 @@ Exporters
* Maya (meshes)
</longdescription>
<use>
+ <flag name="beta-components">Build BETA components 'Bites' and 'HLMS'</flag>
<flag name="cg">NVIDIA toolkit plugin</flag>
- <flag name="double-precision">more precise calculations at the expense of speed</flag>
- <flag name="freeimage">support images via freeimage</flag>
+ <flag name="double-precision">More precise calculations at the expense of speed</flag>
+ <flag name="freeimage">Support images via freeimage</flag>
<flag name="gl3plus">Build OpenGL 3+ RenderSystem (EXPERIMENTAL)</flag>
- <flag name="gles2">build OpenGL ES 2.x RenderSystem</flag>
+ <flag name="gles2">Build OpenGL ES 2.x RenderSystem</flag>
<flag name="gles3">Enable OpenGL ES 3.x Features</flag>
<flag name="json">Use dev-libs/rapidjson (needed by Hlms JSON materials)</flag>
- <flag name="ois">pull in Object-oriented Input System library for samples</flag>
- <flag name="tools">build+install helper tools</flag>
+ <flag name="ois">Pull in Object-oriented Input System library for samples</flag>
+ <flag name="resman-legacy">Resource Manager LEGACY : search in all groups twice - for case sensitive and insensitive lookup.</flag>
+ <flag name="resman-pedantic">Resource Manager PEDANTIC : require an explicit resource group. Case sensitive lookup.</flag>
+ <flag name="resman-strict">Resource Manager STRICT : search in default group if not specified otherwise. Case sensitive lookup.</flag>
+ <flag name="tools">Build and install helper tools</flag>
</use>
<upstream>
<remote-id type="bitbucket">sinbad/ogre</remote-id>
diff --git a/dev-games/ogre/ogre-1.10.12.ebuild b/dev-games/ogre/ogre-1.10.12.ebuild
index 3094851..5c4f4ed 100644
--- a/dev-games/ogre/ogre-1.10.12.ebuild
+++ b/dev-games/ogre/ogre-1.10.12.ebuild
@@ -13,11 +13,15 @@ LICENSE="MIT public-domain"
SLOT="0/1.10.0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="cg doc double-precision examples +freeimage gl3plus gles2 gles3 ois +opengl profile tools"
+IUSE="beta-components cg doc double-precision egl examples +freeimage gles2 ois +opengl profile resman-legacy resman-pedantic resman-strict tools"
-REQUIRED_USE="examples? ( ois )
- gles3? ( gles2 )
- gl3plus? ( opengl )"
+REQUIRED_USE="
+ || ( gles2 opengl )
+ ^^ ( resman-legacy resman-pedantic resman-strict )
+ examples? (
+ beta-components
+ ois
+ )"
RESTRICT="test" #139905
@@ -26,28 +30,25 @@ RDEPEND="
dev-libs/zziplib
media-libs/freetype:2
virtual/glu
- virtual/opengl
+ opengl? ( virtual/opengl )
x11-libs/libX11
x11-libs/libXaw
x11-libs/libXrandr
x11-libs/libXt
cg? ( media-gfx/nvidia-cg-toolkit )
+ egl? ( media-libs/mesa[egl] )
freeimage? ( media-libs/freeimage )
- gl3plus? ( >=media-libs/mesa-9.2.5 )
- gles2? ( >=media-libs/mesa-9.0.0[gles2] )
- gles3? ( >=media-libs/mesa-10.0.0[gles2] )
- ois? ( dev-games/ois )
- tools? ( dev-libs/tinyxml[stl] )"
+ gles2? ( media-libs/mesa[gles2] )
+ ois? ( dev-games/ois )"
DEPEND="${RDEPEND}
virtual/pkgconfig
x11-base/xorg-proto
doc? ( app-doc/doxygen )"
PATCHES=(
- "${FILESDIR}/${P}-samples.patch"
- "${FILESDIR}/${P}-resource_path.patch"
- "${FILESDIR}/${P}-media_path.patch"
- "${FILESDIR}/${P}-fix_double_precision-88f0d5b.patch"
+ "${FILESDIR}/${PN}-1.10.11-samples.patch"
+ "${FILESDIR}/${PN}-1.10.11-resource_path.patch"
+ "${FILESDIR}/${PN}-1.10.11-media_path.patch"
)
src_prepare() {
@@ -72,25 +73,33 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- -DOGRE_BUILD_COMPONENT_JAVA=NO
- -DOGRE_BUILD_COMPONENT_PYTHON=NO
- -DOGRE_BUILD_DEPENDENCIES=NO
+ -DOGRE_BUILD_COMPONENT_BITES=$(usex beta-components)
+ -DOGRE_BUILD_COMPONENT_HLMS=$(usex beta-components)
+ -DOGRE_BUILD_COMPONENT_JAVA=no
+ -DOGRE_BUILD_COMPONENT_PYTHON=no
+ -DOGRE_BUILD_DEPENDENCIES=no
-DOGRE_BUILD_PLUGIN_CG=$(usex cg)
+ -DOGRE_BUILD_RENDERSYSTEM_GL=$(usex opengl)
+ -DOGRE_BUILD_RENDERSYSTEM_GL3PLUS=$(usex opengl)
+ -DOGRE_BUILD_RENDERSYSTEM_GLES2=$(usex gles2)
-DOGRE_BUILD_SAMPLES=$(usex examples)
- -DOGRE_BUILD_TESTS=FALSE
+ -DOGRE_BUILD_TESTS=no
-DOGRE_BUILD_TOOLS=$(usex tools)
-DOGRE_CONFIG_DOUBLE=$(usex double-precision)
-DOGRE_CONFIG_ENABLE_FREEIMAGE=$(usex freeimage)
-DOGRE_CONFIG_THREADS=3
-DOGRE_CONFIG_THREAD_PROVIDER=std
- -DOGRE_FULL_RPATH=NO
+ -DOGRE_FULL_RPATH=no
+ -DOGRE_GLSUPPORT_USE_EGL=$(usex egl)
-DOGRE_INSTALL_DOCS=$(usex doc)
-DOGRE_INSTALL_SAMPLES=$(usex examples)
-DOGRE_INSTALL_SAMPLES_SOURCE=$(usex examples)
- -DOGRE_NODE_STORAGE_LEGACY=NO
+ -DOGRE_NODE_STORAGE_LEGACY=no
-DOGRE_PROFILING=$(usex profile)
- -DOGRE_RESOURCEMANAGER_STRICT=strict
- -DOGRE_USE_STD11=YES
+ -DOGRE_RESOURCEMANAGER_STRICT=$(\
+ usex resman-pedantic 1 $(\
+ usex resman-strict 2 0))
+ -DOGRE_USE_STD11=yes
)
cmake-utils_src_configure