summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2018-04-08 15:40:07 +0200
committerSven Eden <sven.eden@gmx.de>2018-04-08 15:40:07 +0200
commit46adc54db0443dc5c9e9b18d3d18e000ec882704 (patch)
tree98171359423c7c937133c3f3abece837ee070b46 /dev-games
parentdev-games/ogre: Fixed subslot on v1.11 ebuild, and updated the v2.1 ebuild to... (diff)
downloadseden-46adc54db0443dc5c9e9b18d3d18e000ec882704.tar.gz
seden-46adc54db0443dc5c9e9b18d3d18e000ec882704.tar.bz2
seden-46adc54db0443dc5c9e9b18d3d18e000ec882704.zip
dev-games/ogre-2.1: Fix sample installation
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ogre/files/ogre-2.1-samples.patch13
-rw-r--r--dev-games/ogre/ogre-2.1-r20180329.ebuild11
2 files changed, 20 insertions, 4 deletions
diff --git a/dev-games/ogre/files/ogre-2.1-samples.patch b/dev-games/ogre/files/ogre-2.1-samples.patch
index 71cbea6..6d12fb4 100644
--- a/dev-games/ogre/files/ogre-2.1-samples.patch
+++ b/dev-games/ogre/files/ogre-2.1-samples.patch
@@ -11,3 +11,16 @@
# Add android JNI binding
if(ANDROID AND OGRE_BUILD_ANDROID_JNI_SAMPLE)
+--- a/CMake/InstallResources.cmake 2018-04-06 19:18:45.095348540 +0200
++++ b/CMake/InstallResources.cmake 2018-04-06 19:20:00.342345608 +0200
+@@ -62,8 +62,8 @@
+ set(OGRE_TEST_MEDIA_DIR_DBG "${CMAKE_INSTALL_PREFIX}/Tests/Media")
+ set(OGRE_PLUGIN_DIR_REL "${CMAKE_INSTALL_PREFIX}/${OGRE_LIB_DIRECTORY}/OGRE")
+ set(OGRE_PLUGIN_DIR_DBG "${CMAKE_INSTALL_PREFIX}/${OGRE_LIB_DIRECTORY}/OGRE")
+- set(OGRE_SAMPLES_DIR_REL "${CMAKE_INSTALL_PREFIX}/${OGRE_LIB_DIRECTORY}/OGRE/Samples")
+- set(OGRE_SAMPLES_DIR_DBG "${CMAKE_INSTALL_PREFIX}/${OGRE_LIB_DIRECTORY}/OGRE/Samples")
++ set(OGRE_SAMPLES_DIR_REL "${CMAKE_INSTALL_PREFIX}/share/OGRE/Samples")
++ set(OGRE_SAMPLES_DIR_DBG "${CMAKE_INSTALL_PREFIX}/share/OGRE/Samples")
+ set(OGRE_CFG_INSTALL_PATH "share/OGRE")
+ endif ()
+
diff --git a/dev-games/ogre/ogre-2.1-r20180329.ebuild b/dev-games/ogre/ogre-2.1-r20180329.ebuild
index fac8c8c..c81772d 100644
--- a/dev-games/ogre/ogre-2.1-r20180329.ebuild
+++ b/dev-games/ogre/ogre-2.1-r20180329.ebuild
@@ -124,8 +124,11 @@ src_install() {
dosym "${CONFIGDIR}"/resources.cfg "${SHAREDIR}"/resources.cfg
dosym "${CONFIGDIR}"/resources2.cfg "${SHAREDIR}"/resources2.cfg
- # These are only for the sample browser
- insinto "${SHAREDIR}"
-# doins "${CMAKE_BUILD_DIR}"/bin/quakemap.cfg
- doins "${CMAKE_BUILD_DIR}"/bin/samples.cfg
+ # These are only for the Samples
+ if use examples ; then
+ insinto "${SHAREDIR}"
+ doins "${CMAKE_BUILD_DIR}"/bin/samples.cfg
+ # The build system currently "forgets" to install these
+ doins -r "${CMAKE_BUILD_DIR}"/Samples
+ fi
}