summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2011-06-26 19:35:34 +0200
committerSven Eden <sven.eden@gmx.de>2011-06-26 19:35:34 +0200
commit44f920a51e14f67cae8ba3c99938126ba0a37d7d (patch)
tree393f2af0d43f72b5bc6ecbff58e34473fa8ce429 /games-strategy
parentNo longer neccessary, the patch is officialy tested in vmware overlay. *Hurra... (diff)
downloadseden-44f920a51e14f67cae8ba3c99938126ba0a37d7d.tar.gz
seden-44f920a51e14f67cae8ba3c99938126ba0a37d7d.tar.bz2
seden-44f920a51e14f67cae8ba3c99938126ba0a37d7d.zip
freeorion no longer compiles against boost <1.46
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeorion/ChangeLog6
-rw-r--r--games-strategy/freeorion/Manifest3
-rw-r--r--games-strategy/freeorion/freeorion-9999-r6.ebuild105
3 files changed, 113 insertions, 1 deletions
diff --git a/games-strategy/freeorion/ChangeLog b/games-strategy/freeorion/ChangeLog
index ae2ba8f..1d4b97a 100644
--- a/games-strategy/freeorion/ChangeLog
+++ b/games-strategy/freeorion/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*freeorion-9999-r6 (26 Jun 2011)
+
+ 26 Jun 2011; Sven Eden <sven.eden@gmx.de> +freeorion-9999-r6.ebuild :
+ - xml Use-Flag no longer needed
+ - FreeOrion no longer compiles against boost <1.46
+
*freeorion-9999-r5 (27 Mar 2011)
27 Mar 2011; Sven Eden <sven.eden@gmx.de> +freeorion-9999-r5.ebuild :
diff --git a/games-strategy/freeorion/Manifest b/games-strategy/freeorion/Manifest
index fdb777a..6e56282 100644
--- a/games-strategy/freeorion/Manifest
+++ b/games-strategy/freeorion/Manifest
@@ -1,3 +1,4 @@
EBUILD freeorion-9999-r5.ebuild 2829 RMD160 ddbb4bb5ac6b03e36dbcbe8fba9f489d3286cbd8 SHA1 dbdd4eb8e819b9262ae145155e481a3794645a3b SHA256 4a550b9a6a11c38f58e26030c45ae9d6093e65b8d94b13feec321548933fe566
-MISC ChangeLog 263 RMD160 a660340eb32fb385e9e81cf57355f938ba542455 SHA1 114a9c739072f2417238177b69264a55f00d5cf1 SHA256 82618dc1d05ec2d63ae49a4c9d30d231b29fa2e76064d4a3e2c1d699384f0a17
+EBUILD freeorion-9999-r6.ebuild 2825 RMD160 f6291e38ccc0842645af72c89d3088760b8154a3 SHA1 b6b167c596f14faabb3806455e6d3944c3be5beb SHA256 8183e27d96ff0fee3df1f47afc36c217d489422fbd07781297e8abb2c3c2b1c7
+MISC ChangeLog 457 RMD160 8e6b1257fd95f0c88b390ddead71014792ce2eca SHA1 55e562f9aba1ebc9bd540b1a82ce4bad0820875c SHA256 ec8426df7c83758b8434bfafead74fc096be17aa2b78fac3055f4df03ac0df4d
MISC metadata.xml 482 RMD160 4d1a06c8b3833acbcf43d0b56a0c0ff3ba938fde SHA1 fdcead5b8dc226ee4bc44e19642fdec006831c2d SHA256 d440736d71b8eaac1b5a2a5171274171e7b5bbbcc6d4b8d2c14fd37c36e51a96
diff --git a/games-strategy/freeorion/freeorion-9999-r6.ebuild b/games-strategy/freeorion/freeorion-9999-r6.ebuild
new file mode 100644
index 0000000..589a054
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-9999-r6.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit cmake-utils games subversion
+
+DESCRIPTION="FreeOrion is a free and open source clone of Master Of Orion"
+HOMEPAGE="http://www.freeorion.org"
+ESVN_REPO_URI="https://${PN}.svn.sourceforge.net/svnroot/${PN}/trunk"
+ESVN_PROJECT="${PN}"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0"
+KEYWORDS="~amd64 ~x86"
+# IUSE="cg debug threads xml"
+IUSE="cg debug threads"
+
+SLOT="0"
+
+RDEPEND="
+ dev-games/gigi[ogre,threads=]
+ || ( threads? ( >=dev-games/ogre-1.7.1[boost,cg=,boost-threads] )
+ !threads? ( >=dev-games/ogre-1.7.1[boost,cg=,-boost-threads] )
+ )
+ <dev-lang/python-3
+ dev-libs/boost:1.46
+ media-gfx/graphviz
+ media-libs/freealut
+ >=media-libs/libogg-1.1.3
+ >=media-libs/libsdl-1.2
+ >=media-libs/libvorbis-1.1.2
+ media-libs/openal
+ sci-physics/bullet
+ sys-devel/libtool
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+CMAKE_USE_DIR="${S}/FreeOrion"
+
+src_prepare() {
+ # Let's make the autorevision work.
+ subversion_wc_info
+ sed -i -e \
+ "s:svn_revision_number ???:svn_revision_number ${ESVN_WC_REVISION}:" \
+ FreeOrion/CMakeLists.txt || die "sed FreeOrion/CMakeLists.txt failed"
+}
+
+src_configure() {
+ # Due to the testing nature of gigi and freeorion,
+ # and all the ogre+boost stuff, flags should be filtered:
+ strip-flags
+
+ # Type-Pun pointers always break strict aliasing rules,
+ # and this thing is full of those
+ append-flags -fno-strict-aliasing
+
+ # using xml serialization seems to break on linker level with
+ # boost-1.45. For this the new xml USE flag will switch to
+ # binary archives if -xml is used:
+# use xml || sed -i -e \
+# "s:define FREEORION_BINARY_SERIALIZATION 0:define FREEORION_BINARY_SERIALIZATION 1:" \
+# FreeOrion/util/Serialize.h || die "sed FreeOrion/util/Serialize.h failed"
+
+ local mycmakeargs+=(
+ $(cmake-utils_use_enable debug DEBUG)
+ $(cmake-utils_use_build debug DEBUG)
+ )
+
+ mycmakeargs+=(
+ "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}/${PN}"
+ "-DCMAKE_INSTALL_ICONDIR=${GAMES_DATADIR_BASE}/pixmaps/"
+ "-DCMAKE_INSTALL_DESKTOPDIR=${GAMES_DATADIR_BASE}/applications/"
+ "-DCMAKE_DOC_DIR=/usr/share/doc/${PF}"
+ "-DCMAKE_MAN_DIR=/usr/share/man"
+ "-DCMAKE_DATA_DIR=${GAMES_DATADIR}"
+ "-DCMAKE_DATA_PATH=${GAMES_DATADIR}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ ## This is a rather wild thing, but I can't think of a quicker way right now:
+ # Add ogre_plugins config:
+
+ OGRECFG="${D}/${GAMES_PREFIX}/${PN}/ogre_plugins.cfg"
+ cat > ${OGRECFG} <<EOF
+# Plugin folder
+PluginFolder=/usr/lib64/OGRE
+# Plugins
+Plugin=RenderSystem_GL
+Plugin=Plugin_ParticleFX
+Plugin=Plugin_OctreeSceneManager
+EOF
+
+ ## Extra-Plugin with cg enabled:
+ use cg && echo "Plugin=Plugin_CgProgramManager" >> ${OGRECFG}
+
+ prepgamesdirs
+}