summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2018-04-23 18:52:16 +0200
committerSven Eden <sven.eden@gmx.de>2018-04-23 18:52:16 +0200
commit823cd33654a667653c0b9729789d9199a3ebb93b (patch)
tree892aa975278ffdc273718933ab78ae919e910699 /sys-auth/elogind
parentdev-games/ogre-2.1: Fix sample installation (diff)
downloadseden-823cd33654a667653c0b9729789d9199a3ebb93b.tar.gz
seden-823cd33654a667653c0b9729789d9199a3ebb93b.tar.bz2
seden-823cd33654a667653c0b9729789d9199a3ebb93b.zip
sys-auth/elogind : Only provide live ebuilds for the latest two stable branches.
Diffstat (limited to 'sys-auth/elogind')
-rw-r--r--sys-auth/elogind/elogind-233.7.ebuild109
-rw-r--r--sys-auth/elogind/elogind-235.9999.ebuild (renamed from sys-auth/elogind/elogind-9999.ebuild)84
-rw-r--r--sys-auth/elogind/elogind-236.9999.ebuild (renamed from sys-auth/elogind/elogind-235.1.ebuild)78
-rw-r--r--sys-auth/elogind/files/elogind-226.4-docs.patch15
-rw-r--r--sys-auth/elogind/files/elogind-236.1-docs.patch24
5 files changed, 101 insertions, 209 deletions
diff --git a/sys-auth/elogind/elogind-233.7.ebuild b/sys-auth/elogind/elogind-233.7.ebuild
deleted file mode 100644
index ba00b1f..0000000
--- a/sys-auth/elogind/elogind-233.7.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools linux-info pam udev xdg-utils
-
-DESCRIPTION="The systemd project's logind, extracted to a standalone package"
-HOMEPAGE="https://github.com/elogind/elogind"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="acl debug pam policykit selinux"
-
-COMMON_DEPEND="
- sys-apps/util-linux
- sys-libs/libcap
- virtual/libudev:=
- acl? ( sys-apps/acl )
- pam? ( virtual/pam )
- selinux? ( sys-libs/libselinux )
-"
-DEPEND="${COMMON_DEPEND}
- app-text/docbook-xml-dtd:4.2
- app-text/docbook-xml-dtd:4.5
- app-text/docbook-xsl-stylesheets
- dev-util/gperf
- dev-util/intltool
- sys-devel/libtool
- virtual/pkgconfig
-"
-RDEPEND="${COMMON_DEPEND}
- !sys-apps/systemd
- <sys-libs/glibc-2.26
-"
-PDEPEND="
- sys-apps/dbus
- policykit? ( sys-auth/polkit )
-"
-
-PATCHES=( "${FILESDIR}/${PN}-226.4-docs.patch" )
-
-pkg_setup() {
- local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
-
- if use kernel_linux; then
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- default
- eautoreconf # Makefile.am patched by "${FILESDIR}/${P}-docs.patch"
- xdg_environment_reset
-}
-
-src_configure() {
- econf \
- --with-pamlibdir=$(getpam_mod_dir) \
- --with-udevrulesdir="$(get_udevdir)"/rules.d \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --with-rootlibdir="${EPREFIX}"/$(get_libdir) \
- --with-rootprefix="${EPREFIX}/" \
- --with-rootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind \
- --enable-smack \
- --with-cgroup-controller=openrc \
- --disable-lto \
- --without-kill-user-processes \
- $(use_enable debug debug elogind) \
- $(use_enable acl) \
- $(use_enable pam) \
- $(use_enable selinux)
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-
- newinitd "${FILESDIR}"/${PN}.init ${PN}
-
- sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
- newconfd ${PN}.conf ${PN}
-}
-
-pkg_postinst() {
- if [ "$(rc-config list boot | grep elogind)" != "" ]; then
- ewarn "elogind is currently started from boot runlevel."
- elif [ "$(rc-config list default | grep elogind)" != "" ]; then
- ewarn "elogind is currently started from default runlevel."
- ewarn "Please remove elogind from the default runlevel and"
- ewarn "add it to the boot runlevel by:"
- ewarn "# rc-update del elogind default"
- ewarn "# rc-update add elogind boot"
- else
- ewarn "elogind is currently not started from any runlevel."
- ewarn "You may add it to the boot runlevel by:"
- ewarn "# rc-update add elogind boot"
- fi
- ewarn "Alternatively you can leave elogind out of any"
- ewarn "runlevel. It will then be started automatically"
- if use pam; then
- ewarn "when the first service calls it via dbus, or the"
- ewarn "first user logs into the system."
- else
- ewarn "when the first service calls it via dbus."
- fi
-}
diff --git a/sys-auth/elogind/elogind-9999.ebuild b/sys-auth/elogind/elogind-235.9999.ebuild
index bc5bfca..9d628f5 100644
--- a/sys-auth/elogind/elogind-9999.ebuild
+++ b/sys-auth/elogind/elogind-235.9999.ebuild
@@ -8,11 +8,11 @@ inherit git-r3 linux-info meson pam udev xdg-utils
DESCRIPTION="The systemd project's logind, extracted to a standalone package"
HOMEPAGE="https://github.com/elogind/elogind"
EGIT_REPO_URI="https://github.com/elogind/elogind.git"
-EGIT_BRANCH="master"
+EGIT_BRANCH="v235-stable"
LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="amd64 ~arm x86"
IUSE="+acl debug doc +pam +policykit selinux"
COMMON_DEPEND="
@@ -23,14 +23,13 @@ COMMON_DEPEND="
pam? ( virtual/pam )
selinux? ( sys-libs/libselinux )
"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.2
app-text/docbook-xml-dtd:4.5
app-text/docbook-xsl-stylesheets
dev-util/gperf
dev-util/intltool
- >=dev-util/meson-0.41.0
- >=dev-util/ninja-1.7.2
+ sys-devel/libtool
virtual/pkgconfig
"
RDEPEND="${COMMON_DEPEND}
@@ -41,11 +40,12 @@ PDEPEND="
policykit? ( sys-auth/polkit )
"
-PATCHES=( "${FILESDIR}/${PN}-235.1-docs.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-235.1-docs.patch"
+)
pkg_setup() {
- local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SECURITY_SMACK
- ~SIGNALFD ~TIMERFD"
+ local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
if use kernel_linux; then
linux-info_pkg_setup
@@ -58,43 +58,45 @@ src_prepare() {
}
src_configure() {
- local emesonargs cgroupmode rccgroupmode
+ local rccgroupmode="$(grep rc_cgroup_mode /etc/rc.conf | cut -d '"' -f 2)"
+ local cgroupmode="legacy"
- rccgroupmode="$(grep rc_cgroup_mode /etc/rc.conf | cut -d '"' -f 2)"
- cgroupmode="legacy"
-
- if [ "xhybrid" = "x${rccgroupmode}" ] ; then
+ if [[ "xhybrid" = "x${rccgroupmode}" ]] ; then
cgroupmode="hybrid"
- elif [ "xunified" = "x${rccgroupmode}" ] ; then
+ elif [[ "xunified" = "x${rccgroupmode}" ]] ; then
cgroupmode="unified"
fi
- emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${P}" \
- -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html" \
- -Dpamlibdir=$(getpam_mod_dir) \
- -Dudevrulesdir="$(get_udevdir)"/rules.d \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- -Drootlibdir="${EPREFIX}"/$(get_libdir) \
- -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind \
- -Drootprefix="${EPREFIX}/" \
- -Dsmack=true \
- -Dman=auto \
- -Dhtml=$(usex doc auto false) \
- -Dcgroup-controller=openrc \
- -Ddefault-hierarchy=${cgroupmode} \
- -Ddebug=$(usex debug elogind false) \
- --buildtype $(usex debug debug release) \
- -Dacl=$(usex acl true false) \
- -Dpam=$(usex pam true false) \
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ -Dpamlibdir=$(getpam_mod_dir)
+ -Dudevrulesdir="$(get_udevdir)"/rules.d
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ -Drootlibdir="${EPREFIX}"/$(get_libdir)
+ -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind
+ -Drootprefix="${EPREFIX}/"
+ -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions"
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
+ -Dman=auto
+ -Dsmack=true
+ -Dcgroup-controller=openrc
+ -Ddefault-hierarchy=${cgroupmode}
+ -Ddefault-kill-user-processes=false
+ -Dacl=$(usex acl true false)
+ -Ddebug=$(usex debug elogind false)
+ --buildtype $(usex debug debug release)
+ -Dhtml=$(usex doc auto false)
+ -Dpam=$(usex pam true false)
-Dselinux=$(usex selinux true false)
- -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions" \
- -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions" \
)
+
meson_src_configure
}
src_install() {
+ DOCS+=( src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
+
meson_src_install
newinitd "${FILESDIR}"/${PN}.init ${PN}
@@ -104,9 +106,9 @@ src_install() {
}
pkg_postinst() {
- if [ "$(rc-config list boot | grep elogind)" != "" ]; then
- ewarn "elogind is currently started from boot runlevel."
- elif [ "$(rc-config list default | grep elogind)" != "" ]; then
+ if [[ "$(rc-config list boot | grep elogind)" != "" ]]; then
+ elog "elogind is currently started from boot runlevel."
+ elif [[ "$(rc-config list default | grep elogind)" != "" ]]; then
ewarn "elogind is currently started from default runlevel."
ewarn "Please remove elogind from the default runlevel and"
ewarn "add it to the boot runlevel by:"
@@ -117,12 +119,4 @@ pkg_postinst() {
ewarn "You may add it to the boot runlevel by:"
ewarn "# rc-update add elogind boot"
fi
- ewarn "Alternatively you can leave elogind out of any"
- ewarn "runlevel. It will then be started automatically"
- if use pam; then
- ewarn "when the first service calls it via dbus, or the"
- ewarn "first user logs into the system."
- else
- ewarn "when the first service calls it via dbus."
- fi
}
diff --git a/sys-auth/elogind/elogind-235.1.ebuild b/sys-auth/elogind/elogind-236.9999.ebuild
index d6c31d6..8b5a085 100644
--- a/sys-auth/elogind/elogind-235.1.ebuild
+++ b/sys-auth/elogind/elogind-236.9999.ebuild
@@ -3,15 +3,17 @@
EAPI=6
-inherit linux-info meson pam udev xdg-utils
+inherit git-r3 linux-info meson pam udev xdg-utils
DESCRIPTION="The systemd project's logind, extracted to a standalone package"
HOMEPAGE="https://github.com/elogind/elogind"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/elogind/elogind.git"
+EGIT_BRANCH="v236-stable"
LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="amd64 ~arm x86"
IUSE="+acl debug doc +pam +policykit selinux"
COMMON_DEPEND="
@@ -39,7 +41,9 @@ PDEPEND="
policykit? ( sys-auth/polkit )
"
-PATCHES=( "${FILESDIR}/${PN}-235.1-docs.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-236.1-docs.patch"
+)
pkg_setup() {
local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SIGNALFD ~TIMERFD"
@@ -55,43 +59,45 @@ src_prepare() {
}
src_configure() {
- local emesonargs cgroupmode rccgroupmode
+ local rccgroupmode="$(grep rc_cgroup_mode /etc/rc.conf | cut -d '"' -f 2)"
+ local cgroupmode="legacy"
- rccgroupmode="$(grep rc_cgroup_mode /etc/rc.conf | cut -d '"' -f 2)"
- cgroupmode="legacy"
-
- if [ "xhybrid" = "x${rccgroupmode}" ] ; then
+ if [[ "xhybrid" = "x${rccgroupmode}" ]] ; then
cgroupmode="hybrid"
- elif [ "xunified" = "x${rccgroupmode}" ] ; then
+ elif [[ "xunified" = "x${rccgroupmode}" ]] ; then
cgroupmode="unified"
fi
- emesonargs=(
- -Ddocdir="${EPREFIX}/usr/share/doc/${P}" \
- -Dhtmldir="${EPREFIX}/usr/share/doc/${P}/html" \
- -Dpamlibdir=$(getpam_mod_dir) \
- -Dudevrulesdir="$(get_udevdir)"/rules.d \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- -Drootlibdir="${EPREFIX}"/$(get_libdir) \
- -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind \
- -Drootprefix="${EPREFIX}/" \
- -Dsmack=true \
- -Dman=auto \
- -Dhtml=$(usex doc auto false) \
- -Dcgroup-controller=openrc \
- -Ddefault-hierarchy=${cgroupmode} \
- -Ddebug=$(usex debug elogind false) \
- --buildtype $(usex debug debug release) \
- -Dacl=$(usex acl true false) \
- -Dpam=$(usex pam true false) \
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}/usr/share/doc/${PF}"
+ -Dhtmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ -Dpamlibdir=$(getpam_mod_dir)
+ -Dudevrulesdir="$(get_udevdir)"/rules.d
+ --libdir="${EPREFIX}"/usr/$(get_libdir)
+ -Drootlibdir="${EPREFIX}"/$(get_libdir)
+ -Drootlibexecdir="${EPREFIX}"/$(get_libdir)/elogind
+ -Drootprefix="${EPREFIX}/"
+ -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions"
+ -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions"
+ -Dman=auto
+ -Dsmack=true
+ -Dcgroup-controller=openrc
+ -Ddefault-hierarchy=${cgroupmode}
+ -Ddefault-kill-user-processes=false
+ -Dacl=$(usex acl true false)
+ -Ddebug=$(usex debug elogind false)
+ --buildtype $(usex debug debug release)
+ -Dhtml=$(usex doc auto false)
+ -Dpam=$(usex pam true false)
-Dselinux=$(usex selinux true false)
- -Dbashcompletiondir="${EPREFIX}/usr/share/bash-completion/completions" \
- -Dzsh-completion="${EPREFIX}/usr/share/zsh/site-functions" \
)
+
meson_src_configure
}
src_install() {
+ DOCS+=( src/libelogind/sd-bus/GVARIANT-SERIALIZATION )
+
meson_src_install
newinitd "${FILESDIR}"/${PN}.init ${PN}
@@ -101,9 +107,9 @@ src_install() {
}
pkg_postinst() {
- if [ "$(rc-config list boot | grep elogind)" != "" ]; then
- ewarn "elogind is currently started from boot runlevel."
- elif [ "$(rc-config list default | grep elogind)" != "" ]; then
+ if [[ "$(rc-config list boot | grep elogind)" != "" ]]; then
+ elog "elogind is currently started from boot runlevel."
+ elif [[ "$(rc-config list default | grep elogind)" != "" ]]; then
ewarn "elogind is currently started from default runlevel."
ewarn "Please remove elogind from the default runlevel and"
ewarn "add it to the boot runlevel by:"
@@ -114,12 +120,4 @@ pkg_postinst() {
ewarn "You may add it to the boot runlevel by:"
ewarn "# rc-update add elogind boot"
fi
- ewarn "Alternatively you can leave elogind out of any"
- ewarn "runlevel. It will then be started automatically"
- if use pam; then
- ewarn "when the first service calls it via dbus, or the"
- ewarn "first user logs into the system."
- else
- ewarn "when the first service calls it via dbus."
- fi
}
diff --git a/sys-auth/elogind/files/elogind-226.4-docs.patch b/sys-auth/elogind/files/elogind-226.4-docs.patch
deleted file mode 100644
index 4161f63..0000000
--- a/sys-auth/elogind/files/elogind-226.4-docs.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/Makefile.am 2017-02-16 13:22:56.764985896 +0100
-+++ b/Makefile.am 2017-02-16 13:23:04.998986057 +0100
-@@ -194,12 +194,6 @@
- bin_PROGRAMS =
- rootlibexec_PROGRAMS =
-
--dist_doc_DATA = \
-- README \
-- NEWS \
-- LICENSE.LGPL2.1 \
-- LICENSE.GPL2
--
- @INTLTOOL_POLICY_RULE@
-
- # ------------------------------------------------------------------------------
diff --git a/sys-auth/elogind/files/elogind-236.1-docs.patch b/sys-auth/elogind/files/elogind-236.1-docs.patch
new file mode 100644
index 0000000..46c6fa9
--- /dev/null
+++ b/sys-auth/elogind/files/elogind-236.1-docs.patch
@@ -0,0 +1,24 @@
+--- a/meson.build 2018-04-20 17:19:23.912940283 +0200
++++ b/meson.build 2018-04-20 17:20:02.265941434 +0200
+@@ -2800,20 +2800,7 @@
+ # install_data('modprobe.d/systemd.conf',
+ # install_dir : modprobedir)
+ #endif // 0
+-install_data('README',
+- 'NEWS',
+- 'CODING_STYLE',
+-#if 0 /// UNNEEDED by elogind
+-# 'DISTRO_PORTING',
+-# 'ENVIRONMENT.md',
+-#endif // 0
+- 'LICENSE.GPL2',
+- 'LICENSE.LGPL2.1',
+- 'src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
+-#if 0 /// UNNEEDED by elogind
+-# 'TRANSIENT-SETTINGS.md',
+-# 'UIDS-GIDS.md',
+-#endif // 0
++install_data('src/libelogind/sd-bus/GVARIANT-SERIALIZATION',
+ install_dir : docdir)
+
+ #if 0 /// UNNEEDED by elogind