summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <sven.eden@gmx.de>2017-04-08 14:53:42 +0200
committerSven Eden <sven.eden@gmx.de>2017-04-08 14:53:42 +0200
commit302b71461d7025d1b6cdf0cc242e937cb6c3b546 (patch)
tree14ddbd1b907a1a9762108e6df89fac35e46b9445 /sys-auth
parentmedia-video/avidemux-2.6.19 : Version bump (diff)
downloadseden-302b71461d7025d1b6cdf0cc242e937cb6c3b546.tar.gz
seden-302b71461d7025d1b6cdf0cc242e937cb6c3b546.tar.bz2
seden-302b71461d7025d1b6cdf0cc242e937cb6c3b546.zip
sys-auth/elogind-227.9999 : Live ebuild vor dev_v228 branch
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/elogind/elogind-227.9999.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/sys-auth/elogind/elogind-227.9999.ebuild b/sys-auth/elogind/elogind-227.9999.ebuild
new file mode 100644
index 0000000..aa57f31
--- /dev/null
+++ b/sys-auth/elogind/elogind-227.9999.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools git-r3 linux-info pam udev
+
+DESCRIPTION="The systemd project's logind, extracted to a standalone package"
+HOMEPAGE="https://github.com/elogind/elogind"
+EGIT_REPO_URI="https://github.com/elogind/elogind.git"
+EGIT_BRANCH="dev_v228"
+
+LICENSE="CC0-1.0 LGPL-2.1+ public-domain"
+SLOT="0"
+KEYWORDS=""
+IUSE="acl debug pam policykit selinux"
+
+COMMON_DEPEND="
+ sys-apps/util-linux
+ sys-libs/libcap
+ virtual/libudev:=
+ acl? ( sys-apps/acl )
+ pam? ( virtual/pam )
+ selinux? ( sys-libs/libselinux )
+"
+RDEPEND="${COMMON_DEPEND}
+ sys-apps/dbus
+ !sys-apps/systemd
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xml-dtd:4.5
+ app-text/docbook-xsl-stylesheets
+ dev-util/gperf
+ dev-util/intltool
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+PDEPEND="policykit? ( sys-auth/polkit )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-docs.patch"
+)
+
+pkg_setup() {
+ local CONFIG_CHECK="~CGROUPS ~EPOLL ~INOTIFY_USER ~SECURITY_SMACK
+ ~SIGNALFD ~TIMERFD"
+
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf # Makefile.am patched by "${FILESDIR}/${P}-docs.patch"
+}
+
+src_configure() {
+ econf \
+ --with-pamlibdir=$(getpam_mod_dir) \
+ --with-udevrulesdir="$(get_udevdir)"/rules.d \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --with-rootlibdir="${EPREFIX}"/$(get_libdir) \
+ --enable-smack \
+ --disable-kdbus \
+ $(use_enable debug debug elogind) \
+ $(use_enable acl) \
+ $(use_enable pam) \
+ $(use_enable selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+}
+
+pkg_postinst() {
+ if [ "$(rc-config list default | grep elogind)" = "" ]; then
+ ewarn "To enable the elogind daemon, elogind must be"
+ ewarn "added to the default runlevel:"
+ ewarn "# rc-update add elogind default"
+ fi
+}