summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/telepathy-morse/telepathy-morse-9999.ebuild')
-rw-r--r--net-im/telepathy-morse/telepathy-morse-9999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-im/telepathy-morse/telepathy-morse-9999.ebuild b/net-im/telepathy-morse/telepathy-morse-9999.ebuild
new file mode 100644
index 0000000..7f560fd
--- /dev/null
+++ b/net-im/telepathy-morse/telepathy-morse-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="Telegram connection manager for Telepathy."
+HOMEPAGE="https://projects.kde.org/projects/playground/network/telepathy/telepathy-morse"
+EGIT_REPO_URI=( "git://anongit.kde.org/telepathy-morse" )
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ net-libs/telegram-qt
+ >=net-libs/telepathy-qt-0.9.6.0
+"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.8.12
+"
+
+DOCS=( LICENSE.LGPL README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=OFF
+ -DENABLE_TESTAPP=OFF
+ -DENABLE_EXAMPLES=OFF
+ -DDESIRED_QT_VERSION=5
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}